summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-14 02:01:20 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-14 02:01:20 +0000
commitb9cbe56abd28fd53e5a2a42696a8a8655d203d18 (patch)
tree7669b5858e3f2050ceec4dab9d3c687d5b6592dc /net-mail
parentversion bump (diff)
downloadhistorical-b9cbe56abd28fd53e5a2a42696a8a8655d203d18.tar.gz
historical-b9cbe56abd28fd53e5a2a42696a8a8655d203d18.tar.bz2
historical-b9cbe56abd28fd53e5a2a42696a8a8655d203d18.zip
new version. masked because its a unstable release.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/ChangeLog10
-rw-r--r--net-mail/evolution/evolution-1.3.1.ebuild184
-rw-r--r--net-mail/evolution/files/digest-evolution-1.3.12
3 files changed, 195 insertions, 1 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index 665a2e01419e..84b578410a56 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/evolution
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.44 2003/03/09 14:58:21 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.45 2003/03/14 02:01:20 liquidx Exp $
+
+*evolution-1.3.1 (14 Mar 2003)
+
+ 14 Mar 2003; Alastair Tse <liquidx@gentoo.org> evolution-1.3.1.ebuild:
+ version bump to gtk2 _beta_ evolution. this version can co-exist with
+ evolution 1.2.x, but you must NOT run them at the same time. currently masked
+ because not everyone wants to break their mail clients ;)
+ Remember, this is an unstable release!
17 Feb 2003; foser <foser@gentoo.org> evolution-1.[2.0-r1,0.8,2.1,2.2].ebuild :
Fixed db source uri (#15839)
diff --git a/net-mail/evolution/evolution-1.3.1.ebuild b/net-mail/evolution/evolution-1.3.1.ebuild
new file mode 100644
index 000000000000..5c5ba3dd10ef
--- /dev/null
+++ b/net-mail/evolution/evolution-1.3.1.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.3.1.ebuild,v 1.1 2003/03/14 02:01:20 liquidx Exp $
+
+IUSE="ssl mozilla ldap doc spell pda ipv6 kerberos"
+
+inherit eutils flag-o-matic gnome.org libtool virtualx gnome2
+
+DB3="db-3.1.17"
+S="${WORKDIR}/${P}"
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.ximian.com/pub/ximian-evolution-beta/source/${P}.tar.gz
+ http://www.sleepycat.com/update/snapshot/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+
+SLOT="2" # can co-exist with evolution <= 1.2
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+RDEPEND=">=gnome-extra/gtkhtml-3.0.1
+ >=gnome-base/ORBit2-2.6.0
+ >=gnome-base/libbonoboui-2.0
+ >=gnome-base/gnome-vfs-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnome-2.0
+ >=gnome-base/bonobo-activation-2.2.1
+ >=dev-libs/libxml2-2.5
+ >=gnome-base/gconf-2.0
+ >=gnome-extra/gal-1.99.2
+ >=net-libs/libsoup-1.99.12
+ >=gnome-base/libgnomecanvas-2.2.0.2
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libgnomeprint-2.2
+ doc? ( >=app-text/scrollkeeper-0.3.10-r1 )
+ ssl? ( mozilla? ( >=net-www/mozilla-0.9.9 ) : ( >=dev-libs/openssl-0.9.5 ) )
+ ldap? ( >=net-nds/openldap-2.0 )
+ pda? ( >=gnome-extra/gnome-pilot-2.0.1
+ >=dev-libs/pilot-link-0.11.7
+ >=gnome-extra/gnome-pilot-conduits-2.0.1 )
+ kerberos? ( >=app-crypt/krb5-1.2.5 )
+ spell? ( >=app-text/gnome-spell-1.0.1 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4.1-r1
+ >=dev-util/intltool-0.20
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+
+ # *************************************************************
+ #
+ # DB3 compile...
+ #
+ # *************************************************************
+
+ # Rather ugly hack to make sure pthread mutex support are not enabled ...
+ cd ${WORKDIR}/${DB3}/dist
+ einfo "Compiling DB3..."
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+
+ if [ "`egrep "^LIBS=[[:space:]]*-lpthread" Makefile`" ]
+ then
+ append-flags "-pthread"
+ fi
+
+ make || die
+ make prefix=${WORKDIR}/db3 install || die
+
+ # *************************************************************
+ #
+ # Evolution compile...
+ #
+ # *************************************************************
+
+ einfo "Compiling Evolution..."
+ cd ${S}
+
+ local myconf=""
+ local MOZILLA="${MOZILLA_FIVE_HOME}"
+
+ if [ -n "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+ if [ -n "`use ldap`" ] ; then
+ myconf="${myconf} --with-openldap=yes --with-static-ldap=no"
+ else
+ myconf="${myconf} --with-openldap=no"
+ fi
+
+ # Kerberos
+ if [ -n "`use kerberos`" ]; then
+ myconf="${myconf} --with-krb5=/usr"
+ else
+ myconf="${myconf} --without-krb5"
+ fi
+
+
+ # Use Mozilla NSS libs if 'mozilla' *and* 'ssl' in USE
+ if [ -n "`use ssl`" -a -n "`use mozilla`" ] ; then
+ myconf="${myconf} --enable-nss=yes \
+ --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA} \
+ --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ # Else use OpenSSL if 'mozilla' not in USE ...
+ if [ -n "`use ssl`" -a -z "`use mozilla`" ] ; then
+ myconf="${myconf} --enable-openssl=yes"
+ fi
+
+ if [ -n "`use doc`" ] ; then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6=yes"
+ else
+ myconf="${myconf} --enable-ipv6=no"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-db3=${WORKDIR}/db3 \
+ ${myconf} || die
+
+ #needs to be able to connect to X display to build.
+ Xemake || Xmake || die
+}
+
+src_install() {
+
+ # omf docs missing in evo-1.3.1
+ #cd omf-install
+ #cp Makefile Makefile.old
+ #sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ #rm Makefile.old
+
+ # fix kde shortcut (evo-1.3.1)
+ cd ${S}/data
+ cp Makefile Makefile.old
+ sed -e 's,^install-kde-applnk:,install-kde-applnk:\n\t$(mkinstalldirs) $(DESTDIR)$(kdedesktopdir); \\,' Makefile.old > Makefile
+ rm Makefile.old
+
+ cd ${S}
+
+ # Install with $DESTDIR, as in some rare cases $D gets hardcoded
+ # into the binaries (seems like a ccache problem at present),
+ # because everything is recompiled with the "new" PREFIX, if
+ # $DESTDIR is _not_ used.
+ make DESTDIR=${D} \
+ prefix=/usr \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ datadir=/usr/share \
+ sysconfdir=/etc \
+ localstatedir=/var/lib \
+ KDE_APPLNK_DIR=/usr/share/applnk \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+# evo-1.3.1 doesn't seem to have any OMFs
+SCROLLKEEPER_UPDATE="0"
diff --git a/net-mail/evolution/files/digest-evolution-1.3.1 b/net-mail/evolution/files/digest-evolution-1.3.1
new file mode 100644
index 000000000000..0722748e8eff
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.3.1
@@ -0,0 +1,2 @@
+MD5 67597aded27d13c2fcf302e9ac4fc124 evolution-1.3.1.tar.gz 14765398
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117