summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-24 14:54:25 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-24 14:54:25 +0000
commit9fe2a0701a563047fb73644da3f605ec8c03c8b4 (patch)
tree608cbd390d05771be6c0264a977bd9b551f537db /net-mail
parentadded tiff USE flag (diff)
downloadhistorical-9fe2a0701a563047fb73644da3f605ec8c03c8b4.tar.gz
historical-9fe2a0701a563047fb73644da3f605ec8c03c8b4.tar.bz2
historical-9fe2a0701a563047fb73644da3f605ec8c03c8b4.zip
new version, and a new revision with fixed bugs
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/balsa/ChangeLog8
-rw-r--r--net-mail/balsa/balsa-1.2.4-r1.ebuild61
-rw-r--r--net-mail/balsa/balsa-1.3.4.ebuild60
-rw-r--r--net-mail/balsa/files/balsa-1.2.4.diff12
-rw-r--r--net-mail/balsa/files/balsa-1.3.4.diff12
-rw-r--r--net-mail/balsa/files/digest-balsa-1.2.4-r11
-rw-r--r--net-mail/balsa/files/digest-balsa-1.3.41
7 files changed, 154 insertions, 1 deletions
diff --git a/net-mail/balsa/ChangeLog b/net-mail/balsa/ChangeLog
index 4bbfdda7c46f..1937a7119b34 100644
--- a/net-mail/balsa/ChangeLog
+++ b/net-mail/balsa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/balsa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.3 2002/04/12 18:48:20 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.4 2002/04/24 14:54:25 spider Exp $
+
+
+*balsa-1.2.4-r1 (24 Apr 2002)
+ 24 Apr 2002; Spider <spider@gentoo.org> balsa-1.2.4-r1.ebuild balsa-1.3.4.ebuild
+ update with a patch to make it compile with spellchecking
+ add development series per request
*balsa-1.2.4 (11 Apr 2002)
diff --git a/net-mail/balsa/balsa-1.2.4-r1.ebuild b/net-mail/balsa/balsa-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..831467805b02
--- /dev/null
+++ b/net-mail/balsa/balsa-1.2.4-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke (blocke@shivan.org)
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-1.2.4-r1.ebuild,v 1.1 2002/04/24 14:54:25 spider Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Balsa: email client for GNOME"
+SRC_URI="http://www.theochem.kth.se/~pawsa/balsa/${A}"
+HOMEPAGE="http://www.balsa.net"
+
+DEPEND="=dev-libs/glib-1.2*
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ >=gnome-base/gnome-core-1.4.0.4-r1
+ >=gnome-base/gnome-print-0.30
+ >=gnome-base/ORBit-0.5.10-r1
+ >=media-libs/gdk-pixbuf-0.13.0
+ >=app-text/pspell-0.11.2
+ >=net-libs/libesmtp-0.8.6
+ >=dev-libs/libpcre-3.4
+ gtkhtml? ( >=gnome-extra/gtkhtml-0.16.1 )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ # this patch is from Riccardo Persichetti
+ # (ricpersi@libero.it) to make balsa compile
+ patch -p0 < ${FILESDIR}/balsa-1.2.4.diff
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --with-ssl"
+ fi
+
+ if [ "`use gtkhtml`" ] ; then
+ myconf="$myconf --with-gtkhtml"
+ fi
+
+ libmutt/configure --prefix=/usr --host=${CHOST} --with-mailpath=/var/mail
+ assert "configure libmutt failed"
+ ./configure --prefix=/usr --host=${CHOST} --enable-threads --enable-pcre $myconf
+ assert "configure balsa failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO docs/*
+}
+
diff --git a/net-mail/balsa/balsa-1.3.4.ebuild b/net-mail/balsa/balsa-1.3.4.ebuild
new file mode 100644
index 000000000000..221c873d7c94
--- /dev/null
+++ b/net-mail/balsa/balsa-1.3.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke (blocke@shivan.org)
+# Modified by Riccardo Persichetti (ricpersi@libero.it)
+# /space/gentoo/cvsroot/gentoo-x86/net-mail/balsa/balsa-1.3.4.ebuild,v 1.2 2002/04/12 18:48:20 spider Exp
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Balsa: email client for GNOME"
+SRC_URI="http://www.theochem.kth.se/~pawsa/balsa/${A}"
+HOMEPAGE="http://www.balsa.net"
+
+DEPEND="=dev-libs/glib-1.2*
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ >=gnome-base/gnome-core-1.4.0.4-r1
+ >=gnome-base/gnome-print-0.30
+ >=gnome-base/ORBit-0.5.10-r1
+ >=media-libs/gdk-pixbuf-0.13.0
+ >=app-text/pspell-0.11.2
+ >=net-libs/libesmtp-0.8.11
+ >=dev-libs/libpcre-3.4
+ gtkhtml? ( >=gnome-extra/gtkhtml-0.16.1 )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ # this patch is from Riccardo Persichetti
+ # (ricpersi@libero.it) to make balsa compile
+ patch -p0 < ${FILESDIR}/balsa-1.3.4.diff
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use gtkhtml && myconf="${myconf} --with-gtkhtml"
+
+ libmutt/configure --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-threads \
+ --enable-pcre ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
+
+
diff --git a/net-mail/balsa/files/balsa-1.2.4.diff b/net-mail/balsa/files/balsa-1.2.4.diff
new file mode 100644
index 000000000000..45247d77d2bc
--- /dev/null
+++ b/net-mail/balsa/files/balsa-1.2.4.diff
@@ -0,0 +1,12 @@
+--- balsa-1.2.4-orig/configure Mon Mar 25 00:34:33 2002
++++ balsa-1.2.4/configure Tue Apr 23 02:15:35 2002
+@@ -6629,7 +6629,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpspell $LIBS"
++ LIBS="-lpspell -lstdc++ $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+
diff --git a/net-mail/balsa/files/balsa-1.3.4.diff b/net-mail/balsa/files/balsa-1.3.4.diff
new file mode 100644
index 000000000000..d7e56f5912ed
--- /dev/null
+++ b/net-mail/balsa/files/balsa-1.3.4.diff
@@ -0,0 +1,12 @@
+--- balsa-1.3.4-orig/configure Mon Mar 25 00:34:33 2002
++++ balsa-1.3.4/configure Tue Apr 23 02:15:35 2002
+@@ -6629,7 +6629,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpspell $LIBS"
++ LIBS="-lpspell -lstdc++ $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+
diff --git a/net-mail/balsa/files/digest-balsa-1.2.4-r1 b/net-mail/balsa/files/digest-balsa-1.2.4-r1
new file mode 100644
index 000000000000..3fc8d3fd9d60
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-1.2.4-r1
@@ -0,0 +1 @@
+MD5 7ffeeb025be60f0b6a151d447ba5c748 balsa-1.2.4.tar.bz2 1975224
diff --git a/net-mail/balsa/files/digest-balsa-1.3.4 b/net-mail/balsa/files/digest-balsa-1.3.4
new file mode 100644
index 000000000000..afd4ea2596bb
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-1.3.4
@@ -0,0 +1 @@
+MD5 c540ffa8c2e435c6b9c62dc469b382c3 balsa-1.3.4.tar.bz2 2231146