summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-11-29 03:36:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-11-29 03:36:20 +0000
commit4792cf929e02c5c91b91cfc46df5526ef1f4e148 (patch)
treead5041e33f611792256efc6df119492f6f0db8a3 /net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild
parentfix bug #32969 and head/tail stuff (diff)
downloadhistorical-4792cf929e02c5c91b91cfc46df5526ef1f4e148.tar.gz
historical-4792cf929e02c5c91b91cfc46df5526ef1f4e148.tar.bz2
historical-4792cf929e02c5c91b91cfc46df5526ef1f4e148.zip
fix bug #32969 and head/tail stuff
Diffstat (limited to 'net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild')
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild
new file mode 100644
index 000000000000..5a9feea6777c
--- /dev/null
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild,v 1.1 2003/11/29 03:36:18 robbat2 Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Rate-limited autoresponder for qmail."
+SRC_URI="http://untroubled.org/qmail-autoresponder/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/qmail-autoresponder/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~sparc ~ppc"
+
+DEPEND="virtual/glibc
+ dev-libs/bglibs
+ mysql? ( dev-db/mysql )"
+RDEPEND=">=net-mail/qmail-1.03-r7
+ mysql? ( dev-db/mysql )"
+
+inherit fixheadtails
+
+src_unpack() {
+ unpack ${A}
+
+ # This patch fixes a multi-line string issue with gcc-3.3
+ # Closes Bug #30137
+ epatch ${FILESDIR}/${P}-gcc33-multiline-string-fix.patch
+
+ cd ${S}
+ ht_fix_file Makefile
+}
+
+src_compile() {
+ cd ${S}
+ echo "/usr/lib/bglibs/include" > conf-bgincs
+ echo "/usr/lib/bglibs/lib" > conf-bglibs
+ echo "${CC} ${CFLAGS}" > conf-cc
+ echo "${CC} ${LDFLAGS}" > conf-ld
+
+ # fails on parallel builds!
+ make qmail-autoresponder || die "Failed to make qmail-autoresponder"
+ if use mysql; then
+ make qmail-autoresponder-mysql || die "Failed to make qmail-autoresponder-mysql"
+ fi
+}
+
+src_install () {
+ dobin qmail-autoresponder
+ doman qmail-autoresponder.1
+ if use mysql; then
+ dobin qmail-autoresponder-mysql
+ dodoc schema.mysql
+ fi
+
+ dodoc ANNOUNCEMENT FILES NEWS README TARGETS TODO VERSION COPYING ChangeLog procedure.txt
+}
+
+pkg_postinst() {
+ einfo "Please see /usr/share/doc/${PF}/README for per-user configurations"
+}