summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-04-19 02:55:34 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-04-19 02:55:34 +0000
commit0e472aea53bfeaa06a7d1562ba324338284e2f44 (patch)
tree7acfff02713d0de228fd9a233383241e734a8da2 /net-mail/postfix/files
parentnew postfix release and quite a few postfix Gentoo bug fixes (see ChangeLog) (diff)
downloadhistorical-0e472aea53bfeaa06a7d1562ba324338284e2f44.tar.gz
historical-0e472aea53bfeaa06a7d1562ba324338284e2f44.tar.bz2
historical-0e472aea53bfeaa06a7d1562ba324338284e2f44.zip
new postfix release and quite a few postfix Gentoo bug fixes (see ChangeLog)
Diffstat (limited to 'net-mail/postfix/files')
-rw-r--r--net-mail/postfix/files/digest-postfix-2.0.910
-rwxr-xr-xnet-mail/postfix/files/postfix24
-rw-r--r--net-mail/postfix/files/postfix.rc63
3 files changed, 26 insertions, 11 deletions
diff --git a/net-mail/postfix/files/digest-postfix-2.0.9 b/net-mail/postfix/files/digest-postfix-2.0.9
index 8b6b537b59b3..65a9ea9bebbe 100644
--- a/net-mail/postfix/files/digest-postfix-2.0.9
+++ b/net-mail/postfix/files/digest-postfix-2.0.9
@@ -1,13 +1,3 @@
-MD5 a3eadfcfa0bf6f88ccff41e2d065745b /files/postfix-2.0.8_patch.patch 552
-MD5 4096261f3f7900791280f9595c60aade /files/postfix.rc6 506
-MD5 569f1c46350b2718419b72bb9c443c3f /files/saslpass 135
-MD5 460833c3a1ffc3a240c72f0537802b5c /files/tls+ipv6-1.4-pf-1.1.11-20020917.patch.bz2 72150
-MD5 40a96d0b5dfb56714e11d1f379ddc5a7 /files/main.cf 18376
-MD5 e651e2015b6c6f1495ac84a37e4a8871 /files/smtpd.conf 130
-MD5 e17b09d7df6537631ef2263b83fe0d38 /files/master.cf 4421
-MD5 798b43d4f63482e4eae84941d5b4f40e /files/smtp.pam 206
-MD5 803eb5ffc166aaaf2f3b78ddf71fe73d /files/postfix-2.0.0/main.cf.diff 2382
-MD5 6e3f1f40d61d599917ff9000f054dfd6 /postfix-2.0.9.ebuild 5325
MD5 c1ad12edfa19c23579b251078c464651 postfix-2.0.9.tar.gz 1347572
MD5 42e3c15c5d9b59eb4cd15304f9c11627 pfixtls-0.8.13-2.0.6-0.9.7a.tar.gz 226006
MD5 b2bec23a55360ac5bfa55426ecb5f1e3 tls+ipv6-1.13-pf-2.0.7.patch.gz 95608
diff --git a/net-mail/postfix/files/postfix b/net-mail/postfix/files/postfix
new file mode 100755
index 000000000000..98f376c276f1
--- /dev/null
+++ b/net-mail/postfix/files/postfix
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/files/postfix,v 1.4 2003/04/19 02:55:27 drobbins Exp $
+
+depend() {
+ need net
+ use logger dns
+ provide mta
+}
+
+PIDFILE=/var/spool/postfix/pid/master.pid
+
+start() {
+ ebegin "Starting postfix"
+ /usr/sbin/postfix start &>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping postfix"
+ /usr/sbin/postfix stop &>/dev/null
+ eend $?
+}
diff --git a/net-mail/postfix/files/postfix.rc6 b/net-mail/postfix/files/postfix.rc6
index d357bae922fb..01e766e69ab6 100644
--- a/net-mail/postfix/files/postfix.rc6
+++ b/net-mail/postfix/files/postfix.rc6
@@ -1,11 +1,12 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/files/postfix.rc6,v 1.8 2003/02/14 23:03:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/files/postfix.rc6,v 1.9 2003/04/19 02:55:27 drobbins Exp $
depend() {
need net
use logger dns
+ provide mta
}
PIDFILE=/var/spool/postfix/pid/master.pid