summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2002-12-14 18:33:03 +0000
committerJon Portnoy <avenj@gentoo.org>2002-12-14 18:33:03 +0000
commit864bedc717d35474c948e2174a720c5777b59e61 (patch)
tree2daf37ef01fea18ea605c33cddc2aed3fbd57272 /net-mail/fetchmail
parentMove to stable profile on account of bug #1162, comment #3. (diff)
downloadhistorical-864bedc717d35474c948e2174a720c5777b59e61.tar.gz
historical-864bedc717d35474c948e2174a720c5777b59e61.tar.bz2
historical-864bedc717d35474c948e2174a720c5777b59e61.zip
Version bump, major security fix.
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog12
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.0.ebuild82
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.2.01
3 files changed, 93 insertions, 2 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 82792d653d05..9e97e3df4082 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,14 @@
-# ChangeLog for net-mailfetchmailChangeLog/
+# ChangeLog for net-mail/fetchmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.16 2002/12/13 11:00:07 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.17 2002/12/14 18:32:57 avenj Exp $
+
+*fetchmail-6.2.0 (14 Dec 2002)
+
+ 14 Dec 2002; Jon Portnoy <avenj@gentoo.org> fetchmail-6.2.0.ebuild :
+ Version bump, major security fix. In stable straight off due to the
+ nature of the security hole (potential root compromise).
+ See http://security.e-matters.de/advisories/052002.html for more
+ information.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-mail/fetchmail/fetchmail-6.2.0.ebuild b/net-mail/fetchmail/fetchmail-6.2.0.ebuild
new file mode 100644
index 000000000000..b1c732668046
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.2.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.0.ebuild,v 1.1 2002/12/14 18:33:03 avenj Exp $
+
+IUSE="ssl nls"
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="x86"
+
+src_compile() {
+
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ # This needs inet6-apps, which we don't have
+ #use ipv6 && myconf="${myconf} --enable-inet6 --enable-netsec"
+ # || myconf="${myconf} --disable-inet6 --disable-netsec"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+
+}
+
+src_install() {
+
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.2.0 b/net-mail/fetchmail/files/digest-fetchmail-6.2.0
new file mode 100644
index 000000000000..a9eb7075604d
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.2.0
@@ -0,0 +1 @@
+MD5 1242753944ad242bb4312af6be08b810 fetchmail-6.2.0.tar.gz 1089936