summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2004-10-23 13:57:10 +0000
committerJoseph Jezak <josejx@gentoo.org>2004-10-23 13:57:10 +0000
commit4ff88583b9c16c4a610a87a4941440ba4df085c7 (patch)
tree3d943480cc4db63e39d56cae8bc463dd4e8e7c9c /net-libs
parentRemoved old ebuild. (diff)
downloadhistorical-4ff88583b9c16c4a610a87a4941440ba4df085c7.tar.gz
historical-4ff88583b9c16c4a610a87a4941440ba4df085c7.tar.bz2
historical-4ff88583b9c16c4a610a87a4941440ba4df085c7.zip
Initial import, bug #50822
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gecko-sdk/ChangeLog7
-rw-r--r--net-libs/gecko-sdk/Manifest2
-rw-r--r--net-libs/gecko-sdk/files/digest-gecko-sdk-1.7.31
-rw-r--r--net-libs/gecko-sdk/files/mozilla-1.3-fix-RAW-target.patch12
-rw-r--r--net-libs/gecko-sdk/files/mozilla-alpha-xpcom-subs-fix.patch139
-rw-r--r--net-libs/gecko-sdk/gecko-sdk-1.7.3.ebuild87
-rw-r--r--net-libs/gecko-sdk/metadata.xml9
-rw-r--r--net-libs/openh323/Manifest8
8 files changed, 261 insertions, 4 deletions
diff --git a/net-libs/gecko-sdk/ChangeLog b/net-libs/gecko-sdk/ChangeLog
new file mode 100644
index 000000000000..89aa375ae9e9
--- /dev/null
+++ b/net-libs/gecko-sdk/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-libs/gecko-sdk
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gecko-sdk/ChangeLog,v 1.1 2004/10/23 13:57:10 josejx Exp $
+
+ 23 Oct 2004; Joseph Jezak <josejx@gentoo.org> :
+ Initial import, bug #50822
+
diff --git a/net-libs/gecko-sdk/Manifest b/net-libs/gecko-sdk/Manifest
new file mode 100644
index 000000000000..fed8a24a9b0b
--- /dev/null
+++ b/net-libs/gecko-sdk/Manifest
@@ -0,0 +1,2 @@
+MD5 2a2e3f2213f8dbbfd87ca37bdb42be54 gecko-sdk-1.7.3.ebuild 2093
+MD5 640ad02464c41c9b820db9b59c7eeaec files/digest-gecko-sdk-1.7.3 75
diff --git a/net-libs/gecko-sdk/files/digest-gecko-sdk-1.7.3 b/net-libs/gecko-sdk/files/digest-gecko-sdk-1.7.3
new file mode 100644
index 000000000000..a10c327f101f
--- /dev/null
+++ b/net-libs/gecko-sdk/files/digest-gecko-sdk-1.7.3
@@ -0,0 +1 @@
+MD5 15cb68da1d58f055f871b77ff655df77 mozilla-source-1.7.3.tar.bz2 29716200
diff --git a/net-libs/gecko-sdk/files/mozilla-1.3-fix-RAW-target.patch b/net-libs/gecko-sdk/files/mozilla-1.3-fix-RAW-target.patch
new file mode 100644
index 000000000000..5951496e9893
--- /dev/null
+++ b/net-libs/gecko-sdk/files/mozilla-1.3-fix-RAW-target.patch
@@ -0,0 +1,12 @@
+--- mozilla/xpinstall/packager/Makefile.in.orig 2003-02-23 14:41:08.000000000 +0200
++++ mozilla/xpinstall/packager/Makefile.in 2003-02-23 14:41:36.000000000 +0200
+@@ -87,6 +87,9 @@
+ ifeq ($(MOZ_PKG_FORMAT),DEB)
+ PKG_SUFFIX = .deb
+ endif
++ifeq ($(MOZ_PKG_FORMAT),RAW)
++MAKE_SDK = echo
++endif
+
+ TARGETS = $(PACKAGE) $(SDK)
+
diff --git a/net-libs/gecko-sdk/files/mozilla-alpha-xpcom-subs-fix.patch b/net-libs/gecko-sdk/files/mozilla-alpha-xpcom-subs-fix.patch
new file mode 100644
index 000000000000..c7f95467438a
--- /dev/null
+++ b/net-libs/gecko-sdk/files/mozilla-alpha-xpcom-subs-fix.patch
@@ -0,0 +1,139 @@
+--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp 2002-04-10 05:37:38.000000000 +0200
++++ mozilla-alpha/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp 2002-10-06 10:44:59.000000000 +0200
+@@ -20,6 +20,7 @@
+ * the Initial Developer. All Rights Reserved.
+ *
+ * Contributor(s):
++ * Glen Nakamura <glen@imodulo.com>
+ *
+ * Alternatively, the contents of this file may be used under the terms of
+ * either the GNU General Public License Version 2 or later (the "GPL"), or
+@@ -37,16 +38,14 @@
+
+ /* Platform specific code to invoke XPCOM methods on native objects */
+
+-/* contributed by Glen Nakamura <glen.nakamura@usa.net> */
+-
+ #include "xptcprivate.h"
+
+ /* Prototype specifies unmangled function name and disables unused warning */
+-static void
++void
+ invoke_copy_to_stack(PRUint64* d, PRUint32 paramCount, nsXPTCVariant* s)
+ __asm__("invoke_copy_to_stack") __attribute__((unused));
+
+-static void
++void
+ invoke_copy_to_stack(PRUint64* d, PRUint32 paramCount, nsXPTCVariant* s)
+ {
+ const PRUint8 NUM_ARG_REGS = 6-1; // -1 for "this" pointer
+@@ -163,7 +162,11 @@
+ "bis $16,$16,$1\n\t" /* load "this" */
+ "ldq $2,16($15)\n\t" /* load "methodIndex" */
+ "ldq $1,0($1)\n\t" /* load vtable */
++#if defined(__GXX_ABI_VERSION) && __GXX_ABI_VERSION >= 100 /* G++ V3 ABI */
++ "s8addq $2,$31,$2\n\t" /* vtable index = "methodIndex" * 8 */
++#else /* not G++ V3 ABI */
+ "s8addq $2,16,$2\n\t" /* vtable index = "methodIndex" * 8 + 16 */
++#endif /* G++ V3 ABI */
+ "addq $1,$2,$1\n\t"
+ "ldq $27,0($1)\n\t" /* load address of function */
+ "jsr $26,($27),0\n\t" /* call virtual function */
+@@ -176,4 +179,3 @@
+ "ret $31,($26),1\n\t"
+ ".end XPTC_InvokeByIndex"
+ );
+-
+--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp 2002-04-10 05:37:42.000000000 +0200
++++ mozilla-alpha/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp 2002-10-06 10:45:10.000000000 +0200
+@@ -20,6 +20,7 @@
+ * the Initial Developer. All Rights Reserved.
+ *
+ * Contributor(s):
++ * Glen Nakamura <glen@imodulo.com>
+ *
+ * Alternatively, the contents of this file may be used under the terms of
+ * either the GNU General Public License Version 2 or later (the "GPL"), or
+@@ -37,16 +38,14 @@
+
+ /* Implement shared vtbl methods. */
+
+-/* contributed by Glen Nakamura <glen.nakamura@usa.net> */
+-
+ #include "xptcprivate.h"
+
+ /* Prototype specifies unmangled function name and disables unused warning */
+-static nsresult
++nsresult
+ PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint64* args)
+ __asm__("PrepareAndDispatch") __attribute__((unused));
+
+-static nsresult
++nsresult
+ PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint64* args)
+ {
+ const PRUint8 PARAM_BUFFER_COUNT = 16;
+@@ -188,23 +187,45 @@
+ * nsresult nsXPTCStubBase::Stub##n()
+ * Sets register $1 to "methodIndex" and jumps to SharedStub.
+ */
++#define STUB_MANGLED_ENTRY(n, symbol) \
++ "#### Stub"#n" ####" "\n\t" \
++ ".text" "\n\t" \
++ ".align 5" "\n\t" \
++ ".globl " symbol "\n\t" \
++ ".ent " symbol "\n" \
++symbol ":" "\n\t" \
++ ".frame $30,0,$26,0" "\n\t" \
++ "ldgp $29,0($27)" "\n" \
++"$" symbol "..ng:" "\n\t" \
++ ".prologue 1" "\n\t" \
++ "lda $1,"#n "\n\t" \
++ "br $31,$SharedStub..ng" "\n\t" \
++ ".end " symbol
++
++#if defined(__GXX_ABI_VERSION) && __GXX_ABI_VERSION >= 100 /* G++ V3 ABI */
++
++#define STUB_ENTRY(n) \
++__asm__( \
++ ".if "#n" < 10" "\n\t" \
++ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase5Stub"#n"Ev") "\n\t" \
++ ".elseif "#n" < 100" "\n\t" \
++ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase6Stub"#n"Ev") "\n\t" \
++ ".elseif "#n" < 1000" "\n\t" \
++ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase7Stub"#n"Ev") "\n\t" \
++ ".else" "\n\t" \
++ ".err \"Stub"#n" >= 1000 not yet supported.\"" "\n\t" \
++ ".endif" \
++ );
++
++#else /* not G++ V3 ABI */
++
+ #define STUB_ENTRY(n) \
+ __asm__( \
+- "#### Stub"#n" ####\n" \
+-".text\n\t" \
+- ".align 5\n\t" \
+- ".globl Stub"#n"__14nsXPTCStubBase\n\t" \
+- ".ent Stub"#n"__14nsXPTCStubBase\n" \
+-"Stub"#n"__14nsXPTCStubBase:\n\t" \
+- ".frame $30,0,$26,0\n\t" \
+- "ldgp $29,0($27)\n" \
+-"$Stub"#n"__14nsXPTCStubBase..ng:\n\t" \
+- ".prologue 1\n\t" \
+- "lda $1,"#n"\n\t" \
+- "br $31,$SharedStub..ng\n\t" \
+- ".end Stub"#n"__14nsXPTCStubBase" \
++ STUB_MANGLED_ENTRY(n, "Stub"#n"__14nsXPTCStubBase") \
+ );
+
++#endif /* G++ V3 ABI */
++
+ #define SENTINEL_ENTRY(n) \
+ nsresult nsXPTCStubBase::Sentinel##n() \
+ { \
+@@ -213,4 +234,3 @@
+ }
+
+ #include "xptcstubsdef.inc"
+-
diff --git a/net-libs/gecko-sdk/gecko-sdk-1.7.3.ebuild b/net-libs/gecko-sdk/gecko-sdk-1.7.3.ebuild
new file mode 100644
index 000000000000..f96d854833e9
--- /dev/null
+++ b/net-libs/gecko-sdk/gecko-sdk-1.7.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gecko-sdk/gecko-sdk-1.7.3.ebuild,v 1.1 2004/10/23 13:57:10 josejx Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic gcc eutils nsplugins mozilla-launcher mozilla makeedit
+
+IUSE="java crypt gtk2 ssl"
+# Internal USE flags that I do not really want to advertise ...
+IUSE="${IUSE} mozcalendar moznoirc moznomail moznocompose moznoxft"
+
+EMVER="0.86.0"
+IPCVER="1.0.8"
+
+# handle _rc versions
+MY_PV=${PV/_alpha/a} # handle alpha
+MY_PV=${MY_PV/_beta/b} # handle beta
+MY_PV=${MY_PV/_rc/rc} # handle rc
+
+DESCRIPTION="Gecko SDK"
+HOMEPAGE="http://www.mozilla.org"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla${MY_PV}/src/mozilla-source-${MY_PV}.tar.bz2"
+KEYWORDS="ppc"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+RDEPEND=""
+DEPEND="java? ( >=dev-java/java-config-0.2.0 )
+ dev-lang/perl"
+
+S="${WORKDIR}/mozilla"
+
+src_unpack() {
+ typeset x
+
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die
+
+ if [[ $(gcc-major-version) -eq 3 ]]; then
+ # ABI Patch for alpha/xpcom for gcc-3.x
+ if [[ ${ARCH} == alpha ]]; then
+ epatch ${FILESDIR}/mozilla-alpha-xpcom-subs-fix.patch
+ fi
+ fi
+
+ # Fix logic error when using RAW target
+ # <azarah@gentoo.org> (23 Feb 2003)
+ epatch ${FILESDIR}/mozilla-1.3-fix-RAW-target.patch
+
+ WANT_AUTOCONF=2.1 autoconf || die
+}
+
+src_compile() {
+ local myconf
+
+ ####################################
+ #
+ # myconf, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ # mozilla_conf comes from mozilla.eclass
+ mozilla_conf
+
+ myconf="${myconf} \
+ --prefix=/usr/lib/mozilla \
+ --with-default-mozilla-five-home=/usr/lib/mozilla"
+
+ ####################################
+ #
+ # Configure and build Mozilla
+ #
+ ####################################
+
+ ./configure ${myconf} || die
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake || die
+}
+
+src_install(){
+ cd ${S}/dist
+ mkdir -p ${D}/usr/share
+ cp -RL sdk ${D}/usr/share/gecko-sdk
+}
diff --git a/net-libs/gecko-sdk/metadata.xml b/net-libs/gecko-sdk/metadata.xml
new file mode 100644
index 000000000000..d8b6700bc579
--- /dev/null
+++ b/net-libs/gecko-sdk/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mozilla</herd>
+<maintainer>
+ <email>josejx@gentoo.org</email>
+ <name>Joseph Jezak</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-libs/openh323/Manifest b/net-libs/openh323/Manifest
index f2af861d09e0..5b71446f6801 100644
--- a/net-libs/openh323/Manifest
+++ b/net-libs/openh323/Manifest
@@ -1,4 +1,4 @@
-MD5 93513822a799aa8c8349d73e7e9117e6 ChangeLog 8232
+MD5 f1a67bc0a63c023828fa59f2f172ce75 ChangeLog 8327
MD5 5ae9f140fcd4525c88ee9239bd8772a6 metadata.xml 267
MD5 bc1d3d9e9dfe4dea1ee2195db7e2cd04 openh323-1.11.7.ebuild 1826
MD5 cba34a1ddf5939fc027e879871a633c7 openh323-1.12.0-r1.ebuild 2821
@@ -6,22 +6,22 @@ MD5 ac4ea2adff91762288ef0246d7446f48 openh323-1.12.2-r1.ebuild 3106
MD5 03ffce610d4d5c1bad37d71290ce3a7b openh323-1.12.2-r2.ebuild 3723
MD5 8ff12b73f518acdd8cc8356ec4fe04b3 openh323-1.13.2-r1.ebuild 4027
MD5 2b323f821a82d94ecaaad482405ac025 openh323-1.13.2.ebuild 3705
-MD5 523e8954ce3c87436adc788a6f31c04b openh323-1.13.5.ebuild 4049
MD5 12403060d8b2aab0cf2256cb868512fc openh323-1.9.10-r1.ebuild 1103
+MD5 0d5caeb02a13b7304ee90ba957327763 openh323-1.13.5.ebuild 4054
MD5 e9ac1227eaf205c20f84a4fc712e8d66 files/digest-openh323-1.11.7 68
MD5 238a3a0b91aabce0a61e0dd5c4b9ee68 files/digest-openh323-1.12.0-r1 68
MD5 2efc1a39c75805caacb974bfa6208dea files/digest-openh323-1.12.2-r1 68
MD5 2efc1a39c75805caacb974bfa6208dea files/digest-openh323-1.12.2-r2 68
MD5 8f793eaf228e13d19c7393fe95c8ed19 files/digest-openh323-1.13.2 68
MD5 8f793eaf228e13d19c7393fe95c8ed19 files/digest-openh323-1.13.2-r1 68
-MD5 9519f9e7c6a88c9159cba2345725ed9d files/digest-openh323-1.13.5 73
MD5 47caff52a16cf5135ad984dcfe022f6a files/digest-openh323-1.9.10-r1 68
MD5 c3dd75b2e6b09b4f5cc5b88a12064159 files/openh323-1.11.7-emptyMakefile 8
MD5 3f59306b619abf22dd5338af0c4c099b files/openh323-1.12.0-include-order.diff 1326
MD5 76afb2b1c9c9e4aa4414531ffdd812e9 files/openh323-1.12.2-ffmpeg.diff 1899
MD5 767748fd04f2626be4c6914e110a1676 files/openh323-1.12.2-include-order.diff 1361
MD5 76afb2b1c9c9e4aa4414531ffdd812e9 files/openh323-1.13.2-ffmpeg.diff 1899
-MD5 e4b00dfe33b6d0574e651c93ceddf59d files/openh323-1.13.2-gcc34.diff 291
MD5 d63db2246a246adf622afeefabbb1e9d files/openh323-1.13.2-include-order.diff 1027
+MD5 9519f9e7c6a88c9159cba2345725ed9d files/digest-openh323-1.13.5 73
MD5 76afb2b1c9c9e4aa4414531ffdd812e9 files/openh323-1.13.5-ffmpeg.diff 1899
MD5 d63db2246a246adf622afeefabbb1e9d files/openh323-1.13.5-include-order.diff 1027
+MD5 e4b00dfe33b6d0574e651c93ceddf59d files/openh323-1.13.2-gcc34.diff 291