summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2002-12-24 11:37:15 +0000
committerStefan Jones <cretin@gentoo.org>2002-12-24 11:37:15 +0000
commit937105c34826d4caff9bb375c79b8842b10b6e8f (patch)
tree62580a74c9d078008c85429bbb1f3406eec55e1a /net-libs/soup
parentVersion pump submitted by Mark Hollomon #12625. (diff)
downloadhistorical-937105c34826d4caff9bb375c79b8842b10b6e8f.tar.gz
historical-937105c34826d4caff9bb375c79b8842b10b6e8f.tar.bz2
historical-937105c34826d4caff9bb375c79b8842b10b6e8f.zip
New soup version, evolution-1.2.1 will need it soon
Diffstat (limited to 'net-libs/soup')
-rw-r--r--net-libs/soup/ChangeLog9
-rw-r--r--net-libs/soup/files/digest-soup-0.7.101
-rw-r--r--net-libs/soup/soup-0.7.10.ebuild52
3 files changed, 60 insertions, 2 deletions
diff --git a/net-libs/soup/ChangeLog b/net-libs/soup/ChangeLog
index 2008f05ab92b..8287e789b932 100644
--- a/net-libs/soup/ChangeLog
+++ b/net-libs/soup/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-libs/soup
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/ChangeLog,v 1.7 2002/12/13 11:00:04 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/ChangeLog,v 1.8 2002/12/24 11:37:13 cretin Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
+
+*soup-0.7.10 (24 Dec 2002)
+
+ 24 Dec 2002; Stefan Jones <cretin@gentoo.org> :
+ New version, preempt any bugs in evolution with this.
+
*soup-0.7.4-r1 (9 Nov 2002)
9 Nov 2002; Martin Schlemmer <azarah@gentoo.org> :
diff --git a/net-libs/soup/files/digest-soup-0.7.10 b/net-libs/soup/files/digest-soup-0.7.10
new file mode 100644
index 000000000000..571d421e3d3f
--- /dev/null
+++ b/net-libs/soup/files/digest-soup-0.7.10
@@ -0,0 +1 @@
+MD5 baf1ecd6e14ca50544ce889ba363a9be soup-0.7.10.tar.bz2 303967
diff --git a/net-libs/soup/soup-0.7.10.ebuild b/net-libs/soup/soup-0.7.10.ebuild
new file mode 100644
index 000000000000..09c129cadf44
--- /dev/null
+++ b/net-libs/soup/soup-0.7.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/soup-0.7.10.ebuild,v 1.1 2002/12/24 11:37:15 cretin Exp $
+
+IUSE="ssl doc"
+
+inherit gnome.org libtool
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Soup is a SOAP implementation"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ =dev-libs/glib-1.2*
+ >=dev-libs/libxml2-2.4.16
+ dev-libs/popt
+ ssl? ( dev-libs/openssl )
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+LICENSE="GPL-2 | LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use ssl \
+ && myconf="--enable-ssl" \
+ || myconf="--disable-ssl"
+
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ # there is a --enable-apache here.....
+
+ econf \
+ ${myconf} \
+ --with-libxml=1 || die
+ # Evolution 1.1 and 1.2 need it with libxml1
+
+ # dont always work with -j4 -- <azarah@gentoo.org> 9 Nov 2002
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ABOUT-NLS COPYING* ChangeLog README* INSTALL NEWS TODO
+}
+