summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-03-05 02:17:57 +0000
committerChuck Short <zul@gentoo.org>2004-03-05 02:17:57 +0000
commit6a53cadbf304b8870beef3beb6fd1c4658de2bfd (patch)
tree95c1a85a858235bdacb0a2acb38ab2946781ff1d /net-irc
parentVersion bump. Added ~amd64 to KEYWORDS. (diff)
downloadhistorical-6a53cadbf304b8870beef3beb6fd1c4658de2bfd.tar.gz
historical-6a53cadbf304b8870beef3beb6fd1c4658de2bfd.tar.bz2
historical-6a53cadbf304b8870beef3beb6fd1c4658de2bfd.zip
Ebuild improvements. closes #42396.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/unrealircd/ChangeLog5
-rw-r--r--net-irc/unrealircd/Manifest4
-rw-r--r--net-irc/unrealircd/unrealircd-3.2_rc1.ebuild100
3 files changed, 78 insertions, 31 deletions
diff --git a/net-irc/unrealircd/ChangeLog b/net-irc/unrealircd/ChangeLog
index 90720c12a707..114fae513be8 100644
--- a/net-irc/unrealircd/ChangeLog
+++ b/net-irc/unrealircd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/unrealircd
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.5 2004/02/21 02:42:37 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.6 2004/03/05 02:17:44 zul Exp $
+
+ 04 Mar 2004; Chuck Short <zul@gentoo.org> unrealircd-3.2_rc1.ebuild:
+ Ebuild improvements. Closes #42396.
*unrealircd-3.2_rc1 (20 Feb 2004)
diff --git a/net-irc/unrealircd/Manifest b/net-irc/unrealircd/Manifest
index 7bd9e6d82163..0e00a9a62dd0 100644
--- a/net-irc/unrealircd/Manifest
+++ b/net-irc/unrealircd/Manifest
@@ -1,7 +1,7 @@
-MD5 e5ec64b30a0925475c962825fc241d03 unrealircd-3.2_rc1.ebuild 1932
+MD5 c464c60aa768db325a8a07c49a2406af unrealircd-3.2_rc1.ebuild 2772
MD5 e8ec5f3f341ab6c4146ca830ec27c456 unrealircd-3.1.5.1.ebuild 1950
MD5 32fa593bf9497733cf19aecc68606f40 unrealircd-3.1.6.ebuild 1954
-MD5 65117e9e20e47f8ac9e7ff9e69dc2105 ChangeLog 916
+MD5 53696248249aea7eca02d2a8f9e755dd ChangeLog 1026
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 2faabd524feebdf184243497848c4da9 files/unrealircd.confd 517
MD5 0e5e4e0c025911074b2673b9a040aa57 files/digest-unrealircd-3.1.6 68
diff --git a/net-irc/unrealircd/unrealircd-3.2_rc1.ebuild b/net-irc/unrealircd/unrealircd-3.2_rc1.ebuild
index 699b980de229..b48a733e5d28 100644
--- a/net-irc/unrealircd/unrealircd-3.2_rc1.ebuild
+++ b/net-irc/unrealircd/unrealircd-3.2_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2_rc1.ebuild,v 1.1 2004/02/21 02:42:37 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2_rc1.ebuild,v 1.2 2004/03/05 02:17:44 zul Exp $
MY_P=Unreal3.2-RC1
DESCRIPTION="aimed to be an advanced (not easy) IRCd"
@@ -10,62 +10,106 @@ SRC_URI="http://www.gower.net/unrealircd/${MY_P}.tar.gz
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86"
-IUSE="ssl"
+KEYWORDS="~x86 -*"
+IUSE="ssl ipv6 leaf"
DEPEND="ssl? ( dev-libs/openssl )
>=sys-apps/sed-4"
S=${WORKDIR}/Unreal3.2
-src_unpack() {
- unpack ${A} && cd ${S}
- rm -f .CHANGES.NEW .RELEASE.NOTES
-# epatch ${FILESDIR}/${PV}-Config.patch
-# sed -i 's:^ID_CVS.*::' src/res_mkquery.c
-
-# cp Config{,.orig}
-# sed -e "s:GENTOO_CFLAGS:${CFLAGS}:" \
-# Config.orig > Config
-}
src_compile() {
- ./Config -quick || die "configure failed"
- make RES="res_init.o res_comp.o res_mkquery.o" \
- || die "compiling failed"
+ local myconf=" --enable-nospoof \
+ --prefix=/usr \
+ --with-dpath=${D}/etc/unrealircd \
+ --with-spath=/usr/bin/unrealircd \
+ --enable-prefixaq \
+ --enable-ziplinks \
+ --with-listen=5 \
+ --with-nick-history=2000 \
+ --with-sendq=3000000 \
+ --with-bufferpool=18 \
+ --with-hostname=`hostname` \
+ --with-permissions=0600 \
+ --with-fd-setsize=1024 \
+ --enable-dynamic-linking"
+
+ if [ -n "`use ssl`" ] ; then
+ einfo "Enabling SSL/Crypto support"
+ myconf="${myconf} --enable-ssl"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ einfo "Enabling IPv6 support"
+ myconf="${myconf} --enable-inet6"
+ fi
+
+ if [ -n "`use leaf`" ] ; then
+ einfo "Enabling ircd as leaf server"
+ myconf="${myconf} --enable-leaf"
+ sleep 5
+ else
+ einfo "Enabling ircd as hub server(default)"
+ ewarn "Set USE=\"leaf\" if you want a leaf server."
+ sleep 5
+ myconf="${myconf} --enable-hub"
+ fi
+
+ econf ${myconf} || die
+
+ emake || die
}
src_install() {
+ cd ${S}
+
newbin src/ircd unrealircd || die
+ if [ -n "`use ssl`" ] ; then
+ newbin ${FILESDIR}/mkunrealircd-cert.sh mkunrealircd-cert
+ fi
+
insinto /etc/unrealircd
- doins badwords.*.conf
+ doins badwords.*.conf help.conf
+
+ if [ -n "`use ssl`" ] ; then
+ doins src/ssl.cnf
+ fi
+
insinto /etc/unrealircd/networks
- doins networks/{template.network,unrealircd.conf}
+ doins networks/{*.network,makenet,networks.ndx}
+
+ insinto /etc/unrealircd/aliases
+ doins aliases/*.conf
- rm -rf ircdcron/CVS
- rm -rf doc/CVS
- rm -rf doc/technical/CVS
- dodoc doc/* Changes Donation Unreal.nfo ircdcron/*
+ insinto /etc/unrealircd/modules
+ doins src/modules/*.so
+
+ dodoc doc/Authors doc/example.conf doc/example.settings
+ dodoc doc/coding-guidelines doc/tao.of.irc doc/unreal32docs.html
exeinto /etc/init.d
newexe ${FILESDIR}/unrealircd.rc unrealircd
+
insinto /etc/conf.d
newins ${FILESDIR}/unrealircd.confd unrealircd
+
+ into /etc/unrealircd
+ dodir /etc/unrealircd/tmp
}
pkg_postinst() {
einfo "UnrealIRCD will not run until you do a few things ..."
echo
einfo "Setup /etc/unrealircd/unrealircd.conf"
- einfo " see /etc/unrealircd/template.network for more info"
- einfo "Setup /etc/unrealircd/ircd.conf"
einfo " see /usr/share/doc/${PF}/example.conf.gz for more info"
echo
- einfo "You can find example cron scripts here:"
- einfo " /usr/share/doc/${PF}/ircd.cron"
- einfo " /usr/share/doc/${PF}/ircdchk"
- echo
einfo "You can also use /etc/init.d/unrealircd to start at boot"
echo
+ if [ -n "`use ssl`" ] ; then
+ einfo "Run /usr/bin/mkunrealircd-cert to create a default cert for ssl."
+ einfo "The cert defaults are in /etc/unrealircd/ssl.cnf edit this prior to running."
+ echo
+ fi
}