summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-07-27 17:27:18 +0000
committerSven Wegener <swegener@gentoo.org>2004-07-27 17:27:18 +0000
commit149f223f60f41f7cf8dbd1e26be3c233003392a6 (patch)
tree27ccfb5d7c5bb4e7b3d2dc6a74e594e0b5fc9e91 /net-irc/iip
parentFixes src/pkg typo (diff)
downloadhistorical-149f223f60f41f7cf8dbd1e26be3c233003392a6.tar.gz
historical-149f223f60f41f7cf8dbd1e26be3c233003392a6.tar.bz2
historical-149f223f60f41f7cf8dbd1e26be3c233003392a6.zip
Removed the enewuser command in src_install for bug #58526. The created user isn't used later on. Made iip-1.1.0 CFLAGS aware. Added dev-lang/perl to build time dependencies for 1.2.0 as pod2man is needed to create the man page.
Diffstat (limited to 'net-irc/iip')
-rw-r--r--net-irc/iip/ChangeLog8
-rw-r--r--net-irc/iip/Manifest16
-rw-r--r--net-irc/iip/iip-1.1.0.ebuild40
-rw-r--r--net-irc/iip/iip-1.2.ebuild37
4 files changed, 58 insertions, 43 deletions
diff --git a/net-irc/iip/ChangeLog b/net-irc/iip/ChangeLog
index b0f23974a4d3..5ea1213e9213 100644
--- a/net-irc/iip/ChangeLog
+++ b/net-irc/iip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/iip
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/iip/ChangeLog,v 1.8 2004/07/01 22:21:21 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/iip/ChangeLog,v 1.9 2004/07/27 17:27:18 swegener Exp $
+
+ 27 Jul 2004; Sven Wegener <swegener@gentoo.org> iip-1.1.0.ebuild,
+ iip-1.2.ebuild:
+ Removed the enewuser command in src_install for bug #58526. The created user
+ isn't used later on. Made iip-1.1.0 CFLAGS aware. Added dev-lang/perl to build
+ time dependencies for 1.2.0 as pod2man is needed to create the man page.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> iip-1.1.0.ebuild,
iip-1.2.ebuild:
diff --git a/net-irc/iip/Manifest b/net-irc/iip/Manifest
index 129961a2346a..a6303dce761b 100644
--- a/net-irc/iip/Manifest
+++ b/net-irc/iip/Manifest
@@ -1,6 +1,16 @@
-MD5 70f6492b1d8e6401c294c7acf59608bd ChangeLog 1367
-MD5 f4d26909c9c213ff8ceef8636c07be55 iip-1.1.0.ebuild 793
-MD5 35cd572761431f742d19009561929ded iip-1.2.ebuild 935
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 b9fd0a64281812ea5286bb2fd611e7e9 ChangeLog 1687
+MD5 830d7f87c1677d10dff173631e3a0ddb iip-1.1.0.ebuild 951
+MD5 35e841307a152be82d8e9f0bab392625 iip-1.2.ebuild 829
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 6c9503150f532297b61909618997f875 files/digest-iip-1.1.0 58
MD5 4a0260da2d54bb5646ddc91b604ce49b files/digest-iip-1.2 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFBBpDCAXomK8S72HoRApvCAJ0Tc6+zJb0v+AyHNbHvTqO6WLk0iwCfVXTS
+gUw6wCSM4gWsF3SYj+z5pyU=
+=q12S
+-----END PGP SIGNATURE-----
diff --git a/net-irc/iip/iip-1.1.0.ebuild b/net-irc/iip/iip-1.1.0.ebuild
index 08b15b5ae75a..8a7b29d723cb 100644
--- a/net-irc/iip/iip-1.1.0.ebuild
+++ b/net-irc/iip/iip-1.1.0.ebuild
@@ -1,11 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/iip/iip-1.1.0.ebuild,v 1.6 2004/07/01 22:21:21 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/iip/iip-1.1.0.ebuild,v 1.7 2004/07/27 17:27:18 swegener Exp $
-inherit eutils
-
-S="${WORKDIR}/${P}/src"
-DESCRIPTION="Proxy server for encrypted anonymous irc-like network"
+DESCRIPTION="Proxy server for encrypted anonymous IRC-like network"
HOMEPAGE="http://www.invisiblenet.net/iip/"
SRC_URI="mirror://sourceforge/invisibleip/${P}.tgz"
LICENSE="GPL-2"
@@ -13,21 +10,32 @@ SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
-DEPEND="virtual/libc"
-RDEPEND=""
+S="${WORKDIR}/${P}/src"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e "s/-g -Wall -O2/${CFLAGS}/" ${S}/Makefile || die "sed failed"
+}
src_compile() {
- emake || die
+ emake || die "emake failed"
}
src_install() {
- ehome=/home/iip
- enewuser iip
- dodir /usr/man/man1
- dodir /usr/bin
- dodir /usr/share/iip
- make PREFIX=${D}usr INSTALLFILEPATH=${D}usr/share/iip/ install || die
+ dodir /usr/bin /usr/share/man/man1
+
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMANDST=${D}/usr/share/man/man1/ \
+ INSTALLFILEPATH=${D}/usr/share/iip/ \
+ INSTALLUSER=root \
+ install || die "make install failed"
+
cd ${WORKDIR}/${P}
- dodoc AUTHORS CHANGELOG COPYING INSTALL README
+ dodoc AUTHORS CHANGELOG README
}
-
diff --git a/net-irc/iip/iip-1.2.ebuild b/net-irc/iip/iip-1.2.ebuild
index 717883d1a4ce..f86147e2924d 100644
--- a/net-irc/iip/iip-1.2.ebuild
+++ b/net-irc/iip/iip-1.2.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/iip/iip-1.2.ebuild,v 1.7 2004/07/01 22:21:21 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/iip/iip-1.2.ebuild,v 1.8 2004/07/27 17:27:18 swegener Exp $
-inherit eutils
+MY_P="${P}-dev1"
-MY_P="iip-1.2-dev1"
-
-DESCRIPTION="Proxy server for encrypted anonymous irc-like network"
+DESCRIPTION="Proxy server for encrypted anonymous IRC-like network"
HOMEPAGE="http://www.invisiblenet.net/iip/"
SRC_URI="mirror://sourceforge/invisibleip/${MY_P}.tar.bz2"
LICENSE="GPL-2"
@@ -14,32 +12,25 @@ SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
-DEPEND="virtual/libc
- dev-libs/openssl
- >=sys-apps/sed-4"
-RDEPEND=""
+RDEPEND="virtual/libc
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=sys-apps/sed-4"
S="${WORKDIR}/${MY_P}"
src_compile() {
- econf || die
+ econf || die "econf failed"
sed -i \
- -e "s:-Werror::" ${S}/src/Makefile || \
- die "sed Makefile failed"
+ -e "s:-Werror::" ${S}/src/Makefile || \
+ die "sed Makefile failed"
- emake || die
+ emake || die "emake failed"
}
src_install() {
- ehome=/home/iip
- enewuser iip
- dodir /usr/man/man1
- dodir /usr/bin
- dodir /usr/share/iip
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man install || die
- dodoc AUTHORS CHANGELOG COPYING INSTALL README
-
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS README
}
-