summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-06-21 23:30:48 +0000
committerSven Wegener <swegener@gentoo.org>2004-06-21 23:30:48 +0000
commit8c21909d621236e15795aaa42f9c76110c12e86c (patch)
tree8f0fe4d66beb026c014e99fef6dc1f3c61c59537 /net-irc/bnc
parentnew release, mark 2.0.0 x86 (diff)
downloadhistorical-8c21909d621236e15795aaa42f9c76110c12e86c.tar.gz
historical-8c21909d621236e15795aaa42f9c76110c12e86c.tar.bz2
historical-8c21909d621236e15795aaa42f9c76110c12e86c.zip
Modified the gcc34 patch to not change functionality. Made CFLAGS aware.
Diffstat (limited to 'net-irc/bnc')
-rw-r--r--net-irc/bnc/ChangeLog6
-rw-r--r--net-irc/bnc/Manifest12
-rw-r--r--net-irc/bnc/bnc-2.8.6-r1.ebuild16
-rw-r--r--net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch25
4 files changed, 33 insertions, 26 deletions
diff --git a/net-irc/bnc/ChangeLog b/net-irc/bnc/ChangeLog
index bebf35aac9da..3cf3daaac379 100644
--- a/net-irc/bnc/ChangeLog
+++ b/net-irc/bnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/bnc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.8 2004/06/21 22:52:56 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.9 2004/06/21 23:30:48 swegener Exp $
+
+ 22 Jun 2004; Sven Wegener <swegener@gentoo.org>
+ files/bnc-2.8.6-gotofail-labelfix.patch, bnc-2.8.6-r1.ebuild:
+ Modified the gcc34 patch to not change functionality. Made CFLAGS aware.
22 Jun 2004; Bryan Østergaard <kloeri@gentoo.org> +bnc-2.8.6-r1.ebuild files/bncsetup.patch:
Add patch to bncsetup, thanks to redeeman and GurliGebis.
diff --git a/net-irc/bnc/Manifest b/net-irc/bnc/Manifest
index 66e222ae0f02..d5c8f16d03fc 100644
--- a/net-irc/bnc/Manifest
+++ b/net-irc/bnc/Manifest
@@ -1,10 +1,10 @@
-MD5 02e2c0b30baa141024e507d423edead0 bnc-2.8.6-r1.ebuild 1062
-MD5 1c272033ebb22fe4329f8d35e9402bcb bnc-2.8.6.ebuild 1020
+MD5 821b6cdbfbb69b5588561e539f8f27d6 ChangeLog 1560
MD5 2c4fdb759c0b2c50f6d93b6946ded966 bnc-2.6.4.ebuild 910
-MD5 4b01b794ff6216f41edc44ae8829faff ChangeLog 1368
+MD5 48ceb67e22e2d612d819e7b111d536cf bnc-2.8.6-r1.ebuild 1152
+MD5 1c272033ebb22fe4329f8d35e9402bcb bnc-2.8.6.ebuild 1020
MD5 b548677db8b820721075cb8c151fe399 metadata.xml 250
-MD5 b9427cecfd47491ea920651f047adb36 files/digest-bnc-2.8.6-r1 59
-MD5 6befce77dfbc40849385319dae3c3120 files/bnc-2.8.6-gotofail-labelfix.patch 701
+MD5 cab5a601ff0bb6f73c793cbe7a278f4e files/bnc-2.8.6-gotofail-labelfix.patch 538
+MD5 e8809f89a22004c0092dcb8502e17bfa files/bncsetup.patch 1212
MD5 3aecb068876402e1030f940f6caa829a files/digest-bnc-2.6.4 59
MD5 b9427cecfd47491ea920651f047adb36 files/digest-bnc-2.8.6 59
-MD5 e8809f89a22004c0092dcb8502e17bfa files/bncsetup.patch 1212
+MD5 b9427cecfd47491ea920651f047adb36 files/digest-bnc-2.8.6-r1 59
diff --git a/net-irc/bnc/bnc-2.8.6-r1.ebuild b/net-irc/bnc/bnc-2.8.6-r1.ebuild
index 165d003a067c..4672b41694d5 100644
--- a/net-irc/bnc/bnc-2.8.6-r1.ebuild
+++ b/net-irc/bnc/bnc-2.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.6-r1.ebuild,v 1.1 2004/06/21 22:52:56 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.6-r1.ebuild,v 1.2 2004/06/21 23:30:48 swegener Exp $
inherit eutils
@@ -20,16 +20,22 @@ DEPEND="virtual/glibc"
S=${WORKDIR}/${MY_P}
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
# fix gcc-3.4 compilation, bug #54689.
epatch ${FILESDIR}/bnc-2.8.6-gotofail-labelfix.patch
epatch ${FILESDIR}/bncsetup.patch
- econf || die
- emake || die
- mv mkpasswd bncmkpasswd
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake OPTS="${CFLAGS}" || die "emake failed"
}
src_install() {
+ mv mkpasswd bncmkpasswd
dodoc CHANGES README
dobin bnc bncchk bncsetup bncmkpasswd || die
insinto /usr/share/${MY_P}
diff --git a/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch b/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch
index a4ced2e47223..b04f1e98419a 100644
--- a/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch
+++ b/net-irc/bnc/files/bnc-2.8.6-gotofail-labelfix.patch
@@ -1,26 +1,23 @@
-diff -Naur bnc2.8.6.orig/cmds.c bnc2.8.6/cmds.c
---- bnc2.8.6.orig/cmds.c 2002-07-13 04:48:13.000000000 +0200
-+++ bnc2.8.6/cmds.c 2004-06-21 23:32:49.057908144 +0200
-@@ -503,8 +503,8 @@
- tprintf(&cptr->loc, "NOTICE AUTH :Docked session %i\n", dptr->srv.fd);
+diff -u bnc2.8.6/cmds.c bnc2.8.6-gcc34/cmds.c
+--- bnc2.8.6/cmds.c 2002-07-13 02:48:13.000000000 +0000
++++ bnc2.8.6-gcc34/cmds.c 2004-06-21 23:16:39.809362023 +0000
+@@ -504,8 +504,8 @@
}
}
-- tprintf(&cptr->loc, "NOTICE AUTH :End of dock list\n");
- nodock:
-+ tprintf(&cptr->loc, "NOTICE AUTH :End of dock list\n");
+ tprintf(&cptr->loc, "NOTICE AUTH :End of dock list\n");
+-nodock:
}
++nodock:
tprintf(&cptr->loc, "NOTICE AUTH :type /quote help for basic list of commands and usage\n");
}
-@@ -1066,10 +1066,9 @@
- vhost = vhost_ptr->vhost;
+ return w;
+@@ -1067,8 +1067,8 @@
break;
}
-- }
+ }
-vfast_fail:
-+ }
}
--
+vfast_fail:
+
res = inet_aton(vhost, &addr);
if(res == 1)
- {