summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-05-04 18:34:49 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-05-04 18:34:49 +0000
commitdf853de79708fea9942612d22f56ea9d9ed09ec7 (patch)
tree153a786d09d398fb420a426b14d43f0fafe75b7a /net-im
parentVersion bumped. Ebuild submitted by Jiri VERUNEK <verunek@vol.cz> in #20391. (diff)
downloadhistorical-df853de79708fea9942612d22f56ea9d9ed09ec7.tar.gz
historical-df853de79708fea9942612d22f56ea9d9ed09ec7.tar.bz2
historical-df853de79708fea9942612d22f56ea9d9ed09ec7.zip
Version bumped. Ebuild submitted by Jiri VERUNEK <verunek@vol.cz> in #20391.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/linphone/Manifest2
-rw-r--r--net-im/linphone/files/digest-linphone-0.10.21
-rw-r--r--net-im/linphone/linphone-0.10.2.ebuild51
3 files changed, 53 insertions, 1 deletions
diff --git a/net-im/linphone/Manifest b/net-im/linphone/Manifest
index 0225752afa08..555d01e7b3c0 100644
--- a/net-im/linphone/Manifest
+++ b/net-im/linphone/Manifest
@@ -1,4 +1,4 @@
-MD5 6b449ae5ec1719410fa15b8c8549e56e ChangeLog 592
+MD5 ee8d74c6532fb9d21587e68a3f394bc7 ChangeLog 778
MD5 a3d8f2f4dc288b2d1ac1fb07c1f918e5 linphone-0.9.0.ebuild 1373
MD5 c59b6d0f0d832aefbce563233b014d54 linphone-0.9.0-r1.ebuild 1376
MD5 69a481c7d3865479a4e4286251e6a736 linphone-0.10.2.ebuild 1448
diff --git a/net-im/linphone/files/digest-linphone-0.10.2 b/net-im/linphone/files/digest-linphone-0.10.2
new file mode 100644
index 000000000000..276919c36200
--- /dev/null
+++ b/net-im/linphone/files/digest-linphone-0.10.2
@@ -0,0 +1 @@
+MD5 b61a3ffb88791ef22c1462bacbba2aee linphone-0.10.2.tar.gz 2701500
diff --git a/net-im/linphone/linphone-0.10.2.ebuild b/net-im/linphone/linphone-0.10.2.ebuild
new file mode 100644
index 000000000000..e377da613f99
--- /dev/null
+++ b/net-im/linphone/linphone-0.10.2.ebuild
@@ -0,0 +1,51 @@
+IUSE="doc gtk nls xv alsa"
+
+DESCRIPTION="Linphone is a Web phone with a GNOME interface. It let you make two-party calls over IP networks such as the Internet. It uses the IETF protocols SIP (Session Initiation Protocol) and RTP (Realtime Transport Protocol) to make calls, so it should be able to communicate with other SIP-based Web phones. With several codecs available, it can be used with high speed connections as well as 28k modems."
+HOMEPAGE="http://www.linphone.org/?lang=us"
+SRC_URI="http://simon.morlat.free.fr/download/${PV}/sources/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="dev-libs/glib
+ >=net-libs/libosip-0.9.6
+ dev-util/pkgconfig
+ xv? ( dev-lang/nasm )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2 )
+ gnome? ( gnome-base/gnome-panel
+ gnome-base/libgnome
+ gnome-base/libgnomeui )
+ alsa? ( >media-sound/alsa-driver-0.5 )
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+
+ local myconf
+
+ if use gnome
+ then
+ use gtk2 && myconf="${myconf} --enable-platform-gnome-2"
+ else
+ use gnome || myconf="${myconf}--enable-gnome_ui=no"
+ fi
+
+ if use gtk && use doc
+ then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ econf \
+ `use_enable alsa` \
+ `use_enable nls` \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ dodoc ABOUT-NLS COPYING README AUTHORS BUGS INSTALL NEWS ChangeLog TODO
+ einstall PIXDESTDIR=${D} || die
+}