summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2002-12-22 13:45:34 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2002-12-22 13:45:34 +0000
commitdbc8e13f1064338485835e4d44254f99e78f5ee1 (patch)
tree8b863d2c359e40acd867116d42e9aa9623c3afb7 /net-ftp
parenttypo (diff)
downloadhistorical-dbc8e13f1064338485835e4d44254f99e78f5ee1.tar.gz
historical-dbc8e13f1064338485835e4d44254f99e78f5ee1.tar.bz2
historical-dbc8e13f1064338485835e4d44254f99e78f5ee1.zip
New version
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpcube/ChangeLog6
-rw-r--r--net-ftp/ftpcube/files/digest-ftpcube-0.4.01
-rw-r--r--net-ftp/ftpcube/ftpcube-0.4.0.ebuild35
3 files changed, 42 insertions, 0 deletions
diff --git a/net-ftp/ftpcube/ChangeLog b/net-ftp/ftpcube/ChangeLog
index 663f6f36730d..a3bcba797714 100644
--- a/net-ftp/ftpcube/ChangeLog
+++ b/net-ftp/ftpcube/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Author: José Alberto Suárez López <bass@gentoo.org>
+*ftpcube-0.4.4 (22 Dic 2002)
+
+ 22 Dic 2022; J.Alberto Suarez L. <bass@gentoo.org> ftpcube-0.4.0.ebuild:
+ New version.
+ A few changes in the ebuild, now use WxPython.
+
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*ftpcube-0.3.3 (20 Aug 2002)
diff --git a/net-ftp/ftpcube/files/digest-ftpcube-0.4.0 b/net-ftp/ftpcube/files/digest-ftpcube-0.4.0
new file mode 100644
index 000000000000..6ad7b8b47f74
--- /dev/null
+++ b/net-ftp/ftpcube/files/digest-ftpcube-0.4.0
@@ -0,0 +1 @@
+MD5 ced53fcea9dd2dc8704fe3c311e7180f ftpcube-0.4.0.tar.gz 107685
diff --git a/net-ftp/ftpcube/ftpcube-0.4.0.ebuild b/net-ftp/ftpcube/ftpcube-0.4.0.ebuild
new file mode 100644
index 000000000000..086b9fdf180e
--- /dev/null
+++ b/net-ftp/ftpcube/ftpcube-0.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.4.0.ebuild,v 1.1 2002/12/22 13:45:34 bass Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Graphic ftp client written in python and gtk"
+SRC_URI="mirror://sourceforge/ftpcube/${P}.tar.gz"
+HOMEPAGE="http://ftpcube.sourceforge.net/"
+DEPEND="dev-python/wxPython"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~x86 ~sparc"
+
+src_compile() {
+ python setup.py clean || die "clean fails"
+}
+
+src_install() {
+ dobin ftpcube
+ dodir /usr/lib/python2.2/site-packages/libftpcube
+ dodir /usr/lib/python2.2/site-packages/libftpcube/archtypes
+ dodir /usr/lib/python2.2/site-packages/libftpcube/wxPyColourChooser
+ insinto /usr/lib/python2.2/site-packages/libftpcube
+ doins libftpcube/*
+ insinto /usr/lib/python2.2/site-packages/libftpcube/archtypes
+ doins libftpcube/archtypes/*
+ insinto /usr/lib/python2.2/site-packages/libftpcube/wxPyColourChooser
+ doins libftpcube/wxPyColourChooser/*
+ dodir /usr/share/ftpcube/icons
+ insinto /usr/share/ftpcube/icons
+ doins icons/*
+ dosym /usr/share/ftpcube/icons/ftpcube.xpm /usr/share/icons
+ dodoc CHANGELOG README TODO COPYING COPYING.ICONS
+}