summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-09-06 19:00:01 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-09-06 19:00:01 +0000
commit8df7e03252aac57c97e0c451c5e8b1be0040b2b7 (patch)
tree541e5840c6a3c4602b93bfb8f6c030996179401b /net-ftp
parentoftpd is now supported for rc5/rc6 inits (diff)
downloadhistorical-8df7e03252aac57c97e0c451c5e8b1be0040b2b7.tar.gz
historical-8df7e03252aac57c97e0c451c5e8b1be0040b2b7.tar.bz2
historical-8df7e03252aac57c97e0c451c5e8b1be0040b2b7.zip
New version.
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.4.31
-rw-r--r--net-ftp/lftp/lftp-2.4.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-ftp/lftp/files/digest-lftp-2.4.3 b/net-ftp/lftp/files/digest-lftp-2.4.3
new file mode 100644
index 000000000000..c6828a9fb363
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.4.3
@@ -0,0 +1 @@
+MD5 3692e8f252c97b7ed9185ab9b51d1ea1 lftp-2.4.3.tar.bz2
diff --git a/net-ftp/lftp/lftp-2.4.3.ebuild b/net-ftp/lftp/lftp-2.4.3.ebuild
new file mode 100644
index 000000000000..15d60ae2335a
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.4.3.ebuild,v 1.1 2001/09/06 19:00:01 g2boojum Exp $
+
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Groovy little ftp client"
+SRC_URI="ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${A}
+ http://metalab.unc.edu/pub/Linux/system/network/file-transfer/${A}"
+
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ -z "`use ssl`" ] ; then
+ myconf="$myconf --without-ssl"
+ fi
+
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+
+ try ./configure --prefix=/usr --sysconfdir=/etc/lftp --with-modules --mandir=/usr/share/man $myconf
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D}/usr sysconfdir=${D}/etc/lftp mandir=${D}/usr/share/man install
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS NEWS
+ dodoc README* THANKS TODO
+
+}
+
+
+
+
+