summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-10-07 07:00:25 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-10-07 07:00:25 +0000
commit751e69b290a375a25d376fe1e2723bb4fc0064d9 (patch)
treedd848736429b36554539efaec017bf35672a0400 /net-ftp
parentFixing the DEPEND to use only cpufrequtils-002 or greater, since 001 has know... (diff)
downloadhistorical-751e69b290a375a25d376fe1e2723bb4fc0064d9.tar.gz
historical-751e69b290a375a25d376fe1e2723bb4fc0064d9.tar.bz2
historical-751e69b290a375a25d376fe1e2723bb4fc0064d9.zip
version bump fixing some bugs and adding a couple of features. removed older ebuilds too
Package-Manager: portage-2.1.2_pre2
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog9
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.5.53
-rw-r--r--net-ftp/lftp/lftp-3.5.5.ebuild62
3 files changed, 73 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 3030378ae499..edb3060bdcd0 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.117 2006/09/13 18:18:07 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.118 2006/10/07 07:00:25 dragonheart Exp $
+
+*lftp-3.5.5 (07 Oct 2006)
+
+ 07 Oct 2006; Daniel Black <dragonheart@gentoo.org> -lftp-3.4.4.ebuild,
+ -lftp-3.5.1.ebuild, +lftp-3.5.5.ebuild:
+ version bump fixing some bugs and adding a couple of features. removed older
+ ebuilds too
09 Aug 2006; Daniel Black <dragonheart@gentoo.org>
-files/lftp-3.5.2-gnutls-segv.patch,
diff --git a/net-ftp/lftp/files/digest-lftp-3.5.5 b/net-ftp/lftp/files/digest-lftp-3.5.5
new file mode 100644
index 000000000000..36185da8994e
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.5.5
@@ -0,0 +1,3 @@
+MD5 ba379944f9408df1cc260add8b832b69 lftp-3.5.5.tar.bz2 1324088
+RMD160 56f2ad191ac2468b1d6fb643f824322c6b186d0f lftp-3.5.5.tar.bz2 1324088
+SHA256 7c5c4cf269b9bb560466ee4b599ecf6613867973b551fe0a87ed6bfd346121d6 lftp-3.5.5.tar.bz2 1324088
diff --git a/net-ftp/lftp/lftp-3.5.5.ebuild b/net-ftp/lftp/lftp-3.5.5.ebuild
new file mode 100644
index 000000000000..1f4812c26429
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.5.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.5.5.ebuild,v 1.1 2006/10/07 07:00:25 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+
+#SRC_URI="http://the.wiretapped.net/mirrors/lftp/${P}.tar.bz2"
+# Was a bit too slow and unreliable last time I tried (dragonheart)
+SRC_URI="ftp://lftp.yar.ru/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ !ppc-macos? ( >=sys-libs/readline-5.1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ use ppc-macos && myconf="${myconf} --with-included-readline"
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}