summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-10-09 12:06:44 +0000
committerPeter Volkov <pva@gentoo.org>2009-10-09 12:06:44 +0000
commit1b9dd58e1fca931a7cc223c3b81112b7db36c24f (patch)
treee0a552b3fb7ab0e28ca3e15300d72dd38a32d6d1 /net-firewall
parentVersion bump, bug #281617, thank Vieri for this work. (diff)
downloadhistorical-1b9dd58e1fca931a7cc223c3b81112b7db36c24f.tar.gz
historical-1b9dd58e1fca931a7cc223c3b81112b7db36c24f.tar.bz2
historical-1b9dd58e1fca931a7cc223c3b81112b7db36c24f.zip
Version bump, bug #281617, thank Vieri for this work.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-lite/ChangeLog7
-rw-r--r--net-firewall/shorewall-lite/shorewall-lite-4.2.11.ebuild65
-rw-r--r--net-firewall/shorewall-perl/ChangeLog8
-rw-r--r--net-firewall/shorewall-perl/shorewall-perl-4.2.11.1.ebuild59
-rw-r--r--net-firewall/shorewall-shell/ChangeLog7
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.2.11.ebuild57
-rw-r--r--net-firewall/shorewall6/ChangeLog7
-rw-r--r--net-firewall/shorewall6/shorewall6-4.2.11.ebuild72
8 files changed, 278 insertions, 4 deletions
diff --git a/net-firewall/shorewall-lite/ChangeLog b/net-firewall/shorewall-lite/ChangeLog
index c9323d4ce366..8e177015cd22 100644
--- a/net-firewall/shorewall-lite/ChangeLog
+++ b/net-firewall/shorewall-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-lite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.55 2009/06/08 04:01:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.56 2009/10/09 12:06:31 pva Exp $
+
+*shorewall-lite-4.2.11 (09 Oct 2009)
+
+ 09 Oct 2009; Peter Volkov <pva@gentoo.org> +shorewall-lite-4.2.11.ebuild:
+ Version bump, bug #281617, thank Vieri for this work.
08 Jun 2009; Jeroen Roovers <jer@gentoo.org> shorewall-lite-4.0.15.ebuild:
Stable for HPPA (bug #256064).
diff --git a/net-firewall/shorewall-lite/shorewall-lite-4.2.11.ebuild b/net-firewall/shorewall-lite/shorewall-lite-4.2.11.ebuild
new file mode 100644
index 000000000000..043db3222bbd
--- /dev/null
+++ b/net-firewall/shorewall-lite/shorewall-lite-4.2.11.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/shorewall-lite-4.2.11.ebuild,v 1.1 2009/10/09 12:06:31 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_PN="${PN/-lite/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+MY_P_DOCS="${MY_PN}-docs-html-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="An iptables-based firewall whose config is handled by a normal Shorewall."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/shorewall-lite
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}/shorewall-lite" shorewall-lite
+
+ dodoc changelog.txt releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo "There are man pages for shorewall-lite(8) and for each"
+ einfo "configuration file."
+ einfo
+ einfo "You should have already generated a firewall script with"
+ einfo "'shorewall compile' on the administrative Shorewall."
+ einfo "Please refer to"
+ einfo "http://www.shorewall.net/CompiledPrograms.html"
+ einfo
+ einfo "If you intend to use the 2.6 IPSEC Support, you must retrieve the"
+ einfo "kernel patches from http://shorewall.net/pub/shorewall/contrib/IPSEC/"
+ einfo "or install kernel 2.6.16+ as well as a recent Netfilter iptables"
+ einfo "and compile it with support for policy match."
+ einfo
+ einfo "Note that /etc/shorewall-lite/shorewall.conf has been renamed"
+ einfo "to /etc/shorewall-lite/shorewall-lite.conf"
+ einfo
+ einfo "Known problems:"
+ einfo "http://shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+}
diff --git a/net-firewall/shorewall-perl/ChangeLog b/net-firewall/shorewall-perl/ChangeLog
index dab63606e57d..824aad0e4860 100644
--- a/net-firewall/shorewall-perl/ChangeLog
+++ b/net-firewall/shorewall-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-perl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.33 2009/06/08 04:02:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.34 2009/10/09 12:03:31 pva Exp $
+
+*shorewall-perl-4.2.11.1 (09 Oct 2009)
+
+ 09 Oct 2009; Peter Volkov <pva@gentoo.org>
+ +shorewall-perl-4.2.11.1.ebuild:
+ Version bump, bug #281617, thank Vieri for this work.
08 Jun 2009; Jeroen Roovers <jer@gentoo.org> shorewall-perl-4.0.15.ebuild:
Stable for HPPA (bug #256064).
diff --git a/net-firewall/shorewall-perl/shorewall-perl-4.2.11.1.ebuild b/net-firewall/shorewall-perl/shorewall-perl-4.2.11.1.ebuild
new file mode 100644
index 000000000000..777a994b86dc
--- /dev/null
+++ b/net-firewall/shorewall-perl/shorewall-perl-4.2.11.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/shorewall-perl-4.2.11.1.ebuild,v 1.1 2009/10/09 12:03:31 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/-perl/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall Perl-based compiler that allows faster compilation and execution."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ dev-lang/perl
+ !<net-firewall/shorewall-4.0"
+RDEPEND="${DEPEND}"
+
+PDEPEND="=net-firewall/shorewall-common-${MY_PV_BASE}*"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ elog "In order to use the Perl compiler you need to add"
+ elog "SHOREWALL_COMPILER=perl"
+ elog "to shorewall.conf unless you did not install the Shell compiler."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+ elog "${PN} will be removed in the future."
+ elog "Please consider emerging the latest version of ${MY_PN}."
+}
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index f262facc824e..c855ccf9b94e 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-shell
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.30 2009/06/08 04:01:12 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.31 2009/10/09 12:04:25 pva Exp $
+
+*shorewall-shell-4.2.11 (09 Oct 2009)
+
+ 09 Oct 2009; Peter Volkov <pva@gentoo.org> +shorewall-shell-4.2.11.ebuild:
+ Version bump, bug #281617, thank Vieri for this work.
08 Jun 2009; Jeroen Roovers <jer@gentoo.org>
shorewall-shell-4.0.15.ebuild:
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.2.11.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.2.11.ebuild
new file mode 100644
index 000000000000..191086682bdc
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.2.11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.2.11.ebuild,v 1.1 2009/10/09 12:04:25 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # shorewall-common version to use (ignoring upstream "compatibility matrix" for now as it is not always updated at the same time as the software is released)
+
+MY_PN="${PN/-shell/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+RDEPEND="${DEPEND}"
+
+PDEPEND="=net-firewall/shorewall-common-${MY_PV_BASE}*"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ elog "In order to use the shell compiler you need to add"
+ elog "SHOREWALL_COMPILER=shell"
+ elog "to shorewall.conf unless you do not have the Perl compiler."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+ elog "${PN} will be removed in the future."
+ elog "Please consider emerging the latest version of ${MY_PN}."
+}
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index 120ea3e10363..2db3d07a566e 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.9 2009/06/22 04:33:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.10 2009/10/09 12:06:44 pva Exp $
+
+*shorewall6-4.2.11 (09 Oct 2009)
+
+ 09 Oct 2009; Peter Volkov <pva@gentoo.org> +shorewall6-4.2.11.ebuild:
+ Version bump, bug #281617, thank Vieri for this work.
22 Jun 2009; Jeroen Roovers <jer@gentoo.org> shorewall6-4.2.9.ebuild:
Marked ~hppa (bug #256063).
diff --git a/net-firewall/shorewall6/shorewall6-4.2.11.ebuild b/net-firewall/shorewall6/shorewall6-4.2.11.ebuild
new file mode 100644
index 000000000000..fdddae5e0695
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.2.11.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.2.11.ebuild,v 1.1 2009/10/09 12:06:44 pva Exp $
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~x86"
+
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-perl-${MY_PV_BASE}
+ dev-perl/Socket6
+ !<net-firewall/shorewall-4.0"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "doinitd failed"
+
+ dodoc releasenotes.txt
+ if use doc; then
+ cp -pR Samples6 "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo "There are man pages for ${PN}(8)."
+ einfo "For additional information, see"
+ einfo "http://www.shorewall.net/IPV6Support.html"
+ use doc && einfo "Sample configuration files are in /usr/share/doc/${PF}."
+ einfo
+ elog "If you wish to include DNS names in your IPv6 configuration files,"
+ elog "you must have Perl 5.10 and must emerge dev-perl/Socket6."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+}