summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-02-08 19:00:09 +0000
committerAlin Năstac <mrness@gentoo.org>2006-02-08 19:00:09 +0000
commit9a8687642e733db395716bbf6383ed5e14c160fb (patch)
treef08dd18d51a4f5528935c50597a79a0cb5e30530 /net-dialup
parentstable amd64 (diff)
downloadhistorical-9a8687642e733db395716bbf6383ed5e14c160fb.tar.gz
historical-9a8687642e733db395716bbf6383ed5e14c160fb.tar.bz2
historical-9a8687642e733db395716bbf6383ed5e14c160fb.zip
Version bump that fixes incompatibilities with kernels >= 2.6.14 (#122103).
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/bewan-adsl/ChangeLog9
-rw-r--r--net-dialup/bewan-adsl/Manifest14
-rw-r--r--net-dialup/bewan-adsl/bewan-adsl-0.9.3.ebuild88
-rw-r--r--net-dialup/bewan-adsl/files/digest-bewan-adsl-0.9.31
4 files changed, 104 insertions, 8 deletions
diff --git a/net-dialup/bewan-adsl/ChangeLog b/net-dialup/bewan-adsl/ChangeLog
index 5fcadda5d51e..073df6f589cd 100644
--- a/net-dialup/bewan-adsl/ChangeLog
+++ b/net-dialup/bewan-adsl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/bewan-adsl
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/ChangeLog,v 1.5 2005/02/25 06:40:35 mrness Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/ChangeLog,v 1.6 2006/02/08 19:00:09 mrness Exp $
+
+*bewan-adsl-0.9.3 (08 Feb 2006)
+
+ 08 Feb 2006; Alin Nastac <mrness@gentoo.org> +bewan-adsl-0.9.3.ebuild:
+ Version bump that fixes incompatibilities with kernels >= 2.6.14 (#122103).
*bewan-adsl-0.9.0 (25 Feb 2005)
diff --git a/net-dialup/bewan-adsl/Manifest b/net-dialup/bewan-adsl/Manifest
index a13baa4e019c..01eb716f6f6b 100644
--- a/net-dialup/bewan-adsl/Manifest
+++ b/net-dialup/bewan-adsl/Manifest
@@ -1,17 +1,19 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
+MD5 36ef61b211d19830816f09a020f5390f ChangeLog 1255
MD5 d0efc1235be91ab4c58bddd5f1b38b59 bewan-adsl-0.8.7.ebuild 2353
MD5 bd16ca2d11981fbdae9a990f3af11ff5 bewan-adsl-0.9.0.ebuild 2127
-MD5 cab4920134945b23afc63871d177e72b ChangeLog 1070
-MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
+MD5 492ec7a7a8a9b9f2a31ed9cb55491bf8 bewan-adsl-0.9.3.ebuild 2294
MD5 0572b020603885cca9caf29f664e2f44 files/bewan-adsl-kill-timeout.patch 1093
MD5 96c16fb5ea4312bc3e4b2300e0a7ce69 files/digest-bewan-adsl-0.8.7 59
MD5 d93f0e970aec5e90512811f43cd55c48 files/digest-bewan-adsl-0.9.0 59
+MD5 0582f71161d9846420b9ee9bd856e9b2 files/digest-bewan-adsl-0.9.3 82
+MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFCHsh2jiC39V7gKu0RAqkoAKDHzoKqeE2wxD8ekY1PhTz+d5UZjACgoRX6
-HW4rORLpZ+WNHm2RurEQjgE=
-=K4lW
+iD8DBQFD6j/LjG8pv1lIUX4RAvvlAJ9yb0g870ioDMOBBHssPW6fh4uP/gCg1XaF
+1SZOKqWCY4tqyX346+FaHbQ=
+=OlQ+
-----END PGP SIGNATURE-----
diff --git a/net-dialup/bewan-adsl/bewan-adsl-0.9.3.ebuild b/net-dialup/bewan-adsl/bewan-adsl-0.9.3.ebuild
new file mode 100644
index 000000000000..46512b28784e
--- /dev/null
+++ b/net-dialup/bewan-adsl/bewan-adsl-0.9.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/bewan-adsl-0.9.3.ebuild,v 1.1 2006/02/08 19:00:09 mrness Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Bewan ADSL PCI&USB st driver"
+SRC_URI="http://www.bewan.com/bewan/drivers/A1012-A1006-A904-A888-A983-${PV}.tgz"
+HOMEPAGE="http://www.bewan.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="usb doc"
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+
+S="${WORKDIR}/unicorn"
+
+PCI_S="${S}/unicorn_pci"
+USB_S="${S}/unicorn_usb"
+BUILD_PARAMS="KERNEL_SOURCES=${KV_DIR} KVERS=${KV_FULL}"
+BUILD_TARGETS="modules"
+CONFIG_CHECK="ATM"
+ATM_ERROR="This driver requires you to build your kernel with support for Asynchronous Transfer Mode (ATM)"
+
+pkg_setup() {
+ MODULE_NAMES="unicorn_pci_atm(extra:${PCI_S}) unicorn_pci_eth(extra:${PCI_S})"
+ use usb && MODULE_NAMES="${MODULE_NAMES} unicorn_usb_atm(extra:${USB_S}) unicorn_usb_eth(extra:${USB_S})"
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix up broken Makefiles
+ convert_to_m "${PCI_S}/Makefile"
+ use usb && convert_to_m "${USB_S}/Makefile"
+}
+
+src_compile() {
+ einfo "Build common library"
+ cd "${S}/libm"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
+
+ einfo "Building tools"
+ cd "${S}/tools"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+ cd "${S}/unicorntest"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ cd "${S}"
+ #Install tools
+ dodir /usr/bin
+ cd "${S}/tools" && einstall DESTDIR="${D}" prefix=/usr || \
+ die "Cannot install tools"
+ cd "${S}/unicorntest" && einstall DESTDIR="${D}" prefix=/usr || \
+ die "Cannot install unicorntest"
+ doman "${S}/Documentation/unicorntest.8"
+
+ if use doc; then
+ #Install documantation
+ cd "${S}"
+ dodoc README
+ docinto RFCs
+ dodoc RFCs/*
+ docinto scripts
+ dodoc scripts/*
+ fi
+}
+
+pkg_postinst() {
+ einfo "To load the driver do 'modprobe unicorn_atm' and 'modprobe unicorn_pci' "
+ einfo "and then do what you want with it (configure your pppd)"
+ einfo "OR"
+ einfo "it's time to look at the README file, the scripts directory gives you"
+ einfo "two comprehensive ways to load the driver, configure pppd and launch it."
+
+ linux-mod_pkg_postinst
+}
diff --git a/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.9.3 b/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.9.3
new file mode 100644
index 000000000000..9dd6e6317c42
--- /dev/null
+++ b/net-dialup/bewan-adsl/files/digest-bewan-adsl-0.9.3
@@ -0,0 +1 @@
+MD5 ff9829f03168279a079d05aea780ee99 A1012-A1006-A904-A888-A983-0.9.3.tgz 1176291