summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-12-04 07:14:52 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-12-04 07:14:52 +0000
commitecefc1170d0d394ff4ad2ea12809fb03c391547b (patch)
treeb756db0fee2ef3575a7a70e132b27c56376e1f8a /net-dialup/sercd/sercd-3.0.0-r1.ebuild
parentStable on amd64 and x86, wrt bug #530626 (diff)
downloadhistorical-ecefc1170d0d394ff4ad2ea12809fb03c391547b.tar.gz
historical-ecefc1170d0d394ff4ad2ea12809fb03c391547b.tar.bz2
historical-ecefc1170d0d394ff4ad2ea12809fb03c391547b.zip
Revision bump: EAPI 5, epatch_user, replace einstall with default src_install phase function call wrt bug #521584, replace /var/lock with /run/lock, replace /var/run with /run in default configuration. Drop old revision
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x1F357D42
Diffstat (limited to 'net-dialup/sercd/sercd-3.0.0-r1.ebuild')
-rw-r--r--net-dialup/sercd/sercd-3.0.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-dialup/sercd/sercd-3.0.0-r1.ebuild b/net-dialup/sercd/sercd-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..ee013aee0ec8
--- /dev/null
+++ b/net-dialup/sercd/sercd-3.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/sercd/sercd-3.0.0-r1.ebuild,v 1.1 2014/12/04 07:14:50 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="RFC2217-compliant serial port redirector"
+HOMEPAGE="http://sourceforge.net/projects/sercd"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="xinetd"
+
+RDEPEND="xinetd? ( virtual/inetd )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ epatch_user
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/${PN}.xinetd" "${PN}"
+ fi
+}