summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-07-19 01:46:52 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-07-19 01:46:52 +0000
commitb62f50369f46b34405ba75804e4e9066ee770e45 (patch)
tree0f1337b752606d8b04674e8ff642c057ae1e881c /net-analyzer/mrtg/mrtg-2.14.5.ebuild
parentFix esdcompat patch that was incomplete. (diff)
downloadhistorical-b62f50369f46b34405ba75804e4e9066ee770e45.tar.gz
historical-b62f50369f46b34405ba75804e4e9066ee770e45.tar.bz2
historical-b62f50369f46b34405ba75804e4e9066ee770e45.zip
2.14.5 version bump.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'net-analyzer/mrtg/mrtg-2.14.5.ebuild')
-rw-r--r--net-analyzer/mrtg/mrtg-2.14.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/mrtg/mrtg-2.14.5.ebuild b/net-analyzer/mrtg/mrtg-2.14.5.ebuild
new file mode 100644
index 000000000000..497a7dd3a061
--- /dev/null
+++ b/net-analyzer/mrtg/mrtg-2.14.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mrtg/mrtg-2.14.5.ebuild,v 1.1 2006/07/19 01:46:52 vanquirius Exp $
+
+DESCRIPTION="A tool to monitor the traffic load on network-links"
+HOMEPAGE="http://oss.oetiker.ch/mrtg/"
+SRC_URI="http://people.ee.ethz.ch/~oetiker/webtools/mrtg/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ dev-lang/perl
+ >=media-libs/gd-1.8.4"
+
+src_install () {
+ keepdir /var/lib/mrtg
+
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}"/usr/share/doc/mrtg2 "${D}"/usr/share/doc/${PF}
+
+ newinitd "${FILESDIR}"/mrtg.rc ${PN}
+ newconfd "${FILESDIR}"/mrtg.confd ${PN}
+
+}
+
+pkg_postinst(){
+ einfo "You must configure mrtg before being able to run it. Try cfgmaker."
+ einfo "The following thread may be useful:"
+ einfo "http://forums.gentoo.org/viewtopic-t-105862.html"
+}