summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam McArthur <sandymac@gentoo.org>2002-05-14 04:17:06 +0000
committerWilliam McArthur <sandymac@gentoo.org>2002-05-14 04:17:06 +0000
commit853ea73134a9d702c3bdcfc2c548a863d0c4c354 (patch)
tree5f2cf5ea83d6fa5e96d30247a1c848d83c102e44 /net-analyzer/knocker
parentadded pciutils dep (diff)
downloadhistorical-853ea73134a9d702c3bdcfc2c548a863d0c4c354.tar.gz
historical-853ea73134a9d702c3bdcfc2c548a863d0c4c354.tar.bz2
historical-853ea73134a9d702c3bdcfc2c548a863d0c4c354.zip
Added knocker, closes bug 2637
Diffstat (limited to 'net-analyzer/knocker')
-rw-r--r--net-analyzer/knocker/files/digest-knocker-0.6.61
-rw-r--r--net-analyzer/knocker/knocker-0.6.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/knocker/files/digest-knocker-0.6.6 b/net-analyzer/knocker/files/digest-knocker-0.6.6
new file mode 100644
index 000000000000..a295045f470d
--- /dev/null
+++ b/net-analyzer/knocker/files/digest-knocker-0.6.6
@@ -0,0 +1 @@
+MD5 2f84871bb975d01a432ff95c9159c47a knocker-0.6.6.tar.gz 82474
diff --git a/net-analyzer/knocker/knocker-0.6.6.ebuild b/net-analyzer/knocker/knocker-0.6.6.ebuild
new file mode 100644
index 000000000000..8829d1254c30
--- /dev/null
+++ b/net-analyzer/knocker/knocker-0.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /home/cvsroot/gentoo-x86/skel.ebuild,v 1.6 2002/05/07 03:58:19 drobbi
+ns Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Knocker is an easy to use security port scanner written in C"
+
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/knocker/${P}.tar.gz"
+
+HOMEPAGE="http://knocker.sourceforge.net"
+
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die "emake died"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog AUTHORS README BUGS TO-DO NEWS
+}