summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-08-01 19:48:28 +0000
committerDon Seiler <rizzo@gentoo.org>2003-08-01 19:48:28 +0000
commitf44114155d597e2909a8f9f4b5317cd562f0759c (patch)
tree17b9d43f77eb8ed199f3111b1a63df27be543874 /net-analyzer/cnet
parentInitial import. Thanks to Mike Gardiner for the ebuild. (diff)
downloadhistorical-f44114155d597e2909a8f9f4b5317cd562f0759c.tar.gz
historical-f44114155d597e2909a8f9f4b5317cd562f0759c.tar.bz2
historical-f44114155d597e2909a8f9f4b5317cd562f0759c.zip
Initial import. Thanks to Mike Gardiner for the ebuild.
Diffstat (limited to 'net-analyzer/cnet')
-rw-r--r--net-analyzer/cnet/Manifest4
-rw-r--r--net-analyzer/cnet/cnet-2.0.5.ebuild33
-rw-r--r--net-analyzer/cnet/files/cnet-2.0.5-gentoo.patch43
-rw-r--r--net-analyzer/cnet/files/digest-cnet-2.0.51
-rw-r--r--net-analyzer/cnet/metadata.xml10
5 files changed, 89 insertions, 2 deletions
diff --git a/net-analyzer/cnet/Manifest b/net-analyzer/cnet/Manifest
index b8ad63ababf0..c8dd35c0cb66 100644
--- a/net-analyzer/cnet/Manifest
+++ b/net-analyzer/cnet/Manifest
@@ -1,5 +1,5 @@
-MD5 29c77060a53c162f0c3f686e2f06b00c cnet-2.0.5.ebuild 771
-MD5 b60b4175fd4e77423fc915ed58159e38 ChangeLog 346
+MD5 975f150504319d33da3f4270e028ba7c cnet-2.0.5.ebuild 868
+MD5 0f7257094a7d95ba4471aa9fe54a148e ChangeLog 435
MD5 169e364920f553ebb1b1cdd3f2778f45 metadata.xml 527
MD5 5fa730e3f767e911187654f6f809257f files/digest-cnet-2.0.5 60
MD5 652fb332fa98e02524b07ee1561c6182 files/cnet-2.0.5-gentoo.patch 1363
diff --git a/net-analyzer/cnet/cnet-2.0.5.ebuild b/net-analyzer/cnet/cnet-2.0.5.ebuild
new file mode 100644
index 000000000000..6f8d43c29d65
--- /dev/null
+++ b/net-analyzer/cnet/cnet-2.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/cnet-2.0.5.ebuild,v 1.1 2003/08/01 19:48:23 rizzo Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network simulation tool"
+SRC_URI="http://www.csse.uwa.edu.au/cnet/${P}.tgz"
+HOMEPAGE="http://www.csse.uwa.edu.au/cnet"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-lang/tk-8.3.4"
+RDEPEND=""
+
+# unpacking the source
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/cnet-2.0.5-gentoo.patch
+}
+
+src_install() {
+ # these directories aren't created during the make install
+ # process, so we'll need to make them beforehand, or else
+ # we'll have nowhere to put the files
+ mkdir -p ${D}/usr/{bin,lib,share}
+ mkdir -p ${D}/usr/share/man/man1
+ # install with make now
+ make PREFIX=${D}/usr install
+}
diff --git a/net-analyzer/cnet/files/cnet-2.0.5-gentoo.patch b/net-analyzer/cnet/files/cnet-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..311bb0fc3ea5
--- /dev/null
+++ b/net-analyzer/cnet/files/cnet-2.0.5-gentoo.patch
@@ -0,0 +1,43 @@
+--- Makefile 2003-03-30 21:13:05.000000000 -0600
++++ Makefile 2003-08-01 14:26:04.000000000 -0500
+@@ -7,14 +7,14 @@
+ # It is presumed that BINDIR and MANDIR exist, so you may need
+ # to create them, and set their permissions, if necessary.
+ #
+-PREFIX = /usr/local
++PREFIX = /usr
+ #
+ BINDIR = $(PREFIX)/bin
+-CNETDIR = $(PREFIX)/cnetlib
+-MANDIR = $(PREFIX)/man/man1
++CNETDIR = $(PREFIX)/lib/cnetlib
++MANDIR = $(PREFIX)/share/man/man1
+ MANEXT = 1
+ MANFILE = $(MANDIR)/$(NAME).$(MANEXT)
+-WEBDIR = /home/httpd/html/cnet
++WEBDIR = $(CNETDIR)/html
+
+ # ---------------------------------------------------------------------
+
+--- src/Makefile.linux 2003-04-04 16:26:31.000000000 -0600
++++ src/Makefile.linux 2003-08-01 14:26:04.000000000 -0500
+@@ -29,7 +29,7 @@
+ ANSICC = gcc -ansi
+ INCLUDES = $(LIBELFINC)
+
+-CFLAGS = -O -Wall -fPIC $(INCLUDES) $(XINCLUDES)
++CFLAGS = -march=pentium3 -O3 -pipe -fPIC $(INCLUDES) $(XINCLUDES)
+
+ LD = gcc -rdynamic
+ LIBDIRS = -L/usr/X11R6/lib $(XLIBDIRS) $(LIBELFDIR)
+--- src/config.h 2003-04-25 01:08:23.000000000 -0500
++++ src/config.h 2003-08-01 14:26:04.000000000 -0500
+@@ -169,7 +169,7 @@
+ #if defined(USE_FREEBSD)
+ #define CNETPATH "%%PREFIX%%/share/cnet:%%PREFIX%%/include"
+ #else
+-#define CNETPATH "/usr/local/cnetlib:/usr/lib/cnet:/cslinux/cnetlib"
++#define CNETPATH "/usr/lib/cnetlib:/usr/lib/cnet:"
+ #endif
+
+
diff --git a/net-analyzer/cnet/files/digest-cnet-2.0.5 b/net-analyzer/cnet/files/digest-cnet-2.0.5
new file mode 100644
index 000000000000..0315d4d804c3
--- /dev/null
+++ b/net-analyzer/cnet/files/digest-cnet-2.0.5
@@ -0,0 +1 @@
+MD5 851b6935691fe08e58de40434f782b51 cnet-2.0.5.tgz 1150005
diff --git a/net-analyzer/cnet/metadata.xml b/net-analyzer/cnet/metadata.xml
new file mode 100644
index 000000000000..6d8b5114619c
--- /dev/null
+++ b/net-analyzer/cnet/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>rizzo@gentoo.org</email>
+ <name>Don Seiler</name>
+</maintainer>
+<longdescription>The cnet network simulator enables experimentation with various data-link layer, network layer, routing and transport layer networking protocols in networks consisting of any combination of point-to-point links and IEEE 802.3 Ethernet segments.</longdescription>
+</pkgmetadata>