summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-19 04:40:00 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-19 04:40:00 +0000
commita7db0c95ed78e662d04be63ef6090dee59a4b567 (patch)
tree1d0d325f0099a87689c1cd8c39de6b87d5705212 /media-video
parentver bump #53168 (diff)
downloadhistorical-a7db0c95ed78e662d04be63ef6090dee59a4b567.tar.gz
historical-a7db0c95ed78e662d04be63ef6090dee59a4b567.tar.bz2
historical-a7db0c95ed78e662d04be63ef6090dee59a4b567.zip
clean up a little and dont use $CC
Diffstat (limited to 'media-video')
-rw-r--r--media-video/xanim/Manifest14
-rw-r--r--media-video/xanim/xanim-2.80.1-r4.ebuild20
2 files changed, 22 insertions, 12 deletions
diff --git a/media-video/xanim/Manifest b/media-video/xanim/Manifest
index 1ebdb500602d..43ea7a443990 100644
--- a/media-video/xanim/Manifest
+++ b/media-video/xanim/Manifest
@@ -1,5 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 22576ef1afdc97a802dae059e4ede131 ChangeLog 2601
-MD5 0f5fd0afc995b39e7cc2aa9ad62c9898 xanim-2.80.1-r4.ebuild 3170
+MD5 aaea0b2b1b6e5bea22e14c2b3f01fc60 xanim-2.80.1-r4.ebuild 3180
MD5 6a40e5518b2aaa2929a2572c5d7ca79e files/Makefile 23423
-MD5 a04e6bf35b1c142eb7bbccfdc6c5280b files/digest-xanim-2.80.1-r4 878
MD5 cd8f40081245fb40b09b20eae7f5fd73 files/Makefile.amd64 23429
+MD5 a04e6bf35b1c142eb7bbccfdc6c5280b files/digest-xanim-2.80.1-r4 878
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.8 (GNU/Linux)
+
+iD8DBQFA08OtHTu7gpaalycRAud2AKCI6UHLfhV9xeEtG5b7r2GVD5/jIwCeLg6E
+N080Hj53twMU9FaTCiTWKHM=
+=1op+
+-----END PGP SIGNATURE-----
diff --git a/media-video/xanim/xanim-2.80.1-r4.ebuild b/media-video/xanim/xanim-2.80.1-r4.ebuild
index e6624906fdc1..c92f1c6c0b50 100644
--- a/media-video/xanim/xanim-2.80.1-r4.ebuild
+++ b/media-video/xanim/xanim-2.80.1-r4.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xanim/xanim-2.80.1-r4.ebuild,v 1.23 2004/03/14 00:50:25 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xanim/xanim-2.80.1-r4.ebuild,v 1.24 2004/06/19 04:40:00 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic gcc
DESCRIPTION="program for playing a wide variety of animation, audio and video formats"
HOMEPAGE="http://smurfland.cit.buffalo.edu/xanim/home.html"
-SLOT="0"
+
LICENSE="XAnim"
-KEYWORDS="x86 ppc sparc alpha ~mips hppa amd64 ia64"
+SLOT="0"
+KEYWORDS="x86 ppc sparc ~mips alpha hppa amd64 ia64"
+IUSE=""
RDEPEND="virtual/x11
>=sys-libs/zlib-1.1.3"
-
DEPEND="${RDEPEND}
>=sys-apps/sed-4.0.5"
@@ -82,12 +83,12 @@ src_unpack() {
src_compile() {
# -O higher than -O2 breaks for GCC3.1
- filter-flags "-O?" "-O2"
+ replace-flags -O3 -O2
filter-flags -finline-functions
# Set XA_DLL_PATH even though we statically link the mods, I guess
# this provides extensibility
- make CC="${CC}" OPTIMIZE="${CFLAGS}" \
+ make CC="$(gcc-getCC)" OPTIMIZE="${CFLAGS}" \
XA_DLL_DEF="-DXA_DLL -DXA_PRINT" XA_DLL_PATH=/usr/lib/xanim/mods \
${_XA_EXT:+ \
XA_IV32_LIB="mods/${_XA_CVID}" \
@@ -95,9 +96,8 @@ src_compile() {
XA_CVID_LIB="mods/${_XA_IV32}" }
}
-src_install () {
- into /usr
- dobin xanim
+src_install() {
+ dobin xanim || die
newman docs/xanim.man xanim.1
dodoc README
dodoc docs/README.* docs/*.readme docs/*.doc