summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2006-03-26 23:03:13 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2006-03-26 23:03:13 +0000
commit4ef7f812d31b4f0e6dc89915fb32ad9e81c34e2d (patch)
tree197ce07644f9294200dedf7179409371c0c00e20 /media-video
parentAdd support for ia64. Change the way we do the CFLAGS and GHC_CFLAGS again. M... (diff)
downloadhistorical-4ef7f812d31b4f0e6dc89915fb32ad9e81c34e2d.tar.gz
historical-4ef7f812d31b4f0e6dc89915fb32ad9e81c34e2d.tar.bz2
historical-4ef7f812d31b4f0e6dc89915fb32ad9e81c34e2d.zip
initial ebuild; older Versions on Gentoo.de Overlay
Package-Manager: portage-2.0.54
Diffstat (limited to 'media-video')
-rw-r--r--media-video/noad/ChangeLog12
-rw-r--r--media-video/noad/Manifest19
-rw-r--r--media-video/noad/files/digest-noad-0.6.0-r21
-rw-r--r--media-video/noad/files/noad-0.6.0-directoryfix.diff48
-rw-r--r--media-video/noad/files/reccmds.noad.conf1
-rw-r--r--media-video/noad/files/record-20-noad.sh53
-rw-r--r--media-video/noad/files/vdraddon.noad45
-rw-r--r--media-video/noad/metadata.xml16
-rw-r--r--media-video/noad/noad-0.6.0-r2.ebuild85
9 files changed, 280 insertions, 0 deletions
diff --git a/media-video/noad/ChangeLog b/media-video/noad/ChangeLog
new file mode 100644
index 000000000000..6d8e5dc7d8a7
--- /dev/null
+++ b/media-video/noad/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-video/noad
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.1 2006/03/26 23:03:13 hd_brummy Exp $
+
+*noad-0.6.0-r2 (26 Mar 2006)
+
+ 26 Mar 2006; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/noad-0.6.0-directoryfix.diff, +files/record-20-noad.sh,
+ +files/reccmds.noad.conf, +files/vdraddon.noad, +metadata.xml,
+ +noad-0.6.0-r2.ebuild:
+ initial ebuild; older Versions on Gentoo.de Overlay
+
diff --git a/media-video/noad/Manifest b/media-video/noad/Manifest
new file mode 100644
index 000000000000..5c0957709683
--- /dev/null
+++ b/media-video/noad/Manifest
@@ -0,0 +1,19 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 2e308e73f7b327aceb692689896d1faa ChangeLog 503
+MD5 590e1e11b8f7cff565a3edd7c719dc6b files/digest-noad-0.6.0-r2 63
+MD5 59537f1f5164f2b2bbb0c0a5d3174112 files/noad-0.6.0-directoryfix.diff 1254
+MD5 129ab2c83615337c4242c2ec9a47a3c5 files/reccmds.noad.conf 51
+MD5 5ef1ed25dd3f6d4fc5a1fa3cdf773add files/record-20-noad.sh 1231
+MD5 4dd7bddd8e2fc8e13a875799b8491196 files/vdraddon.noad 782
+MD5 a155e781925071837c62a6c0e4926a2d metadata.xml 445
+MD5 44619081db4530e181267d23c8b4d55f noad-0.6.0-r2.ebuild 2002
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2.2 (GNU/Linux)
+Comment: no further Information
+
+iD8DBQFEJx3Bdn07HTTCgIoRAgweAJ9/FQraybUqx0VehzRALQsN+UxzcACfdPWa
+EuaI4VKyq66TZ74MLPUmhnk=
+=a9q2
+-----END PGP SIGNATURE-----
diff --git a/media-video/noad/files/digest-noad-0.6.0-r2 b/media-video/noad/files/digest-noad-0.6.0-r2
new file mode 100644
index 000000000000..ebbd7f5e3f24
--- /dev/null
+++ b/media-video/noad/files/digest-noad-0.6.0-r2
@@ -0,0 +1 @@
+MD5 62947d5afec56cdb9884535d9813530d noad-0.6.0.tar.bz2 151369
diff --git a/media-video/noad/files/noad-0.6.0-directoryfix.diff b/media-video/noad/files/noad-0.6.0-directoryfix.diff
new file mode 100644
index 000000000000..23e94e858618
--- /dev/null
+++ b/media-video/noad/files/noad-0.6.0-directoryfix.diff
@@ -0,0 +1,48 @@
+taken from http://vdr-portal.de/board/thread.php?threadid=38968
+
+diff -Nur noad.old/svdrpc.cpp noad.new/svdrpc.cpp
+--- noad.old/svdrpc.cpp 2005-02-12 18:32:10.000000000 +0100
++++ noad.new/svdrpc.cpp 2005-09-13 12:52:08.000000000 +0200
+@@ -250,13 +250,30 @@
+ {
+ char *baseName = NULL;
+ char *cp = NULL;
+- char *vend = strchr(filename,'/');
+- if( vend )
++ char *fname = NULL;
++ char *vend = NULL;
++
++ asprintf(&fname, "%s", filename);
++ if(fname[strlen(fname) - 1] == '/')
++ fname[strlen(fname) - 1] = '\0';
++ vend = strrchr(fname,'/');
++ if(vend) {
++ *vend = '\0';
++ vend = strrchr(fname,'/');
++ }
++
++ if( vend && vend[1] == '_')
++ {
++ *vend = '\0';
++ vend = strrchr(fname,'/');
++ }
++
++ if( vend && strchr(vend+1, '/'))
+ vend = strchr(vend+1,'/');
+ if( vend )
+- asprintf(&baseName,"mesg %s %s",msg,vend+1);
++ asprintf(&baseName,"mesg %s '%s'",msg,vend+1);
+ else
+- asprintf(&baseName,"mesg %s %s",msg, filename);
++ asprintf(&baseName,"mesg %s '%s'",msg, filename);
+ if( baseName[strlen(baseName)-1] == '/' )
+ baseName[strlen(baseName)-1] = '\0';
+ vend = strrchr(baseName, '/');
+@@ -268,6 +285,7 @@
+
+ free(baseName);
+ free(cp);
++ free(fname);
+ }
+
+ void noadStartMessage( const char *s)
diff --git a/media-video/noad/files/reccmds.noad.conf b/media-video/noad/files/reccmds.noad.conf
new file mode 100644
index 000000000000..966642c645f5
--- /dev/null
+++ b/media-video/noad/files/reccmds.noad.conf
@@ -0,0 +1 @@
+Starte NoaD :/usr/bin/noad -a -o -O after "${2}"
diff --git a/media-video/noad/files/record-20-noad.sh b/media-video/noad/files/record-20-noad.sh
new file mode 100644
index 000000000000..75e99b6b990b
--- /dev/null
+++ b/media-video/noad/files/record-20-noad.sh
@@ -0,0 +1,53 @@
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/files/record-20-noad.sh,v 1.1 2006/03/26 23:03:13 hd_brummy Exp $
+#
+# Joerg Bornkessel <hd_brummy@gentoo.org>
+# Mathias Schwarzott <zzam@gentoo.org>
+#
+
+source /etc/conf.d/vdraddon.noad
+
+CMD="/usr/bin/noad"
+
+# Parameter to start NoAd
+# parameter are "no | liverecord | afterrecord"
+
+[[ ${VDR_USE_NOAD} != "no" ]] || return
+
+# Start NoAd after Record
+
+if [[ "${VDR_USE_NOAD}" == "afterrecord" ]] && [[ "${VDR_RECORD_STATE}" == "after" ]]; then
+
+ [[ "${NOAD_AC3}" == "yes" ]] && CMD="${CMD} -a"
+
+ [[ "${NOAD_JUMP}" == "yes" ]] && CMD="${CMD} -j"
+
+ [[ "${NOAD_OVERLAP}" == "yes" ]] && CMD="${CMD} -o"
+
+ [[ "${NOAD_MESSAGES}" == "yes" ]] && CMD="${CMD} -O"
+
+ CMD="${CMD} ${NOAD_PARAMETER}"
+
+ ${CMD} ${VDR_RECORD_STATE} "${2}"
+fi
+
+# Section for noad on timeshift
+
+if [[ "${VDR_USE_NOAD}" == "liverecord" ]]; then
+
+ [[ "${NOAD_AC3}" == "yes" ]] && CMD="${CMD} -a"
+
+ [[ "${NOAD_JUMP}" == "yes" ]] && CMD="${CMD} -j"
+
+ [[ "${NOAD_OVERLAP}" == "yes" ]] && CMD="${CMD} -o"
+
+ [[ "${NOAD_MESSAGES}" == "yes" ]] && CMD="${CMD} -O"
+
+ CMD="${CMD} --online"
+
+ CMD="${CMD} ${NOAD_PARAMETER}"
+
+ ${CMD} ${VDR_RECORD_STATE} "${2}"
+fi
+
+# uncomment for debug
+#echo $1 $2 >> /tmp/my-record-log-file
diff --git a/media-video/noad/files/vdraddon.noad b/media-video/noad/files/vdraddon.noad
new file mode 100644
index 000000000000..02ca3353c1e4
--- /dev/null
+++ b/media-video/noad/files/vdraddon.noad
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/files/vdraddon.noad,v 1.1 2006/03/26 23:03:13 hd_brummy Exp $
+
+#########
+##
+# run Noad
+# available Parameter
+# no | liverecord | afterrecord
+#
+VDR_USE_NOAD="afterrecord"
+
+## use ac3 detection
+# available Parameter
+# yes | no
+#
+NOAD_AC3="yes"
+
+## detect jumping logos
+# available Parameter
+# yes | no
+#
+NOAD_JUMP="yes"
+
+## detect overlaps
+# available Parameter
+# yes | no
+#
+NOAD_OVERLAP="yes"
+
+## send an OSD-Message to localhost:2001 for start and end
+# available Parameter
+# yes | no
+#
+NOAD_MESSAGES="yes"
+
+## add your own parameter here,
+# yust run 'noad' in konsole for more parameter
+NOAD_PARAMETER=""
+
+
+
+
+
+
diff --git a/media-video/noad/metadata.xml b/media-video/noad/metadata.xml
new file mode 100644
index 000000000000..30fd82cdda39
--- /dev/null
+++ b/media-video/noad/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>hd_brummy@gentoo.org</email>
+ <name>Joerg Bornkessel</name>
+ </maintainer>
+ <maintainer>
+ <email>zzam@gentoo.org</email>
+ <name>Mathias Schwarzott</name>
+ </maintainer>
+ <longdescription lang="en">
+ Mark commercial Breaks in VDR records.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-video/noad/noad-0.6.0-r2.ebuild b/media-video/noad/noad-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..4a561c98e6b8
--- /dev/null
+++ b/media-video/noad/noad-0.6.0-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.6.0-r2.ebuild,v 1.1 2006/03/26 23:03:13 hd_brummy Exp $
+
+inherit eutils
+
+DESCRIPTION="Mark commercial Breaks in VDR records"
+HOMEPAGE="http://http://www.rgob.com/members/theNoad/"
+SRC_URI="http://www.freepgs.com/${PN}/${P}.tar.bz2
+ mirror://vdrfiles/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ffmpeg imagemagick"
+
+DEPEND="media-libs/libmpeg2
+ media-video/vdr
+ ffmpeg? ( >=media-video/ffmpeg-0.4.8 )
+ imagemagick? ( >=media-gfx/imagemagick-6.2.4.2-r1 )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-directoryfix.diff
+
+ sed -i -e "s:-g -O3:$CXXFLAGS:" configure
+}
+
+src_compile() {
+
+ econf \
+ $(use_with ffmpeg) \
+ $(use_with imagemagick magick) \
+ --with-tools \
+ --with-mpeginlude=/usr/include/mpeg2dec
+
+ emake || die "emake faild"
+}
+
+src_install() {
+
+ dobin noad showindex
+ use imagemagick && dobin markpics
+
+ dodoc COPYING README INSTALL
+ # example scripts are installed as dokumentation
+ dodoc allnewnoad allnoad allnoadnice clearlogos noadifnew stat2html
+
+ if has_version ">=media-tv/gentoo-vdr-scripts-0.1_alpha8"
+ then
+ insinto /etc/conf.d
+ doins ${FILESDIR}/vdraddon.noad
+
+ insinto /usr/lib/vdr/record
+ doins ${FILESDIR}/record-20-noad.sh
+
+ insinto /etc/vdr/reccmds
+ doins ${FILESDIR}/reccmds.noad.conf
+ fi
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "Congratulations, you have just installed noad!,"
+ einfo "To integrate noad in VDR you should do this:"
+ echo
+ if has_version ">=media-tv/gentoo-vdr-scripts-0.1_alpha8"
+ then
+ einfo "start and set Parameter in /etc/conf.d/vdraddon.noad"
+ else
+ einfo "Add in /etc/conf.d/vdr:"
+ echo
+ einfo "RECORD=\"noad nice --statisticfile=/video/noad.stat\" "
+ fi
+ echo
+ einfo "More infos can be found on vdr.gentoo.de"
+ echo
+ einfo "Note: You can use here all pararmeters for noad,"
+ einfo "please look in the documentation of noad."
+ echo
+}