summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-15 05:58:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-15 05:58:28 +0000
commit64248129198c80f7d20f502aa98a540088208113 (patch)
tree7e8bf6a188786c4028b97f89f2266c4a2ef503ff /media-video/yanc
parentnew package for configuring nvidia hardware thingies (diff)
downloadhistorical-64248129198c80f7d20f502aa98a540088208113.tar.gz
historical-64248129198c80f7d20f502aa98a540088208113.tar.bz2
historical-64248129198c80f7d20f502aa98a540088208113.zip
new package for configuring nvidia hardware thingies
Diffstat (limited to 'media-video/yanc')
-rw-r--r--media-video/yanc/Manifest3
-rw-r--r--media-video/yanc/files/digest-yanc-0.2.01
-rw-r--r--media-video/yanc/yanc-0.2.0.ebuild63
3 files changed, 66 insertions, 1 deletions
diff --git a/media-video/yanc/Manifest b/media-video/yanc/Manifest
index 495a1b5a4c44..20772757cd9d 100644
--- a/media-video/yanc/Manifest
+++ b/media-video/yanc/Manifest
@@ -1,2 +1,3 @@
-MD5 035cc42c5aaedb6e88611502f1e2c87e yanc-0.2.0.ebuild 1358
+MD5 c5bd053ca810907f9e745664c2e129e4 yanc-0.2.0.ebuild 1516
+MD5 bb54d6e1ed73c8647b170ba562da26a9 ChangeLog 416
MD5 47b5f3091491bba33f121b7ffe96eb43 files/digest-yanc-0.2.0 63
diff --git a/media-video/yanc/files/digest-yanc-0.2.0 b/media-video/yanc/files/digest-yanc-0.2.0
new file mode 100644
index 000000000000..d7dd77ab286d
--- /dev/null
+++ b/media-video/yanc/files/digest-yanc-0.2.0
@@ -0,0 +1 @@
+MD5 2e22de1b30431094887b8b67dd87e8a9 yanc-0.2.0.tar.gz 3622610
diff --git a/media-video/yanc/yanc-0.2.0.ebuild b/media-video/yanc/yanc-0.2.0.ebuild
new file mode 100644
index 000000000000..f7b9695b962c
--- /dev/null
+++ b/media-video/yanc/yanc-0.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/yanc/yanc-0.2.0.ebuild,v 1.1 2003/06/15 05:58:25 seemant Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="YanC is a GUI configuration tool for the NVIDIA Accelerated Linux Driver Set."
+HOMEPAGE="http://yanc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yanc/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~x86"
+
+#
+# As the downloaded package seems to be pre-compiled,
+# the dependances are not clear.
+# TODO: Emerge the real compilable yanc's code
+#
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="x11-base/xfree"
+
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install () {
+ dodir /usr/share/yanc
+ dodir /usr/lib
+ dodir /usr/bin
+
+ cp -r src ${D}/usr/share/yanc
+ cp -r lang ${D}/usr/share/yanc
+ dolib lib/libborqt-6.9.0-qt2.3.so
+ dosym libborqt-6.9.0-qt2.3.so /usr/lib/libborqt-6.9-qt2.3.so
+
+ insinto /usr/share/yanc
+ doins logo.jpg gpl.jpg loeschen.xpm nachunten.xpm nachoben.xpm yanc.xpm
+ doins LICENSE
+
+ exeinto /usr/share/yanc
+ doexe yanc
+
+
+ into /usr
+ dobin script/yanc
+ dosed "s:local:share:" /usr/bin/yanc
+
+ dodoc README*
+ dohtml doc
+}
+
+pkg_postinst() {
+ einfo ''
+ einfo 'WARNING:'
+ einfo '========'
+ einfo '-> Please create a copy of your XF86Config before you use YanC for the'
+ einfo 'first time, because it is possible that your XF86Config is damaged because of'
+ einfo 'the use of YanC. Then a restart of XFree would be impossible.'
+ einfo ''
+ echo ''
+}