summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2008-03-04 21:42:56 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2008-03-04 21:42:56 +0000
commit17c2bcc0d753938f8dd91add68ab8c4ff118f525 (patch)
treec261169a6d5a52d4ffd7912c61de9c5d663638b0 /media-video/undvd/undvd-0.4.0.ebuild
parentVersion bump for security bug #209677 (diff)
downloadhistorical-17c2bcc0d753938f8dd91add68ab8c4ff118f525.tar.gz
historical-17c2bcc0d753938f8dd91add68ab8c4ff118f525.tar.bz2
historical-17c2bcc0d753938f8dd91add68ab8c4ff118f525.zip
0.4.0 release
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'media-video/undvd/undvd-0.4.0.ebuild')
-rw-r--r--media-video/undvd/undvd-0.4.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-video/undvd/undvd-0.4.0.ebuild b/media-video/undvd/undvd-0.4.0.ebuild
new file mode 100644
index 000000000000..7c872b595edb
--- /dev/null
+++ b/media-video/undvd/undvd-0.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/undvd/undvd-0.4.0.ebuild,v 1.1 2008/03/04 21:42:56 gregkh Exp $
+
+inherit eutils
+
+DESCRIPTION="Simple dvd ripping command line app"
+HOMEPAGE="http://sourceforge.net/projects/undvd/"
+SRC_URI="http://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="css xvid"
+
+DEPEND="sys-apps/coreutils
+ app-shells/bash
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-process/procps
+ sys-apps/sed
+ media-video/lsdvd
+ media-video/mplayer
+ css? (
+ media-libs/libdvdcss
+ media-video/vobcopy
+ sys-apps/util-linux
+ )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ einfo "Checking mplayer for USE flags we need..."
+ for f in "encode dvd x264 mp3"; do
+ if ! built_with_use media-video/mplayer $f; then
+ eerror "$f"
+ die "mplayer merged without $f USE flag"
+ fi
+ done
+
+ if use xvid; then
+ if ! built_with_use media-video/mplayer xvid; then
+ eerror "xvid missing. This means you cannot encode to xvid."
+ die "mplayer merged without xvid USE flag"
+ fi
+ fi
+
+ einfo "everything seems to be in order"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}