summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2004-03-10 19:00:35 +0000
committerMax Kalika <max@gentoo.org>2004-03-10 19:00:35 +0000
commitdf03d18d0e61cf3e51ba036e8996b02f97d7df5d (patch)
tree6008b532c6c69b604e9e0e23e0736ae0ec545d5e /media-tv
parentFix bugs #40964 and #42943 by filtering -fPIC and -fforce-addr. (diff)
downloadhistorical-df03d18d0e61cf3e51ba036e8996b02f97d7df5d.tar.gz
historical-df03d18d0e61cf3e51ba036e8996b02f97d7df5d.tar.bz2
historical-df03d18d0e61cf3e51ba036e8996b02f97d7df5d.zip
Add the amd64 workaround as well as filtered flags from mythtv here as well.
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythfrontend/ChangeLog5
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild19
2 files changed, 17 insertions, 7 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index 46533cc79647..93d82f69dc2c 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.11 2004/02/06 14:30:32 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.12 2004/03/10 19:00:35 max Exp $
+
+ 10 Mar 2004; Max Kalika <max@gentoo.org> mythfrontend-0.14-r1.ebuild:
+ Add the amd64 workaround as well as filtered flags from mythtv here as well.
*mythfrontend-0.14-r1 (06 Feb 2004)
diff --git a/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild b/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
index 8f2d50e9ca35..6bacbbcb1063 100644
--- a/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild,v 1.1 2004/02/06 14:30:32 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild,v 1.2 2004/03/10 19:00:35 max Exp $
inherit flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE="alsa arts dvb directfb lcd lirc nvidia cle266"
DEPEND="virtual/x11
@@ -37,7 +37,7 @@ pkg_setup() {
if [ ! "`has mysql ${qt_use}`" ] ; then
eerror "Qt is missing MySQL support. Please add"
eerror "'mysql' to your USE flags, and re-emerge Qt."
- die "Qt needs mysql support"
+ die "Qt needs MySQL support"
fi
return 0
@@ -52,9 +52,16 @@ src_unpack() {
}
src_compile() {
- local cpu="`get-flag march || get-flag mcpu`"
- if [ "${cpu}" ] ; then
- sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ # Fix bugs 40964 and 42943.
+ filter-flags -fforce-addr -fPIC
+
+ if [ "${ARCH}" == "amd64" ]; then
+ sed -e "s:-march=pentiumpro::" -e "/DEFINES += MMX/d" -i settings.pro
+ else
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
fi
if [ "`use alsa`" ] ; then