summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-27 18:16:19 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-27 18:16:19 +0000
commitfefb235c173f8e99bd0b490dad8e3fdb62e52fe0 (patch)
treefc4768cbc2b61897fa46d12e5655f6bb88fb73d9 /media-sound
parentnew version (diff)
downloadhistorical-fefb235c173f8e99bd0b490dad8e3fdb62e52fe0.tar.gz
historical-fefb235c173f8e99bd0b490dad8e3fdb62e52fe0.tar.bz2
historical-fefb235c173f8e99bd0b490dad8e3fdb62e52fe0.zip
new version
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rhythmbox/ChangeLog11
-rw-r--r--media-sound/rhythmbox/files/digest-rhythmbox-0.4.01
-rw-r--r--media-sound/rhythmbox/files/digest-rhythmbox-0.4.11
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.4.1-check_gentoo-be-nicer.patch81
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.4.1.ebuild (renamed from media-sound/rhythmbox/rhythmbox-0.4.0.ebuild)25
5 files changed, 108 insertions, 11 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 5bdec89bce40..b409a34aac9e 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.7 2002/12/04 19:45:43 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.8 2002/12/27 18:16:19 azarah Exp $
-*rhythmbox-0.4.0 (04 Dec 2002)
+*rhythmbox-0.4.1 (26 Dec 2002)
- 04 Dec 2002; Martin Schlemmer <azarah@gentoo.org> :
+ 26 Dec 2002; Martin Schlemmer <azarah@gentoo.org> rhythmbox-0.4.1.ebuild :
+ New version.
+
+*rhythmbox-0.4.0-r1 (04 Dec 2002)
+
+ 04 Dec 2002; Martin Schlemmer <azarah@gentoo.org> rhythmbox-0.4.0-r1.ebuild :
Fix crash if LANG not set, closing bug #10946.
*rhythmbox-0.4.0 (15 Nov 2002)
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.4.0 b/media-sound/rhythmbox/files/digest-rhythmbox-0.4.0
deleted file mode 100644
index 0f02f49e7f75..000000000000
--- a/media-sound/rhythmbox/files/digest-rhythmbox-0.4.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0060ed6e9220f90a1c4d07ff3a8a882c rhythmbox-0.4.0.tar.gz 987679
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.4.1 b/media-sound/rhythmbox/files/digest-rhythmbox-0.4.1
new file mode 100644
index 000000000000..7bdf55befcf9
--- /dev/null
+++ b/media-sound/rhythmbox/files/digest-rhythmbox-0.4.1
@@ -0,0 +1 @@
+MD5 c371babd76bf54f2f238af040f2b2aa9 rhythmbox-0.4.1.tar.gz 1150107
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.4.1-check_gentoo-be-nicer.patch b/media-sound/rhythmbox/files/rhythmbox-0.4.1-check_gentoo-be-nicer.patch
new file mode 100644
index 000000000000..a71663805cb5
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.4.1-check_gentoo-be-nicer.patch
@@ -0,0 +1,81 @@
+--- rhythmbox-0.4.1/shell/main.c.orig 2002-12-27 01:52:38.000000000 +0200
++++ rhythmbox-0.4.1/shell/main.c 2002-12-27 01:56:06.000000000 +0200
+@@ -29,6 +29,10 @@
+ #include <glade/glade-init.h>
+ #include <monkey-media.h>
+ #include <stdlib.h>
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <unistd.h>
++#include <fcntl.h>
+ #include <time.h>
+ #include <string.h>
+
+@@ -48,20 +52,66 @@
+ static gboolean quit = FALSE;
+ static gboolean no_registration = FALSE;
+
++#define GENTOO_TOGGLE "/.rhythmbox-gentoo"
++
+ static void
+ check_gentoo (void)
+ {
++ char *gentoo_toggle = NULL;
++ int fd;
++
++ /*
++ * Malloc enouth memory for our needs ...
++ */
++ gentoo_toggle = (char *)malloc(strlen(GENTOO_TOGGLE) + strlen(g_getenv("HOME")) + 1);
++
++ if ((gentoo_toggle) && ((strlen(g_getenv("HOME"))) > 1))
++ {
++ /*
++ * Setup gentoo_toggle to contain "$HOME/.rhythmbox-gentoo"
++ */
++ strncpy(gentoo_toggle, g_getenv("HOME"), strlen(g_getenv("HOME")));
++ strncpy(gentoo_toggle + strlen(g_getenv("HOME")), GENTOO_TOGGLE,
++ strlen(GENTOO_TOGGLE));
++ }
++ else
++ return;
++
++
+ /*
+ * Dear Gentoo packager,
+ *
+ * I would like to ask you to respect our decision to display this
+ * message and not hack this out.
+ */
++/*
+ if (g_file_test ("/etc/gentoo-release", G_FILE_TEST_EXISTS) == TRUE)
+ {
+ rb_warning_dialog (_("Well well well...\n\n"
+- "Gentoo eh? You'll run into problems. We know. Don't bug us.\n\n"
++ "Gentoo eh? You'll run into problems. We know. Don't bug us.\n\n"
++ "Have a nice day."));
++ }
++ */
++ /*
++ * While I do feel that we should not disrespect their request, this
++ * is really a bit harsh. Thus tone it down, and only display it once.
++ */
++ if ((g_file_test ("/etc/gentoo-release", G_FILE_TEST_EXISTS) == TRUE) &&
++ (g_file_test (gentoo_toggle, G_FILE_TEST_EXISTS) == FALSE))
++ {
++ rb_warning_dialog (_("Dear Gentoo User...\n\n"
++ "Please report problems to http://bugs.gentoo.org/\n"
++ "and NOT to the developers of Rhythmbox.\n\n"
+ "Have a nice day."));
++
++ /*
++ * Create our "toggle" to check if the message should be
++ * displayed or not ...
++ */
++ fd = open(gentoo_toggle, O_CREAT|O_RDWR, S_IRUSR|S_IWUSR);
++ if (fd != -1)
++ close(fd);
++
+ }
+ }
+
diff --git a/media-sound/rhythmbox/rhythmbox-0.4.0.ebuild b/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild
index 3b9643abb156..9df34a895a97 100644
--- a/media-sound/rhythmbox/rhythmbox-0.4.0.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.4.0.ebuild,v 1.1 2002/11/15 12:03:31 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild,v 1.1 2002/12/27 18:16:19 azarah Exp $
-inherit gnome2
+inherit eutils gnome2
-S=${WORKDIR}/${P}
+S="${WORKDIR}/${P}"
DESCRIPTION="RhythmBox - an iTunes clone for GNOME"
SRC_URI="http://www.rhythmbox.org/download/${P}.tar.gz"
HOMEPAGE="http://www.rhythmbox.org/"
@@ -21,16 +21,28 @@ RDEPEND=">=x11-libs/gtk+-2.0.0
=gnome-base/libbonobo-2.0*
=gnome-base/bonobo-activation-1.0*
=gnome-base/libgnomecanvas-2.0*
- >=media-libs/monkey-media-0.6.0
+ >=media-libs/monkey-media-0.6.1
>=gnome-base/gconf-1.2.1
>=gnome-base/ORBit2-2.4.1
>=sys-devel/gettext-0.11.1
- >=media-libs/gst-plugins-0.4.2"
+ =media-libs/gst-plugins-0.4.2*"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
dev-util/intltool"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Soften the message displayed at startup, and only do
+ # it once. Ugly hack I know, but somebody with more C
+ # will have to fix this if need be ...
+ # <azarah@gentoo.org> (27 Dec 2002).
+ cd ${S}; epatch ${FILESDIR}/${PN}-0.4.1-check_gentoo-be-nicer.patch
+}
+
src_install () {
# this is a fix to disable scrollkeeper-update from running in
@@ -43,7 +55,6 @@ src_install () {
}
-LIBTOOL_FIX="1"
-
DOC="AUTHORS COPYING ChangeLog INSTALL INSTALL.GNU HACKING NEWS README THANKS TODO"
SCHEMA="rhythmbox.schemas"
+