summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-08 13:26:23 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-08 13:26:23 +0000
commite80cb3d55bef2a86f417a749743c547b501d5095 (patch)
treeb4e351a0b50c1b11dee4bd1bbce6a4fff6d0d864 /media-sound
parent*** empty log message *** (diff)
downloadhistorical-e80cb3d55bef2a86f417a749743c547b501d5095.tar.gz
historical-e80cb3d55bef2a86f417a749743c547b501d5095.tar.bz2
historical-e80cb3d55bef2a86f417a749743c547b501d5095.zip
*** empty log message ***
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.5.8b-r1.ebuild50
-rw-r--r--media-sound/alsa-driver/files/digest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.5.8-r1.ebuild42
-rw-r--r--media-sound/alsa-utils/files/digest1
-rw-r--r--media-sound/xmms/files/digest1
-rw-r--r--media-sound/xmms/xmms-1.2.2-r1.ebuild34
6 files changed, 129 insertions, 0 deletions
diff --git a/media-sound/alsa-driver/alsa-driver-0.5.8b-r1.ebuild b/media-sound/alsa-driver/alsa-driver-0.5.8b-r1.ebuild
new file mode 100644
index 000000000000..c1c152a32e76
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.5.8b-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.5.8b-r1.ebuild,v 1.1 2000/08/08 13:26:23 achim Exp $
+
+P=alsa-driver-0.5.8b
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+CATEGORY="media-sound"
+DESCRIPTION="Advanced Linux Sound Architecture / Drivers"
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/"${A}
+HOMEPAGE="http://www.alsa-project.org/"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr \
+ --with-kernel=${WORKDIR}/../../../sys-kernel/linux-UP-2.2.17p13/work/linux \
+ --with-moddir=/lib/modules/2.2.17pre13-RAID/misc \
+ --with-isapnp=yes --with-sequencer=yes --with-oss=yes
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /usr
+ dosbin snddevices
+ insinto /lib/modules/2.2.17pre13-RAID/misc
+ doins modules/*.o
+ insinto /usr/src/linux/include/linux
+ for i in asound asoundid asequencer ainstr_simple ainstr_gf1 ainstr_iw
+ do
+ doins include/$i.h
+ done
+ insinto /etc/rc.d/init.d
+ doins utils/alsasound
+ dodoc COPYING FAQ README WARNING doc/README.1st doc/SOUNDCARDS
+}
+
+pkg_postinst() {
+ . /etc/rc.d/config/functions
+ if [ "${ROOT}" = "/" ] ; then
+ einfo "Creating sounddevices..."
+ /usr/sbin/snddevices
+ fi
+}
+
diff --git a/media-sound/alsa-driver/files/digest b/media-sound/alsa-driver/files/digest
new file mode 100644
index 000000000000..f44acea353ed
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest
@@ -0,0 +1 @@
+MD5 a513acd64285f731d217728732351fcf alsa-driver-0.5.8b.tar.bz2
diff --git a/media-sound/alsa-utils/alsa-utils-0.5.8-r1.ebuild b/media-sound/alsa-utils/alsa-utils-0.5.8-r1.ebuild
new file mode 100644
index 000000000000..080f26dd210e
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-0.5.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.5.8-r1.ebuild,v 1.1 2000/08/08 13:26:23 achim Exp $
+
+P=alsa-utils-0.5.8
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+CATEGORY="media-sound"
+DESCRIPTION="Advanced Linux Sound Architecture / Utils"
+SRC_URI="ftp://ftp.alsa-project.org/pub/utils/"${A}
+HOMEPAGE="http://www.alsa-project.org/"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr
+ make
+
+}
+
+src_install() {
+ cd ${S}/aplay
+ cd aplay
+ cp Makefile Makefile.orig
+ sed -e "s:cd \$(bindir):cd \$(DESTDIR)\$(bindir):" \
+ sed -e "s:cd \$(mandir):cd \$(DESTDIR)\$(mandir):" \
+ Makefile.orig > Makefile
+ cd ${S}
+ make DESTDIR=${D} install
+ dodoc ChangeLog COPYING README
+ newdoc alsamixer/README README.alsamixer
+ dodoc seq/aconnect/README* seq/aseqnet/README*
+ prepman
+}
+
+
+
+
diff --git a/media-sound/alsa-utils/files/digest b/media-sound/alsa-utils/files/digest
new file mode 100644
index 000000000000..9a292705cc89
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest
@@ -0,0 +1 @@
+MD5 610313825dc5ef8ca25f94b10028ec93 alsa-utils-0.5.8.tar.bz2
diff --git a/media-sound/xmms/files/digest b/media-sound/xmms/files/digest
new file mode 100644
index 000000000000..d1d83b501775
--- /dev/null
+++ b/media-sound/xmms/files/digest
@@ -0,0 +1 @@
+MD5 c4a99b69eb913329597ba52d727b3394 xmms-1.2.2.tar.gz
diff --git a/media-sound/xmms/xmms-1.2.2-r1.ebuild b/media-sound/xmms/xmms-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..8f3b12689540
--- /dev/null
+++ b/media-sound/xmms/xmms-1.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.2-r1.ebuild,v 1.1 2000/08/08 13:26:23 achim Exp $
+
+P=xmms-1.2.2
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="media-sound"
+DESCRIPTION="X MultiMedia System"
+SRC_URI="ftp://ftp.xmms.org/xmms/1.2.x/"${A}
+HOMEPAGE="http://www.xmms.org/"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ CFLAGS="$CFLAGS -I/opt/gnome/include" ./configure --host=${CHOST} --prefix=/usr/X11R6 --with-catgets
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr/X11R6 install
+ dodoc AUTHORS ChangeLog COPYING FAQ NEWS README TODO
+ insinto /usr/X11R6/include/X11/pixmaps/
+ newins gnomexmms/gnomexmms.xpm xmms.xpm
+}
+
+
+
+