summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-08-13 18:11:01 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-08-13 18:11:01 +0000
commita4f8f3e199579a377572217484f6c2a2e7e7f22a (patch)
treea8453fd9a50df7d0550229bd7296b38177b0e3e2 /media-sound
parent- Disabled NAS support (closes bug #5183). (diff)
downloadhistorical-a4f8f3e199579a377572217484f6c2a2e7e7f22a.tar.gz
historical-a4f8f3e199579a377572217484f6c2a2e7e7f22a.tar.bz2
historical-a4f8f3e199579a377572217484f6c2a2e7e7f22a.zip
Initial version of the ebuild. Closes #5983.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/vsound/ChangeLog9
-rw-r--r--media-sound/vsound/files/digest-vsound-0.52
-rw-r--r--media-sound/vsound/vsound-0.5.ebuild36
3 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/vsound/ChangeLog b/media-sound/vsound/ChangeLog
new file mode 100644
index 000000000000..6d3f9d5614f6
--- /dev/null
+++ b/media-sound/vsound/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-sound/vsound
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vsound/ChangeLog,v 1.1 2002/08/13 18:11:01 agenkin Exp $
+
+*vsound-0.5 (13 Aug 2002)
+
+ 13 Aug 2002; Arcady Genkin <agenkin@thpoon.com> vsound-0.5.ebuild :
+
+ Initial version, submitted by Chris Arndt <arndtc@mailandnews.com>. \ No newline at end of file
diff --git a/media-sound/vsound/files/digest-vsound-0.5 b/media-sound/vsound/files/digest-vsound-0.5
new file mode 100644
index 000000000000..a3f18e640e2e
--- /dev/null
+++ b/media-sound/vsound/files/digest-vsound-0.5
@@ -0,0 +1,2 @@
+MD5 77016cfa2c3ba45d051881051a75ac06 vsound_0.5.orig.tar.gz 116904
+MD5 c638ee6197582c4bb10d630c9c48cac4 vsound_0.5-3.diff.gz 160066
diff --git a/media-sound/vsound/vsound-0.5.ebuild b/media-sound/vsound/vsound-0.5.ebuild
new file mode 100644
index 000000000000..d79bce0b3447
--- /dev/null
+++ b/media-sound/vsound/vsound-0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2000-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vsound/vsound-0.5.ebuild,v 1.1 2002/08/13 18:11:01 agenkin Exp $
+
+DESCRIPTION="Sort a virtual audio loopback cable for RealAudio to wave convertions."
+HOMEPAGE="http://www.zip.com.au/~erikd/vsound/"
+LICENSE="GPL-2"
+DEPEND=">=media-sound/sox-12.17.1
+ >=media-video/realplayer-8-r1"
+
+SRC_URI="http://ftp.br.debian.org/debian/pool/main/v/vsound/${P/-/_}.orig.tar.gz
+ http://ftp.br.debian.org/debian/pool/main/v/vsound/${P/-/_}-3.diff.gz"
+S=${WORKDIR}/${P}
+
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${P/-/_}.orig.tar.gz
+ cd ${S}
+ gunzip --stdout ${DISTDIR}/${P/-/_}-3.diff.gz | patch -p1 || die
+}
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} || die
+
+ emake || die
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING Changelog INSTALL NEWS README README.original
+}