summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-26 20:41:56 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-26 20:41:56 +0000
commit347d54b0226ea216bb302a04b07ad9160e865f92 (patch)
tree3dec1784f8f6d0a53719da6cd6545806946b50fb /media-sound
parent*** empty log message *** (diff)
downloadhistorical-347d54b0226ea216bb302a04b07ad9160e865f92.tar.gz
historical-347d54b0226ea216bb302a04b07ad9160e865f92.tar.bz2
historical-347d54b0226ea216bb302a04b07ad9160e865f92.zip
*** empty log message ***
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lame/files/digest-lame-3.86b1
-rw-r--r--media-sound/lame/lame-3.86b.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/lame/files/digest-lame-3.86b b/media-sound/lame/files/digest-lame-3.86b
new file mode 100644
index 000000000000..7897aa6fbee5
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.86b
@@ -0,0 +1 @@
+MD5 1376a6c944ec3745b46af18fab62db6c lame3.86beta.tar.gz
diff --git a/media-sound/lame/lame-3.86b.ebuild b/media-sound/lame/lame-3.86b.ebuild
new file mode 100644
index 000000000000..ad3227c9939b
--- /dev/null
+++ b/media-sound/lame/lame-3.86b.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.86b.ebuild,v 1.1 2000/08/26 20:41:56 achim Exp $
+
+P=lame-3.86b
+A=lame3.86beta.tar.gz
+S=${WORKDIR}/lame3.86
+CATEGORY="media-sound"
+DESCRIPTION="LAME Ain't an Mp3 Encoder"
+SRC_URI="http://www.sulaco.org/mp3/download/beta/${A}"
+HOMEPAGE="http://www.sulaco.org/mp3/"
+
+src_unpack () {
+
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" Makefile.orig > Makefile
+
+}
+
+src_compile() {
+
+ cd ${S}
+ make
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin lame
+ doman doc/man/lame.1
+ dodoc API COPYING HACKING PRESETS.draft LICENSE README* TODO USAGE
+ docinto html
+ dodoc doc/html/*.html doc/html/*.css
+
+}
+
+
+