summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2010-01-20 08:11:20 +0000
committerChristian Parpart <trapni@gentoo.org>2010-01-20 08:11:20 +0000
commit1a3f1cdfaebbd59072d033eeff1cb650d2dccf42 (patch)
tree1b67513576a1f13fc7c4a9b7ba0b240bd329772c /media-sound
parentworkaround for the EPERM bug (diff)
downloadhistorical-1a3f1cdfaebbd59072d033eeff1cb650d2dccf42.tar.gz
historical-1a3f1cdfaebbd59072d033eeff1cb650d2dccf42.tar.bz2
historical-1a3f1cdfaebbd59072d033eeff1cb650d2dccf42.zip
version bump plus license update
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/teamspeak-client-bin/ChangeLog8
-rw-r--r--media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta11.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/media-sound/teamspeak-client-bin/ChangeLog b/media-sound/teamspeak-client-bin/ChangeLog
index a64f154161e6..b6cd20b29114 100644
--- a/media-sound/teamspeak-client-bin/ChangeLog
+++ b/media-sound/teamspeak-client-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/teamspeak-client-bin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.2 2010/01/03 15:53:31 trapni Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.3 2010/01/20 08:11:20 trapni Exp $
+
+*teamspeak-client-bin-3.0.0_beta11 (20 Jan 2010)
+
+ 20 Jan 2010; Christian Parpart <trapni@gentoo.org>
+ +teamspeak-client-bin-3.0.0_beta11.ebuild:
+ version bump plus license update
*teamspeak-client-bin-3.0.0_beta9 (03 Jan 2010)
diff --git a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta11.ebuild b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta11.ebuild
new file mode 100644
index 000000000000..1370e0c85eed
--- /dev/null
+++ b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta11.ebuild,v 1.1 2010/01/20 08:11:20 trapni Exp $
+
+# NOTE: The comments in this file are for instruction and documentation.
+# They're not meant to appear with your final, production ebuild. Please
+# remember to remove them before submitting or committing your ebuild. That
+# doesn't mean you can't add your own comments though.
+
+# The 'Header' on the third line should just be left alone. When your ebuild
+# will be committed to cvs, the details on that line will be automatically
+# generated to contain the correct data.
+
+EAPI=1
+
+inherit eutils
+
+DESCRIPTION="TeamSpeak Client - Voice Communication Software"
+HOMEPAGE="http://teamspeak.com/"
+LICENSE="teamspeak3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="builtin-qt"
+RESTRICT="strip"
+PROPERTIES="interactive"
+
+SRC_URI="
+ amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/beta-11/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run )
+ x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/beta-11/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )
+"
+
+DEPEND="!builtin-qt? ( x11-libs/qt-core:4 x11-libs/qt-gui:4 )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ # TODO: unpack_makeself -- use this version once it supports makeself 2.1.6
+ for i in ${A}; do
+ sh "${DISTDIR}/${i}" --target "${WORKDIR}" || die "unpack failed"
+ done
+}
+
+src_install() {
+ local dest="${D}/opt/teamspeak3-client"
+
+ mkdir -p "${dest}"
+ cp -R "${WORKDIR}/"* "${dest}/" || die
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/teamspeak3"
+
+ mv "${dest}/ts3client_linux_"* "${dest}/ts3client"
+
+ useq builtin-qt || rm "${dest}"/libQt*
+}