summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-05-19 19:21:39 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-05-19 19:21:39 +0000
commit1201bd6dbbfb8cd752bf8d9f04f0e965af8c9da0 (patch)
treebc77df200479de333c8b34b692dfe2fdd37c3684 /media-sound
parentversion bumped (diff)
downloadhistorical-1201bd6dbbfb8cd752bf8d9f04f0e965af8c9da0.tar.gz
historical-1201bd6dbbfb8cd752bf8d9f04f0e965af8c9da0.tar.bz2
historical-1201bd6dbbfb8cd752bf8d9f04f0e965af8c9da0.zip
Version bump
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog7
-rw-r--r--media-sound/alsa-driver/Manifest2
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.3b.ebuild93
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.3b1
4 files changed, 102 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index bb9618cab22a..26f3ced468b1 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.34 2003/05/04 09:27:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.35 2003/05/19 19:21:39 aliz Exp $
+
+*alsa-driver-0.9.3b (19 May 2003)
+
+ 19 May 2003; Daniel Ahlberg <aliz@gentoo.org> alsa-driver-0.9.3b.ebuild :
+ Version bump.
*alsa-driver-0.9.3 (05 May 2003)
diff --git a/media-sound/alsa-driver/Manifest b/media-sound/alsa-driver/Manifest
index d9dacfb295f2..7084fcfd89b0 100644
--- a/media-sound/alsa-driver/Manifest
+++ b/media-sound/alsa-driver/Manifest
@@ -1,5 +1,6 @@
MD5 787daae725934ffd540b0011cecf86ea ChangeLog 6383
MD5 a0d2f9e64f89d3fea2a09767bb1eb6a2 alsa-driver-0.5.12a.ebuild 1663
+MD5 304036ff2d79f19389121c07b304da6a alsa-driver-0.9.3b.ebuild 2685
MD5 6824caf41e03202f95d32f4855d45f97 alsa-driver-0.9.0_rc2.ebuild 2654
MD5 a64b0229ef1bb9861f766c745f1e1ca8 alsa-driver-0.9.2.ebuild 2686
MD5 304036ff2d79f19389121c07b304da6a alsa-driver-0.9.3a.ebuild 2685
@@ -9,6 +10,7 @@ MD5 87448a6155eb013f2b14e4a531ffc25a files/alsa-driver-0.9.0rc1-ppc.patch 358
MD5 8c81382138ab9223d1e0abdfdb1e5e98 files/alsa-modules.conf 1088
MD5 9732f15dfab42b3c1556f546f14f041f files/alsa-modules.conf-rc 1161
MD5 ac8c1852768868cb9c61a07e6baddc3a files/digest-alsa-driver-0.5.12a 72
+MD5 049f4d7abae8f76ebd520342967c0164 files/digest-alsa-driver-0.9.3b 72
MD5 e3912a14a13dae85c5ee17f351733bae files/digest-alsa-driver-0.9.0_rc2 74
MD5 5283280b5f72b9ea25f3e1e1adcde464 files/digest-alsa-driver-0.9.2 71
MD5 2d39f80fad60314ed189ac266fec3d72 files/digest-alsa-driver-0.9.3a 72
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.3b.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.3b.ebuild
new file mode 100644
index 000000000000..915cf8145f3d
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.3b.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.3b.ebuild,v 1.1 2003/05/19 19:21:39 aliz Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="~x86 ~ppc"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ # Arcady Genkin <agenkin@thpoon.com>
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ make || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You need to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use 'alsamixer' program to unmute them."
+ einfo
+}
+
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3b b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3b
new file mode 100644
index 000000000000..9f0b970e0b9d
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3b
@@ -0,0 +1 @@
+MD5 6cb791b10b31dcef7fffd2417d213301 alsa-driver-0.9.3b.tar.bz2 1523024