summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-15 18:11:56 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-15 18:11:56 +0000
commite24800ff226460668c2ab2d0e480c0a90081fb0f (patch)
tree579ff67ef2d7c5f1ae110fdab9a2b0a1e4ad57f4 /media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
parentadded s390 to keywords (diff)
downloadhistorical-e24800ff226460668c2ab2d0e480c0a90081fb0f.tar.gz
historical-e24800ff226460668c2ab2d0e480c0a90081fb0f.tar.bz2
historical-e24800ff226460668c2ab2d0e480c0a90081fb0f.zip
Filter out -ffast-math. Closes bug #47183.
Diffstat (limited to 'media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild')
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
index 633decf2499e..58afd52f657f 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild,v 1.4 2004/04/03 00:54:49 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild,v 1.5 2004/04/15 18:11:56 eradicator Exp $
-inherit gnome2
+inherit gnome2 flag-o-matic
DESCRIPTION="Music management and playback software for GNOME"
HOMEPAGE="http://web.rhythmbox.org/"
@@ -52,7 +52,6 @@ G2CONF="${G2CONF} \
--disable-schemas-install"
src_unpack( ) {
-
unpack ${A}
cd ${S}
@@ -65,3 +64,10 @@ DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \
MAINTAINERS NEWS README THANKS TODO"
export GST_INSPECT=/bin/true
+
+src_compile() {
+ filter-flags "-ffast-math"
+ gnome2_src_compile
+}
+
+