summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-03 23:52:26 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-03 23:52:26 +0000
commit64381cf6fdf9be4cc12f3d46e8e8e28acbcf44f1 (patch)
tree9fb7ad3735d1e6740e511a3c09774440472ff174 /media-sound/grip
parentstable on ppc (diff)
downloadhistorical-64381cf6fdf9be4cc12f3d46e8e8e28acbcf44f1.tar.gz
historical-64381cf6fdf9be4cc12f3d46e8e8e28acbcf44f1.tar.bz2
historical-64381cf6fdf9be4cc12f3d46e8e8e28acbcf44f1.zip
Readding the amd64 fix for the new version.
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/ChangeLog6
-rw-r--r--media-sound/grip/files/grip-3.1.9-statuscheck-lp64.patch11
-rw-r--r--media-sound/grip/grip-3.1.9.ebuild10
3 files changed, 25 insertions, 2 deletions
diff --git a/media-sound/grip/ChangeLog b/media-sound/grip/ChangeLog
index 7cb181796a2b..798a74634c0b 100644
--- a/media-sound/grip/ChangeLog
+++ b/media-sound/grip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/grip
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.33 2004/04/03 16:11:32 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.34 2004/04/03 23:52:26 eradicator Exp $
+
+ 03 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org> grip-3.1.9.ebuild,
+ files/grip-3.1.9-statuscheck-lp64.patch:
+ Readding the amd64 fix for the new version.
*grip-3.1.9 (03 Apr 2004)
diff --git a/media-sound/grip/files/grip-3.1.9-statuscheck-lp64.patch b/media-sound/grip/files/grip-3.1.9-statuscheck-lp64.patch
new file mode 100644
index 000000000000..4586408a4f79
--- /dev/null
+++ b/media-sound/grip/files/grip-3.1.9-statuscheck-lp64.patch
@@ -0,0 +1,11 @@
+--- grip-3.1.9-orig/src/status_window.c 2004-03-31 04:29:50.000000000 +0200
++++ grip-3.1.9/src/status_window.c 2004-04-04 00:17:15.664086496 +0200
+@@ -83,7 +83,7 @@
+ void StatusWindowWrite(StatusWindow *sw,char *msg)
+ {
+ char *buf, *locale_msg=NULL;
+- int len;
++ gsize len;
+ int pos=0;
+
+ /* gtk_widget_queue_resize(sw->term_widget);*/
diff --git a/media-sound/grip/grip-3.1.9.ebuild b/media-sound/grip/grip-3.1.9.ebuild
index cb5a2e1a93df..720170a5df01 100644
--- a/media-sound/grip/grip-3.1.9.ebuild
+++ b/media-sound/grip/grip-3.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.1.9.ebuild,v 1.1 2004/04/03 16:11:32 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.1.9.ebuild,v 1.2 2004/04/03 23:52:26 eradicator Exp $
inherit eutils
@@ -27,6 +27,14 @@ IUSE="nls oggvorbis"
SLOT="0"
KEYWORDS="~x86 ~ppc alpha ~amd64 ~hppa ~sparc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # AMD64 SMP Crash Fix, submitted by Brian Silverthorn <bcs26@cornell.edu>
+ epatch ${FILESDIR}/${P}-statuscheck-lp64.patch
+}
+
src_compile() {
econf --disable-dependency-tracking `use_enable nls` || die
emake || die "emake failed"