summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-22 22:43:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-22 22:43:14 +0000
commitc21279482cb16761da5484cbc9db7a105a4db6c3 (patch)
tree50d5491dc98bca16cebe79ce73b8a7b1973455b7 /media-sound/ecasound
parentRemoving SRC_TEST since when enabled, it requires a display (and another module) (diff)
downloadhistorical-c21279482cb16761da5484cbc9db7a105a4db6c3.tar.gz
historical-c21279482cb16761da5484cbc9db7a105a4db6c3.tar.bz2
historical-c21279482cb16761da5484cbc9db7a105a4db6c3.zip
Use $(get_libdir) to get the site's dir for python modules.
Package-Manager: portage-2529-svn
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog7
-rw-r--r--media-sound/ecasound/Manifest14
-rw-r--r--media-sound/ecasound/ecasound-2.4.3.ebuild8
3 files changed, 22 insertions, 7 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 64235528eed4..cc2bfdf04181 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/ecasound
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.33 2005/12/26 14:42:15 lu_zero Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.34 2006/01/22 22:43:14 flameeyes Exp $
+
+ 22 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> ecasound-2.4.3.ebuild:
+ Use $(get_libdir) to get the site's dir for python modules.
26 Dec 2005; Luca Barbato <lu_zero@gentoo.org> ecasound-2.3.3.ebuild,
ecasound-2.4.3.ebuild:
diff --git a/media-sound/ecasound/Manifest b/media-sound/ecasound/Manifest
index 922c1a3bfd78..a670bbdfe235 100644
--- a/media-sound/ecasound/Manifest
+++ b/media-sound/ecasound/Manifest
@@ -1,6 +1,16 @@
-MD5 99c27a9584db460d7c189d42d51b166f ChangeLog 5467
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 a0740de85559880e62ee25dd645de4fd ChangeLog 5608
MD5 f6388cadb4f92585f4b64e0352b71eee ecasound-2.3.3.ebuild 2786
-MD5 a8f3cfbe746767536ae427003953134f ecasound-2.4.3.ebuild 3067
+MD5 b95c022efe618437856af6614fab2c02 ecasound-2.4.3.ebuild 3097
MD5 92bd0b879f6e514225f5db2a2d474688 files/digest-ecasound-2.3.3 66
MD5 c060e437668b796937fe7f25d200d092 files/digest-ecasound-2.4.3 67
MD5 eadab3941f136b871837953c9d1472d5 metadata.xml 753
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFD1AggAiZjviIA2XgRAgjmAJ92PG2FORHvTmQPaYZVomaVNrMrPwCg9APe
+QZJY6bxuy9GqYFHquLrZiUI=
+=T7LT
+-----END PGP SIGNATURE-----
diff --git a/media-sound/ecasound/ecasound-2.4.3.ebuild b/media-sound/ecasound/ecasound-2.4.3.ebuild
index 0603db3df88c..fb65fc0e7c0b 100644
--- a/media-sound/ecasound/ecasound-2.4.3.ebuild
+++ b/media-sound/ecasound/ecasound-2.4.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.3.ebuild,v 1.3 2005/12/26 14:42:15 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.3.ebuild,v 1.4 2006/01/22 22:43:14 flameeyes Exp $
+
+inherit multilib
IUSE="alsa arts audiofile debug jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
@@ -56,7 +58,7 @@ src_compile () {
python_prefix="`python -c 'import sys; print sys.prefix'`"
python_includes="$python_prefix/include/python$python_version"
- python_modules="$python_prefix/lib/python$python_version"
+ python_modules="$python_prefix/$(get_libdir)/python$python_version"
myconf="$myconf --with-python-includes=$python_includes"
myconf="$myconf --with-python-modules=$python_modules"