summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-07-14 21:51:58 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-07-14 21:51:58 +0000
commitf0b273311cda42f02d9caeddc2d39e669697d817 (patch)
treea6f14948c474192efdef739a8efddef16ffcc279 /media-libs
parentUSE="gnome" support for enabling gnome-vfs, please test. also a sed hack to d... (diff)
downloadhistorical-f0b273311cda42f02d9caeddc2d39e669697d817.tar.gz
historical-f0b273311cda42f02d9caeddc2d39e669697d817.tar.bz2
historical-f0b273311cda42f02d9caeddc2d39e669697d817.zip
USE="gnome" support for enabling gnome-vfs, please test. also a sed hack to disable gnome-vfs if not wanted. no configure support for disable/enable
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/Manifest4
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-1_beta12-r11
-rw-r--r--media-libs/xine-lib/xine-lib-1_beta12-r1.ebuild138
3 files changed, 141 insertions, 2 deletions
diff --git a/media-libs/xine-lib/Manifest b/media-libs/xine-lib/Manifest
index c246f1fa877e..0eabecbfb21b 100644
--- a/media-libs/xine-lib/Manifest
+++ b/media-libs/xine-lib/Manifest
@@ -1,9 +1,9 @@
MD5 1388f8c8e8516b9fa9888072abb566d8 xine-lib-0.9.13-r3.ebuild 3704
MD5 26ea97e0c81e85adebfd5f314e69455d xine-lib-1_beta11.ebuild 3658
MD5 2ca0cfebb8ed9d40361ca4ca8c11321b xine-lib-1_beta10.ebuild 3480
-MD5 fb4bef8b1fd0881db849d0f72bbeda17 ChangeLog 11565
+MD5 015b2e12e5a3e82f5bae40fe87dd5205 ChangeLog 11767
MD5 f68350589c677913ab371b080a307093 xine-lib-1_beta12.ebuild 3761
-MD5 92463c104be329e602c346c4b7cce313 xine-lib-1_beta12-r1.ebuild 3829
+MD5 5054f5a1ea38c289ac85b5135b9510ba xine-lib-1_beta12-r1.ebuild 4174
MD5 aa54582a91933533008c1211dcbcfb35 files/xine-lib-disable-directfb.patch 4169
MD5 af33e921f7041fafac652c324d3984c1 files/digest-xine-lib-1_beta10 70
MD5 5903fa4c80658b8265910c8745913dae files/digest-xine-lib-1_beta11 70
diff --git a/media-libs/xine-lib/files/digest-xine-lib-1_beta12-r1 b/media-libs/xine-lib/files/digest-xine-lib-1_beta12-r1
new file mode 100644
index 000000000000..079328e72581
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-1_beta12-r1
@@ -0,0 +1 @@
+MD5 db00ce938944b2f3b334e7c27352eadf xine-lib-1-beta12.tar.gz 3919156
diff --git a/media-libs/xine-lib/xine-lib-1_beta12-r1.ebuild b/media-libs/xine-lib/xine-lib-1_beta12-r1.ebuild
new file mode 100644
index 000000000000..0dc3aec1f817
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-1_beta12-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta12-r1.ebuild,v 1.1 2003/07/14 21:51:49 spider Exp $
+
+DESCRIPTION="Core libraries for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ directfb? ( >=dev-libs/DirectFB-0.9.9
+ dev-util/pkgconfig )
+ gnome? ( >=gnome-base/gnome-vfs-2.0
+ dev-util/pkgconfig )
+ >=media-libs/flac-1.0.4
+ >=media-libs/libsdl-1.1.5
+ >=media-libs/libfame-0.9.0
+ >=media-libs/xvid-0.9.0"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa gnome"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+S=${WORKDIR}/${PN}-${PV/_/-}
+SRC_URI="mirror://sourceforge/xine/${PN}-${PV/_/-}.tar.gz"
+
+# this build doesn't play nice with -maltivec (gcc 3.2 only option) on ppc
+# Commenting this out in this ebuild, because CFLAGS and CXXFLAGS are unset
+# at make time any way.
+# Brandon Low (29 Apr 2003)
+# inherit flag-o-matic || die "I lost my inheritance"
+# filter-flags "-maltivec -mabi=altivec"
+# replace-flags k6-3 i686
+# replace-flags k6-2 i686
+# replace-flags k6 i686
+
+#13 Jul 2003: drobbins: build failure using -j5 on a dual Xeon in 1_beta12
+MAKEOPTS="$MAKEOPTS -j1"
+src_compile() {
+
+ # Make sure that the older libraries are not installed (bug #15081).
+ if [ -f /usr/lib/libxine.so.0 ]
+ then
+ einfo "Please uninstall older xine libraries.";
+ einfo "The compilation cannot proceed.";
+ die
+ fi
+
+ # Use the built-in dvdnav plugin.
+ local myconf="--with-included-dvdnav"
+
+ # Most of these are not working currently, but are here for completeness
+ # don't use the --disable-XXXtest because that defaults to ON not OFF
+ use X \
+ || myconf="${myconf} --disable-x11" # --disable-xv"
+ use esd \
+ || myconf="${myconf} --disable-esd" # --disable-esdtest"
+ use nls \
+ || myconf="${myconf} --disable-nls"
+ use alsa \
+ || myconf="${myconf} --disable-alsa" # --disable-alsatest"
+ use arts \
+ || myconf="${myconf} --disable-arts" # --disable-artstest"
+ use aalib \
+ || myconf="${myconf} --disable-aalib" # --disable-aalibtest"
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-vorbis"
+ #--disable-oggtest --disable-vorbistest"
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ einfo "myconf: ${myconf}"
+
+ # Very specific optimization is set by configure
+ # Should fix problems like the one found on bug #11779
+ # raker@gentoo.org (25 Dec 2002)
+ unset CFLAGS
+ unset CXXFLAGS
+
+ econf ${myconf} || die "Configure failed"
+
+ # since there is no --disable-gnomevfs flag we have to fix config.h by hand
+
+ cp config.h config.h.sed
+
+ if [ ! `use gnome` ]
+ then
+ einfo "supposedly not using gnome. disabling gnome-vfs support"
+ cp config.h config.h.sed
+ cat config.h.sed |sed -e s/\#define\ HAVE_GNOME_VFS\ 1/\#undef\ HAVE_GNOME_VFS/g >config.h
+ rm config.h.sed
+ fi
+ emake || die "Parallel make failed"
+}
+
+src_install() {
+
+ einstall || die "Install failed"
+
+ # Xine's makefiles install some file incorrectly. (Gentoo bug #8583, #16112).
+ dodir /usr/share/xine/libxine1/fonts
+ mv ${D}/usr/share/*.xinefont.gz ${D}/usr/share/xine/libxine1/fonts/
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Please note, a new version of xine-lib has been installed,"
+ einfo "for library consistency you need to unmerge old versions"
+ einfo "of xine-lib before merging xine-ui."
+ einfo
+ einfo "This library version 1 is incompatible with the plugins,"
+ einfo "designed for the prior library versions (such as xine-d4d,"
+ einfo "xine-d5d, xine-dmd, and xine-dvdnav."
+ einfo
+ einfo "Also make sure to remove your ~/.xine if upgrading from"
+ einfo "a previous version."
+ einfo
+
+}