summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2005-08-12 15:06:56 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2005-08-12 15:06:56 +0000
commitd766450464747e0942084523423c689b171000fc (patch)
treefe7dad734e57fb41701f18973c48b1f85acf058f /media-libs/win32codecs
parentstable on alpha, wrt bug #102000 (diff)
downloadhistorical-d766450464747e0942084523423c689b171000fc.tar.gz
historical-d766450464747e0942084523423c689b171000fc.tar.bz2
historical-d766450464747e0942084523423c689b171000fc.zip
make multilib aware to have correct install location on amd64, and mark ~amd64
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-libs/win32codecs')
-rw-r--r--media-libs/win32codecs/ChangeLog7
-rw-r--r--media-libs/win32codecs/Manifest16
-rw-r--r--media-libs/win32codecs/win32codecs-20050412.ebuild22
3 files changed, 34 insertions, 11 deletions
diff --git a/media-libs/win32codecs/ChangeLog b/media-libs/win32codecs/ChangeLog
index e166f90dc2bf..954b6db9666c 100644
--- a/media-libs/win32codecs/ChangeLog
+++ b/media-libs/win32codecs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/win32codecs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/win32codecs/ChangeLog,v 1.28 2005/05/04 21:49:21 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/win32codecs/ChangeLog,v 1.29 2005/08/12 15:06:56 dang Exp $
+
+ 12 Aug 2005; <dang@gentoo.org> win32codecs-20050412.ebuild:
+ Add multilib support. This makes the libs get installed in the correct spot
+ on amd64 to be used by 32-bit programs. x86 install locations are
+ unaffected. Also, mark ~amd64
04 May 2005; Jan Brinkmann <luckyduck@gentoo.org>
-win32codecs-20050115.ebuild, win32codecs-20050412.ebuild:
diff --git a/media-libs/win32codecs/Manifest b/media-libs/win32codecs/Manifest
index dea0a86ef0a1..ed3b852b9f2e 100644
--- a/media-libs/win32codecs/Manifest
+++ b/media-libs/win32codecs/Manifest
@@ -1,6 +1,16 @@
-MD5 f18be7c5d9a26b7ec7c317eabb28f239 ChangeLog 4887
-MD5 7300a7b361fa9f48e37722c6952bd432 metadata.xml 158
-MD5 7c114e9145d8eb8cf52c5c5fdf8e4362 win32codecs-20050412.ebuild 991
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 157dbee8428f7c4db32e296a9fc10fba win32codecs-20050216.ebuild 990
+MD5 309e1c9622e472bf8719a97203b5a7fc win32codecs-20050412.ebuild 1243
+MD5 473a150e88f4aea8477274d3f69b1732 ChangeLog 5124
+MD5 7300a7b361fa9f48e37722c6952bd432 metadata.xml 158
MD5 b8645c5758e3393806b7c6095ba11c6c files/digest-win32codecs-20050216 67
MD5 25296a9534a79008c4e54ef0d90f6628 files/digest-win32codecs-20050412 67
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFC/LssomPajV0RnrERAi5PAJwLhpOKoKrC7JLqQKDECUGPsIb3/wCfa6Qh
+UCF67EUm/CLP5ZjaeuGbaio=
+=0r/5
+-----END PGP SIGNATURE-----
diff --git a/media-libs/win32codecs/win32codecs-20050412.ebuild b/media-libs/win32codecs/win32codecs-20050412.ebuild
index 6dbbd2da43ee..0cfbfc5b813c 100644
--- a/media-libs/win32codecs/win32codecs-20050412.ebuild
+++ b/media-libs/win32codecs/win32codecs-20050412.ebuild
@@ -1,29 +1,37 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/win32codecs/win32codecs-20050412.ebuild,v 1.2 2005/05/04 21:20:35 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/win32codecs/win32codecs-20050412.ebuild,v 1.3 2005/08/12 15:06:56 dang Exp $
+inherit multilib
DESCRIPTION="Win32 binary codecs for video and audio playback support"
SRC_URI="http://www1.mplayerhq.hu/MPlayer/releases/codecs/all-${PV}.tar.bz2"
HOMEPAGE="http://www.mplayerhq.hu/"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="-* ~x86"
+KEYWORDS="-* ~amd64 ~x86"
IUSE="quicktime real"
S=${WORKDIR}/all-${PV}
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Daniel Gryniewicz <dang@gentoo.org>
+ has_multilib_profile && ABI="x86"
+}
+
src_install() {
cd ${S}
# see #83221
insopts -m0644
- dodir /usr/lib/win32
+ dodir /usr/$(get_libdir)/win32
if use real
then
- dodir /usr/lib/real
- insinto /usr/lib/real
+ dodir /usr/$(get_libdir)/real
+ insinto /usr/$(get_libdir)/real
doins *so.6.0
# copy newly introduced codecs from realplayer10
@@ -31,10 +39,10 @@ src_install() {
doins *.so
# fix bug #80321
- ln -s ${D}/usr/lib/real/* ${D}/usr/lib/win32/
+ ln -s ${D}/usr/$(get_libdir)/real/* ${D}/usr/$(get_libdir)/win32/
fi
- insinto /usr/lib/win32
+ insinto /usr/$(get_libdir)/win32
if use quicktime
then
doins *.qtx *.qts qtmlClient.dll