summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-30 19:38:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-30 19:38:25 +0000
commit349649262660492ace9b8d73ad1b4da66e9f2424 (patch)
treee49bdd1d55211ccfad194a1fa09500cf5d276cf9 /media-libs/sdl-gfx
parentversion bump, added more docs (bug 30014) (diff)
downloadhistorical-349649262660492ace9b8d73ad1b4da66e9f2424.tar.gz
historical-349649262660492ace9b8d73ad1b4da66e9f2424.tar.bz2
historical-349649262660492ace9b8d73ad1b4da66e9f2424.zip
version bump, added more docs (bug 30014)
Diffstat (limited to 'media-libs/sdl-gfx')
-rw-r--r--media-libs/sdl-gfx/Manifest4
-rw-r--r--media-libs/sdl-gfx/files/digest-sdl-gfx-2.0.81
-rw-r--r--media-libs/sdl-gfx/sdl-gfx-2.0.8.ebuild39
3 files changed, 42 insertions, 2 deletions
diff --git a/media-libs/sdl-gfx/Manifest b/media-libs/sdl-gfx/Manifest
index daa63bf96e7b..a00cb8bd0638 100644
--- a/media-libs/sdl-gfx/Manifest
+++ b/media-libs/sdl-gfx/Manifest
@@ -1,5 +1,5 @@
-MD5 7d63cfb78319983853c60538bf45b635 ChangeLog 1075
+MD5 e652e671b39a801574ffc0796c1921e9 ChangeLog 1228
MD5 093f1c4a6eaa83bccfdcb891d879df2f sdl-gfx-2.0.3.ebuild 821
-MD5 d3844caa3a1c36e28edc33b89f9c9f19 sdl-gfx-2.0.8.ebuild 845
+MD5 58dc3fb1a4ba077e4af7dccac89e524e sdl-gfx-2.0.8.ebuild 885
MD5 7a00e26bd01466e910de637d68c59d75 files/digest-sdl-gfx-2.0.3 65
MD5 b7037798311af68421f018850c1bcbd0 files/digest-sdl-gfx-2.0.8 65
diff --git a/media-libs/sdl-gfx/files/digest-sdl-gfx-2.0.8 b/media-libs/sdl-gfx/files/digest-sdl-gfx-2.0.8
new file mode 100644
index 000000000000..1638814a0892
--- /dev/null
+++ b/media-libs/sdl-gfx/files/digest-sdl-gfx-2.0.8
@@ -0,0 +1 @@
+MD5 5e9e8b24d1f576f247a7560e3df4a7de SDL_gfx-2.0.8.tar.gz 529219
diff --git a/media-libs/sdl-gfx/sdl-gfx-2.0.8.ebuild b/media-libs/sdl-gfx/sdl-gfx-2.0.8.ebuild
new file mode 100644
index 000000000000..84e2f6390f1d
--- /dev/null
+++ b/media-libs/sdl-gfx/sdl-gfx-2.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-gfx/sdl-gfx-2.0.8.ebuild,v 1.1 2003/09/30 19:38:23 mr_bones_ Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/sdl-/SDL_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Graphics drawing primitives library for SDL"
+HOMEPAGE="http://www.ferzkopp.net/Software/SDL_gfx-2.0/"
+SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND=">=media-libs/libsdl-1.2"
+
+filter-flags "-O?" "-O2"
+
+src_compile() {
+ local myconf
+
+ if use ppc || use sparc || use alpha
+ then
+ myconf="--disable-mmx"
+ else
+ use mmx || myconf="--disable-mmx"
+ fi
+
+ econf ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS README
+ dohtml -r Docs/*
+}