summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-10-03 23:42:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-10-03 23:42:49 +0000
commit6108e24acab1eab613749f8fb44992be50f06adf (patch)
treec2da0234a21a2f2c58e433ec18fbb8fc33c96c5f /media-libs/qhull/files/qhull-2010.1-cmake-install.patch
parentold (diff)
downloadhistorical-6108e24acab1eab613749f8fb44992be50f06adf.tar.gz
historical-6108e24acab1eab613749f8fb44992be50f06adf.tar.bz2
historical-6108e24acab1eab613749f8fb44992be50f06adf.zip
Error in previous patch, now installs all qhull headers to allow reverse dependencies to be compatible
Package-Manager: portage-2.2_rc88/cvs/Linux x86_64
Diffstat (limited to 'media-libs/qhull/files/qhull-2010.1-cmake-install.patch')
-rw-r--r--media-libs/qhull/files/qhull-2010.1-cmake-install.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-libs/qhull/files/qhull-2010.1-cmake-install.patch b/media-libs/qhull/files/qhull-2010.1-cmake-install.patch
index 2a110a6ee7e2..9e1914d13d29 100644
--- a/media-libs/qhull/files/qhull-2010.1-cmake-install.patch
+++ b/media-libs/qhull/files/qhull-2010.1-cmake-install.patch
@@ -1,6 +1,6 @@
diff -Nur qhull-2010.1.orig/CMakeLists.txt qhull-2010.1/CMakeLists.txt
---- qhull-2010.1.orig/CMakeLists.txt 2010-01-10 00:07:32.000000000 +0000
-+++ qhull-2010.1/CMakeLists.txt 2010-10-03 22:16:50.000000000 +0100
+--- qhull-2010.1.orig/CMakeLists.txt 2010-10-03 23:04:04.000000000 +0100
++++ qhull-2010.1/CMakeLists.txt 2010-10-03 23:26:54.000000000 +0100
@@ -1,8 +1,44 @@
project(qhull)
-cmake_minimum_required(VERSION 2.4)
@@ -51,8 +51,8 @@ diff -Nur qhull-2010.1.orig/CMakeLists.txt qhull-2010.1/CMakeLists.txt
+install(DIRECTORY html/ DESTINATION ${DOC_INSTALL_DIR})
+endif (WITH_DOCS)
diff -Nur qhull-2010.1.orig/src/CMakeLists.txt qhull-2010.1/src/CMakeLists.txt
---- qhull-2010.1.orig/src/CMakeLists.txt 2010-01-10 00:07:32.000000000 +0000
-+++ qhull-2010.1/src/CMakeLists.txt 2010-10-03 22:21:34.000000000 +0100
+--- qhull-2010.1.orig/src/CMakeLists.txt 2010-10-03 23:04:04.000000000 +0100
++++ qhull-2010.1/src/CMakeLists.txt 2010-10-04 00:23:47.000000000 +0100
@@ -23,8 +23,25 @@
file(GLOB qhull_hdr *.h)
@@ -95,4 +95,4 @@ diff -Nur qhull-2010.1.orig/src/CMakeLists.txt qhull-2010.1/src/CMakeLists.txt
+install(TARGETS qhull qhullcmd rbox qconvex qdelaunay qvoronoi qhalf
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR})
-+install(FILES libqhull.h DESTINATION ${INCLUDE_INSTALL_DIR})
++install(FILES ${qhull_hdr} DESTINATION ${INCLUDE_INSTALL_DIR}/qhull)