summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-16 17:56:29 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-16 17:56:29 +0000
commit480acbf0e593d8077a09b6062823679f3593fa22 (patch)
tree76b3641c518498d532856ace04791e2c22483e32 /media-libs/plotutils
parentchanged accidentally. undid. (diff)
downloadhistorical-480acbf0e593d8077a09b6062823679f3593fa22.tar.gz
historical-480acbf0e593d8077a09b6062823679f3593fa22.tar.bz2
historical-480acbf0e593d8077a09b6062823679f3593fa22.zip
gcc-3.1 compile fixes closes 3359
Diffstat (limited to 'media-libs/plotutils')
-rw-r--r--media-libs/plotutils/ChangeLog8
-rw-r--r--media-libs/plotutils/files/digest-plotutils-2.4.1-r21
-rw-r--r--media-libs/plotutils/plotutils-2.4.1-r2.ebuild94
3 files changed, 102 insertions, 1 deletions
diff --git a/media-libs/plotutils/ChangeLog b/media-libs/plotutils/ChangeLog
index d2af34beba82..41dc651d0f64 100644
--- a/media-libs/plotutils/ChangeLog
+++ b/media-libs/plotutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/plotutils/ChangeLog,v 1.2 2002/04/12 23:53:11 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/plotutils/ChangeLog,v 1.3 2002/06/16 17:56:29 lostlogic Exp $
+
+*plotutils-2.4.1-r2 (16 Jun 2002)
+
+ 16 Jun 2002; Brandon Low <lostlogic@gentoo.org> plotutils-2.4.1-r2.ebuild :
+
+ gcc-3.1 compile fix thanks to Johannes <guj@hrz.tu-chemnitz.de>
*plotutils-2.4.1-r1 (12 Apr 2002)
diff --git a/media-libs/plotutils/files/digest-plotutils-2.4.1-r2 b/media-libs/plotutils/files/digest-plotutils-2.4.1-r2
new file mode 100644
index 000000000000..e75553aa5a39
--- /dev/null
+++ b/media-libs/plotutils/files/digest-plotutils-2.4.1-r2
@@ -0,0 +1 @@
+MD5 8da2cc2ed5a837cad0753c7843ef18ee plotutils-2.4.1.tar.gz 3316030
diff --git a/media-libs/plotutils/plotutils-2.4.1-r2.ebuild b/media-libs/plotutils/plotutils-2.4.1-r2.ebuild
new file mode 100644
index 000000000000..f3690c43f7e2
--- /dev/null
+++ b/media-libs/plotutils/plotutils-2.4.1-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer Tod Neidt <tod@gentoo.org>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+#The plotutils package contains extra X fonts. These fonts are not installed
+#in the current ebuild. The commented out ebuild lines below are for future
+#reference when this ebuild may be updated to install the fonts.
+#NOTE: The current method does not play nice with X and sandbox. Most of the
+#font installation procedures should probably be moved to pkg_postinst.
+#See Bug# 30 at http://bugs.gentoo.org/show_bug.cgi?id=30
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="a powerful C/C++ function library for exporting 2-D vector graphics"
+
+SRC_URI="ftp://ftp.gnu.org/gnu/plotutils/${P}.tar.gz"
+# X? ( ftp://ftp.hp.com/pub/printers/software/mp135mu.exe )
+
+HOMEPAGE="http://www.gnu.org/software/plotutils/"
+
+DEPEND="virtual/glibc
+ media-libs/libpng
+ X? ( virtual/x11 )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/plotutils-2.4.1-gentoo.patch || die
+
+}
+
+src_compile() {
+
+#enable build of C++ version
+ local myconf="--enable-libplotter"
+
+#The following two additional configure options may be of interest
+#to users with specific printers, i.e. HP LaserJets with PCL 5 or HP-GL/2.
+#Not sure if enabling screws the pooch for those without these printers.
+#--enable-ps-fonts-in-pcl --enable-lj-fonts-in-ps
+
+ use X \
+ && myconf="${myconf} --with-x --enable-libxmi" \
+ || myconf="${myconf} --without-x"
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die "Installation Failed"
+
+ dodoc AUTHORS COMPAT COPYING ChangeLog INSTALL INSTALL.fonts INSTALL.pkg \
+ KNOWN_BUGS NEWS ONEWS PROBLEMS README THANKS TODO
+
+}
+
+pkg_postinst() {
+
+ if [ 'use X' ]
+ then
+ einfo ""
+ einfo "*********************************************************"
+ einfo ""
+ einfo "There are extra fonts available in plotutils package."
+ einfo "The current ebuild does not install them for you."
+ einfo "You may want to do so, but you will have to do it"
+ einfo "manually. You are on your own for now."
+ einfo "See /user/share/doc/${P}/INSTALL.fonts"
+ einfo ""
+ einfo "If you manually install the extra fonts and use the"
+ einfo "program xfig, you might want to recompile to take"
+ einfo "advantage of the additional ps fonts."
+ einfo "Also, it is possible to enable ghostscript and possibly"
+ einfo "your printer to use the HP fonts."
+ einfo ""
+ einfo "**********************************************************"
+ einfo ""
+
+ fi
+
+}