summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Reisch <doctomoe@gentoo.org>2002-06-05 09:44:47 +0000
committerOlivier Reisch <doctomoe@gentoo.org>2002-06-05 09:44:47 +0000
commit70c9ebbf82407a73e3b224589d1ba8a4f01eda71 (patch)
tree233ff1faa490f8916ea2de025fcedfbf4b9ca239 /media-gfx/xv
parentbugfixes (diff)
downloadhistorical-70c9ebbf82407a73e3b224589d1ba8a4f01eda71.tar.gz
historical-70c9ebbf82407a73e3b224589d1ba8a4f01eda71.tar.bz2
historical-70c9ebbf82407a73e3b224589d1ba8a4f01eda71.zip
Added a patch to xv-3.10a-r2.ebuild to make it build and link properly on
PPC. This fixes BUG# 3370.
Diffstat (limited to 'media-gfx/xv')
-rw-r--r--media-gfx/xv/ChangeLog11
-rw-r--r--media-gfx/xv/files/xv-3.10a-ppc.patch35
-rw-r--r--media-gfx/xv/xv-3.10a-r2.ebuild7
3 files changed, 51 insertions, 2 deletions
diff --git a/media-gfx/xv/ChangeLog b/media-gfx/xv/ChangeLog
index 68a9ae2af65c..cf5731f32726 100644
--- a/media-gfx/xv/ChangeLog
+++ b/media-gfx/xv/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/xv
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/ChangeLog,v 1.4 2002/04/30 05:47:34 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/ChangeLog,v 1.5 2002/06/05 09:44:46 doctomoe Exp $
+
+*xv-3.10a-r2 (05 Jun 2002)
+
+ 05 Jun 2002; Olivier Reisch <doctomoe@gentoo.org> xv-3.10a-r2.ebuild
+ files/digest-xv-3.10a-r2 :
+
+ Added a patch to the current ebuild that makes the sources build and link
+ fine on PPC. The patch is only applied on PPC, so there should be no
+ changes in code on other platforms. Fixes BUG #3370.
*xv-3.10a-r2 (29 Apr 2002)
diff --git a/media-gfx/xv/files/xv-3.10a-ppc.patch b/media-gfx/xv/files/xv-3.10a-ppc.patch
new file mode 100644
index 000000000000..0c1763988ee5
--- /dev/null
+++ b/media-gfx/xv/files/xv-3.10a-ppc.patch
@@ -0,0 +1,35 @@
+diff -uNr xv-3.10a/Makefile xv-3.10a.n/Makefile
+--- xv-3.10a/Makefile Mon Jan 23 21:20:54 1995
++++ xv-3.10a.n/Makefile Wed Jun 5 11:05:56 2002
+@@ -188,7 +188,7 @@
+ $(NODIRENT) $(VPRINTF) $(TIMERS) $(UNIX) $(BSDTYPES) $(RAND) \
+ $(DXWM) $(MCHN)
+
+-LIBS = -lX11 $(JPEGLIB) $(TIFFLIB) -lm
++LIBS = -L/usr/X11R6/lib -lX11 $(JPEGLIB) $(TIFFLIB) -lm
+
+ OBJS = xv.o xvevent.o xvroot.o xvmisc.o xvimage.o xvcolor.o xvsmooth.o \
+ xv24to8.o xvgif.o xvpm.o xvinfo.o xvctrl.o xvscrl.o xvalg.o \
+diff -uNr xv-3.10a/tiff/Makefile xv-3.10a.n/tiff/Makefile
+--- xv-3.10a/tiff/Makefile Thu Dec 22 23:35:12 1994
++++ xv-3.10a.n/tiff/Makefile Wed Jun 5 11:26:30 2002
+@@ -60,7 +60,6 @@
+
+ ${ALL}: ${OBJS}
+ ${AR} rc libtiff.a $?
+- ${RANLIB} libtiff.a
+
+ ${OBJS}: tiffio.h tiff.h tiffcomp.h tiffiop.h tiffconf.h
+
+diff -uNr xv-3.10a/xv.h xv-3.10a.n/xv.h
+--- xv-3.10a/xv.h Mon Jan 23 21:22:23 1995
++++ xv-3.10a.n/xv.h Wed Jun 5 11:06:18 2002
+@@ -116,7 +116,7 @@
+ # include <errno.h>
+ extern int errno; /* SHOULD be in errno.h, but often isn't */
+ # ifndef __NetBSD__
+- extern char *sys_errlist[]; /* this too... */
++// extern char *sys_errlist[]; /* this too... */
+ # endif
+ #endif
+
diff --git a/media-gfx/xv/xv-3.10a-r2.ebuild b/media-gfx/xv/xv-3.10a-r2.ebuild
index 4106092f090b..8d2cbf936fc2 100644
--- a/media-gfx/xv/xv-3.10a-r2.ebuild
+++ b/media-gfx/xv/xv-3.10a-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Ben Lutgens <lamer@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/xv-3.10a-r2.ebuild,v 1.1 2002/04/30 05:47:34 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/xv-3.10a-r2.ebuild,v 1.2 2002/06/05 09:44:47 doctomoe Exp $
S=${WORKDIR}/${P}
DESCRIPTION="An interactive image manipulation program for X which can
@@ -25,6 +25,11 @@ src_unpack() {
cd ${S}
patch -p1 < ${WORKDIR}/${P}-naz-gentoo.patch || die
)
+ if [ ${ARCH} = "ppc" ]
+ then
+ cd ${S}
+ patch -p1 < ${FILESDIR}/xv-${PV}-ppc.patch || die
+ fi
}
src_compile() {