summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-22 17:46:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-22 17:46:50 +0000
commit7bc1ee895d01f2cc528ca4816f096431272527db (patch)
tree8e5feb5269c2d482b44b009ffe7e0ed321507478 /kde-misc/kanyremote/kanyremote-5.11.ebuild
parentRefactor ebuild to use python functions correctly. Fixes bug #313989 (diff)
downloadhistorical-7bc1ee895d01f2cc528ca4816f096431272527db.tar.gz
historical-7bc1ee895d01f2cc528ca4816f096431272527db.tar.bz2
historical-7bc1ee895d01f2cc528ca4816f096431272527db.zip
Refactor ebuild to use python functions correctly. Fixes bug #312665
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'kde-misc/kanyremote/kanyremote-5.11.ebuild')
-rw-r--r--kde-misc/kanyremote/kanyremote-5.11.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/kde-misc/kanyremote/kanyremote-5.11.ebuild b/kde-misc/kanyremote/kanyremote-5.11.ebuild
index eb3fae93ce4f..4d760425f8b3 100644
--- a/kde-misc/kanyremote/kanyremote-5.11.ebuild
+++ b/kde-misc/kanyremote/kanyremote-5.11.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.11.ebuild,v 1.3 2010/04/19 14:18:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.11.ebuild,v 1.4 2010/04/22 17:46:50 hwoarang Exp $
EAPI="2"
-inherit autotools base
+PYTHON_DEPEND="2"
+inherit autotools python base
DESCRIPTION="KDE frontend to Anyremote"
HOMEPAGE="http://anyremote.sourceforge.net/"
@@ -21,6 +22,10 @@ DEPEND=">=app-mobilephone/anyremote-4.4[bluetooth?]
bluetooth? ( dev-python/pybluez )"
RDEPEND="${DEPEND}"
+pkg_setup () {
+ python_set_active_version 2
+}
+
src_prepare() {
#fix documentation directory wrt bug #316087
sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am