summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-14 05:53:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-14 05:53:06 +0000
commitc28d5eddf887c998fe0d756cafb7033b5e700d22 (patch)
tree8fb29b55b77f002d6d301ff2a697b21d079f4969 /kde-base
parentInitial Import. (diff)
downloadhistorical-c28d5eddf887c998fe0d756cafb7033b5e700d22.tar.gz
historical-c28d5eddf887c998fe0d756cafb7033b5e700d22.tar.bz2
historical-c28d5eddf887c998fe0d756cafb7033b5e700d22.zip
~hppa
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdeartwork/kdeartwork-3.2.0.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/kde-base/kdeartwork/kdeartwork-3.2.0.ebuild b/kde-base/kdeartwork/kdeartwork-3.2.0.ebuild
index 3ec76c7514df..89ae5b21e5ab 100644
--- a/kde-base/kdeartwork/kdeartwork-3.2.0.ebuild
+++ b/kde-base/kdeartwork/kdeartwork-3.2.0.ebuild
@@ -1,14 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-3.2.0.ebuild,v 1.4 2004/02/10 14:28:19 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-3.2.0.ebuild,v 1.5 2004/02/14 05:53:06 vapier Exp $
+
inherit kde-dist
+DESCRIPTION="KDE artwork package"
+
+KEYWORDS="x86 ppc ~sparc ~hppa ~amd64"
IUSE="opengl"
+
DEPEND="opengl? ( virtual/opengl )
~kde-base/kdebase-${PV}"
-DESCRIPTION="KDE artwork package"
-KEYWORDS="x86 ~sparc ~amd64 ppc"
-
-myconf="$myconf --with-dpms"
-use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+src_compile() {
+ myconf="$myconf --with-dpms `use_with opengl gl`"
+ kde_src_compile
+}