summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-05-12 18:26:23 +0000
committerDan Armak <danarmak@gentoo.org>2002-05-12 18:26:23 +0000
commit6f996a310403d3ef5b6f0013cfe216b5e46873a2 (patch)
treeb8735bd0ea7663cacbdc48bc51f3568bfc1c2cfa /kde-base
parentnew kdelibs revision (masked) -closes bug 2118, as well as some other stuff,... (diff)
downloadhistorical-6f996a310403d3ef5b6f0013cfe216b5e46873a2.tar.gz
historical-6f996a310403d3ef5b6f0013cfe216b5e46873a2.tar.bz2
historical-6f996a310403d3ef5b6f0013cfe216b5e46873a2.zip
disabling building with alsa, it just forces people to come up against the bug. print a notice to
match.
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdemultimedia/ChangeLog7
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.0-r1.ebuild10
2 files changed, 11 insertions, 6 deletions
diff --git a/kde-base/kdemultimedia/ChangeLog b/kde-base/kdemultimedia/ChangeLog
index 0d6cd46d37b6..1d9ac0b344f7 100644
--- a/kde-base/kdemultimedia/ChangeLog
+++ b/kde-base/kdemultimedia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdemultimedia
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/ChangeLog,v 1.4 2002/04/30 11:45:11 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/ChangeLog,v 1.5 2002/05/12 18:26:23 danarmak Exp $
+
+ 12 May 2002; Dan Armak <danarmak@gentoo.org> changelog:
+
+ Disabled building with alsa. The kdemm/alsa.9 bug isn't going to disappear soon it seems.
*kdemultimedia-3.0-r1 (30 Apr 2002)
@@ -29,3 +33,4 @@
comments should well explained and written in clean English. The details about
writing correct changelogs are explained in the skel.ChangeLog file which you
can find in the root directory of the portage repository.
+
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.0-r1.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.0-r1.ebuild
index 3472693df8f3..a391ca6e84d6 100644
--- a/kde-base/kdemultimedia/kdemultimedia-3.0-r1.ebuild
+++ b/kde-base/kdemultimedia/kdemultimedia-3.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.0-r1.ebuild,v 1.1 2002/04/30 11:45:11 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.0-r1.ebuild,v 1.2 2002/05/12 18:26:23 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-dist
@@ -11,7 +11,6 @@ newdepend ">=sys-libs/ncurses-5.2
>=media-sound/cdparanoia-3.9.8
>=media-libs/libvorbis-1.0_beta4
>=media-video/xanim-2.80.1
- alsa? ( >=media-libs/alsa-lib-0.5.9 )
nas? ( >=media-libs/nas-1.4.1 )
esd? ( >=media-sound/esound-0.2.22 )
motif? ( >=x11-libs/openmotif-2.1.30 )
@@ -21,13 +20,14 @@ newdepend ">=sys-libs/ncurses-5.2
>=app-cdr/cdrdao-1.1.5
>=media-sound/mpg123-0.59r
tcltk? ( >=dev-lang/tcl-tk.8.0.5-r2 )"
+ #alsa? ( >=media-libs/alsa-lib-0.5.9 )
src_unpack() {
base_src_unpack
cd ${S}
patch -p0 < ${FILESDIR}/${P}-gentoo-timidity.diff
- use alsa && patch -p0 < ${FILESDIR}/${P}-gentoo-alsa.diff
+ #use alsa && patch -p0 < ${FILESDIR}/${P}-gentoo-alsa.diff
kde_sandbox_patch ${S}/kmidi/config
cd ${S}/kmidi/config
@@ -48,14 +48,14 @@ src_compile() {
myinterface="--enable-interface=xaw,ncurses"
myconf="$myconf --enable-xaw --enable-ncurses"
- use alsa && myconf="$myconf --with-alsa" && myaudio="$myaudio,alsa" || myconf="$myconf --disable-alsa"
+ #use alsa && myconf="$myconf --with-alsa --with-arts-alsa" && myaudio="$myaudio,alsa"|| myconf="$myconf --without-alsa --disable-alsa"
+
use nas && myaudio="$myaudio,nas" || myconf="$myconf --disable-nas"
use esd && myaudio="$myaudio,esd" || myconf="$myconf --disable-esd"
use motif && myinterface="$myinterface,motif" && myconf="$myconf --enable-motif"
use gtk && myinterface="$myinterface,gtk" && myconf="$myconf --enable-gtk"
use slang && myinterface="$myinterface,slang" && myconf="$myconf --enable-slang"
use tcltk && myinterface="$myinterface,tcltk" && myconf="$myconf --enable-tcltk"
- #myconf="$myconf --disable-tcltk"
myconf="$myconf $myaudio $myinterface"