summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit89e71ef45253e6d197ba528112eeae6984651626 (patch)
tree043bfec14e51381244a2ec0e91acb3879eae0a5c /kde-base/step
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadhistorical-89e71ef45253e6d197ba528112eeae6984651626.tar.gz
historical-89e71ef45253e6d197ba528112eeae6984651626.tar.bz2
historical-89e71ef45253e6d197ba528112eeae6984651626.zip
[kde-base] KDE SC 4.7.2
Package-Manager: portage-2.2.0_alpha61/cvs/Linux x86_64
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.7.2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index cb3f1bbe64b9..388653b4cce3 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.84 2011/09/07 20:13:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.85 2011/10/06 18:10:58 alexxy Exp $
+
+*step-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +step-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*step-4.7.1 (07 Sep 2011)
diff --git a/kde-base/step/step-4.7.2.ebuild b/kde-base/step/step-4.7.2.ebuild
new file mode 100644
index 000000000000..ce10b16363b0
--- /dev/null
+++ b/kde-base/step/step-4.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.7.2.ebuild,v 1.1 2011/10/06 18:10:58 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+ kde4-base_src_configure
+}