summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commit171699a002ecd434bf376ad233dbe24d18eb2eb6 (patch)
tree6f899a3828a1e37ab8065f27a01b95c12cdc03e0 /kde-base/smokeqt
parentbump to the TeX Live 2011 version (diff)
downloadhistorical-171699a002ecd434bf376ad233dbe24d18eb2eb6.tar.gz
historical-171699a002ecd434bf376ad233dbe24d18eb2eb6.tar.bz2
historical-171699a002ecd434bf376ad233dbe24d18eb2eb6.zip
[kde-base] Version bump KDE SC 4.7.0
Package-Manager: portage-2.2.0_alpha47/cvs/Linux x86_64
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog10
-rw-r--r--kde-base/smokeqt/metadata.xml15
-rw-r--r--kde-base/smokeqt/smokeqt-4.7.0.ebuild57
3 files changed, 82 insertions, 0 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
new file mode 100644
index 000000000000..707b09bcfa5b
--- /dev/null
+++ b/kde-base/smokeqt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for kde-base/smokeqt
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.1 2011/07/27 14:04:29 alexxy Exp $
+
+*smokeqt-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +smokeqt-4.7.0.ebuild,
+ +metadata.xml:
+ Version bump KDE SC 4.7.0
+
diff --git a/kde-base/smokeqt/metadata.xml b/kde-base/smokeqt/metadata.xml
new file mode 100644
index 000000000000..5d483eb286f4
--- /dev/null
+++ b/kde-base/smokeqt/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<use>
+ <flag name="declarative">Compile bindings for <pkg>x11-libs/qt-declarative</pkg>.</flag>
+ <flag name="multimedia">Compile bindings for <pkg>x11-libs/qt-multimedia</pkg>.</flag>
+ <flag name="phonon">Compile bindings for Phonon.</flag>
+ <flag name="qimageblitz">Compile bindings for <pkg>media-libs/qimageblitz</pkg>.</flag>
+ <flag name="qscintilla">Compile bindings for <pkg>x11-libs/qscintilla</pkg>.</flag>
+ <flag name="qthelp">Compile bindings for QtHelp from <pkg>x11-libs/qt-assistant</pkg>.</flag>
+ <flag name="qwt">Compile bindings for <pkg>x11-libs/qwt</pkg>.</flag>
+ <flag name="webkit">Compile bindings for <pkg>x11-libs/qt-webkit</pkg>.</flag>
+</use>
+</pkgmetadata>
diff --git a/kde-base/smokeqt/smokeqt-4.7.0.ebuild b/kde-base/smokeqt/smokeqt-4.7.0.ebuild
new file mode 100644
index 000000000000..96276d80c9e6
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.7.0.ebuild,v 1.1 2011/07/27 14:04:29 alexxy Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+KDE_SCM="git"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-test:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+ webkit? ( x11-libs/qt-webkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+# Split in 4.7
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}