summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-10-02 18:12:30 +0000
committerJohannes Huber <johu@gentoo.org>2012-10-02 18:12:30 +0000
commite24d1892c460e245f1dd758fe478f50e1365610d (patch)
treecdfa55b52059355077e16df18b81627a78ffa553 /kde-base/qyoto
parentUpdate dev channel mask for beta release of chromium-23. (diff)
downloadhistorical-e24d1892c460e245f1dd758fe478f50e1365610d.tar.gz
historical-e24d1892c460e245f1dd758fe478f50e1365610d.tar.bz2
historical-e24d1892c460e245f1dd758fe478f50e1365610d.zip
Version bump KDE SC 4.9.2
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.9.2.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index f40cb1a0f8c9..ec048753c9e5 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.39 2012/09/21 09:32:54 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.40 2012/10/02 18:11:49 johu Exp $
+
+*qyoto-4.9.2 (02 Oct 2012)
+
+ 02 Oct 2012; Johannes Huber <johu@gentoo.org> +qyoto-4.9.2.ebuild:
+ Version bump KDE SC 4.9.2
21 Sep 2012; Johannes Huber <johu@gentoo.org> -qyoto-4.9.0.ebuild:
Remove KDE SC 4.9.0
diff --git a/kde-base/qyoto/qyoto-4.9.2.ebuild b/kde-base/qyoto/qyoto-4.9.2.ebuild
new file mode 100644
index 000000000000..a889af34089e
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.9.2.ebuild,v 1.1 2012/10/02 18:11:49 johu Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}