summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-11-02 22:15:40 +0000
committerAlex Alexander <wired@gentoo.org>2009-11-02 22:15:40 +0000
commit2949ed61ac331b42c84eab992aba8a8aa245811c (patch)
treeb8dc20afdeb0bb71b28d488e020b2d45cf5f25a6 /kde-base/kopete
parentRemoving 0.1.0 ebuild (diff)
downloadhistorical-2949ed61ac331b42c84eab992aba8a8aa245811c.tar.gz
historical-2949ed61ac331b42c84eab992aba8a8aa245811c.tar.bz2
historical-2949ed61ac331b42c84eab992aba8a8aa245811c.zip
Version bump KDE 4.3.3
Package-Manager: portage-2.2_rc48/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog7
-rw-r--r--kde-base/kopete/kopete-4.3.3.ebuild133
2 files changed, 139 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 66784ced5634..89738bd9ca04 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.221 2009/11/01 07:37:02 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.222 2009/11/02 21:33:28 wired Exp $
+
+*kopete-4.3.3 (02 Nov 2009)
+
+ 02 Nov 2009; Alex Alexander <wired@gentoo.org> +kopete-4.3.3.ebuild:
+ Version bump
01 Nov 2009; Jonathan Callen <abcd@gentoo.org> -kopete-4.2.4.ebuild:
Drop old revision
diff --git a/kde-base/kopete/kopete-4.3.3.ebuild b/kde-base/kopete/kopete-4.3.3.ebuild
new file mode 100644
index 000000000000..0e2db9d0fb16
--- /dev/null
+++ b/kde-base/kopete/kopete-4.3.3.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.3.3.ebuild,v 1.1 2009/11/02 21:33:28 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdenetwork"
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook ssl v4l2"
+
+# tests hang, last checked for 4.2.96
+RESTRICT=test
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# bonjour: NO DEPS
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# jabber: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# msn: libmsn == this is wlm plugin, we disable msn one
+# oscar: NO DEPS
+# qq: NO DEPS
+# sms: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS
+# yahoo: NO DEPS
+PROTOCOLS="bonjour facebook gadu groupwise +jabber meanwhile msn oscar qq
+skype testbed winpopup yahoo"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ dev-libs/libpcre
+ $(add_kdebase_dep kdepimlibs)
+ x11-libs/libXScrnSaver
+ >=x11-libs/qt-gui-4.4.0:4[mng]
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? (
+ app-crypt/qca:2
+ net-dns/libidn
+ )
+ meanwhile? ( net-libs/meanwhile )
+ msn? ( net-libs/libmsn )
+ otr? ( >=net-libs/libotr-3.2.0 )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )
+ v4l2? ( media-libs/libv4l )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ media-gfx/imagemagick
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca-ossl )
+"
+# telepathy? ( net-libs/decibel )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/scrnsaverproto
+"
+PDEPEND="
+ facebook? ( net-im/kopete-facebook )
+"
+
+src_configure() {
+ local x x2
+ # Disable old msn support.
+ mycmakeargs="${mycmakeargs} -DWITH_msn=OFF"
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ [[ ${x/+/} = msn ]] && x2=wlm || x2=""
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/} ${x2})"
+ done
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ done
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ #if use telepathy; then
+ # elog "To use kopete telepathy plugins, you need to start gabble first:"
+ # elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ # elog "export TELEPATHY_DATA_PATH=/usr/share/telepathy/managers/"
+ #fi
+
+ if ! use ssl; then
+ if use jabber || use msn; then # || use irc; then
+ echo
+ elog "In order to use ssl in jabber, msn and irc you'll need to"
+ elog "install app-crypt/qca-ossl package."
+ echo
+ fi
+ fi
+}