summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
commit351f7dda3f62817dd3747226a48fb58b92f8e510 (patch)
treed44f25d056ad34656ac0a5ac45ee7fa316af0df4 /kde-base/kimono
parentAdd 3.0 documentation (diff)
downloadhistorical-351f7dda3f62817dd3747226a48fb58b92f8e510.tar.gz
historical-351f7dda3f62817dd3747226a48fb58b92f8e510.tar.bz2
historical-351f7dda3f62817dd3747226a48fb58b92f8e510.zip
[kde-base] Add long waiting KDE SC 4.7.4
Package-Manager: portage-2.2.0_alpha79/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kimono')
-rw-r--r--kde-base/kimono/ChangeLog7
-rw-r--r--kde-base/kimono/kimono-4.7.4.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kimono/ChangeLog b/kde-base/kimono/ChangeLog
index 78f7e0867b70..e820f5b3c282 100644
--- a/kde-base/kimono/ChangeLog
+++ b/kde-base/kimono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kimono
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.10 2011/12/07 23:07:43 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.11 2011/12/11 18:52:18 alexxy Exp $
+
+*kimono-4.7.4 (11 Dec 2011)
+
+ 11 Dec 2011; Alexey Shvetsov <alexxy@gentoo.org> +kimono-4.7.4.ebuild:
+ Version bump KDE SC 4.7.4
07 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org> -kimono-4.7.2.ebuild:
Drop KDE 4.7.2
diff --git a/kde-base/kimono/kimono-4.7.4.ebuild b/kde-base/kimono/kimono-4.7.4.ebuild
new file mode 100644
index 000000000000..8ed6c786c286
--- /dev/null
+++ b/kde-base/kimono/kimono-4.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.7.4.ebuild,v 1.1 2011/12/11 18:52:18 alexxy Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for KDE"
+KEYWORDS="~amd64 ~x86"
+IUSE="akonadi debug plasma semantic-desktop"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep qyoto 'webkit')
+ $(add_kdebase_dep smokeqt)
+ $(add_kdebase_dep smokekde 'akonadi?,semantic-desktop=')
+ plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
+ semantic-desktop? ( >=dev-libs/soprano-2.6.51[clucene] )
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+ kde4-base_src_configure
+}