summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit89e71ef45253e6d197ba528112eeae6984651626 (patch)
tree043bfec14e51381244a2ec0e91acb3879eae0a5c /kde-base/kdepim-common-libs
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadhistorical-89e71ef45253e6d197ba528112eeae6984651626.tar.gz
historical-89e71ef45253e6d197ba528112eeae6984651626.tar.bz2
historical-89e71ef45253e6d197ba528112eeae6984651626.zip
[kde-base] KDE SC 4.7.2
Package-Manager: portage-2.2.0_alpha61/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kdepim-common-libs')
-rw-r--r--kde-base/kdepim-common-libs/ChangeLog8
-rw-r--r--kde-base/kdepim-common-libs/kdepim-common-libs-4.7.2.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/kde-base/kdepim-common-libs/ChangeLog b/kde-base/kdepim-common-libs/ChangeLog
index 5ab87297a854..e20c2e0f5406 100644
--- a/kde-base/kdepim-common-libs/ChangeLog
+++ b/kde-base/kdepim-common-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-common-libs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.7 2011/09/07 20:14:00 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.8 2011/10/06 18:11:03 alexxy Exp $
+
+*kdepim-common-libs-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdepim-common-libs-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*kdepim-common-libs-4.7.1 (07 Sep 2011)
diff --git a/kde-base/kdepim-common-libs/kdepim-common-libs-4.7.2.ebuild b/kde-base/kdepim-common-libs/kdepim-common-libs-4.7.2.ebuild
new file mode 100644
index 000000000000..a243348fb4a0
--- /dev/null
+++ b/kde-base/kdepim-common-libs/kdepim-common-libs-4.7.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/kdepim-common-libs-4.7.2.ebuild,v 1.1 2011/10/06 18:11:03 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kdepim"
+KMNOMODULE="true"
+KDE_SCM="git"
+inherit kde4-meta
+
+DESCRIPTION="Common libraries for KDE PIM apps"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ >=app-office/akonadi-server-1.3.60
+ >=dev-libs/shared-desktop-ontologies-0.6.50
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+# @Since >4.4.76 merged here
+add_blocker akonadi
+add_blocker libkdepim
+add_blocker libkleo
+add_blocker libkpgp
+add_blocker kaddressbook '<4.4.90'
+add_blocker kmail '<4.4.80'
+add_blocker korganizer '<4.5.67'
+
+KMEXTRA="
+ akonadi_next/
+ calendarsupport/
+ calendarviews/
+ incidenceeditor-ng/
+ libkdepim/
+ libkdepimdbusinterfaces/
+ libkleo/
+ libkpgp/
+ kdgantt2/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ nepomuk_email_feeder/
+ ontologies/
+ templateparser/
+"
+
+KMEXTRACTONLY="
+ kleopatra/
+ kmail/
+ knode/org.kde.knode.xml
+ korganizer/korgac/org.kde.korganizer.KOrgac.xml
+ korganizer/org.kde.korganizer.Korganizer.xml
+"
+
+KMSAVELIBS="true"