summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-16 18:28:11 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-16 18:28:11 +0000
commit4ec051eb8fa98a57fb7a000e190c80625bc46b6a (patch)
treec9fe34dcaac3e6f0fa95c8309b824c1368120794 /kde-base/kdepim-common-libs/kdepim-common-libs-4.13.0.ebuild
parentversion bump (diff)
downloadhistorical-4ec051eb8fa98a57fb7a000e190c80625bc46b6a.tar.gz
historical-4ec051eb8fa98a57fb7a000e190c80625bc46b6a.tar.bz2
historical-4ec051eb8fa98a57fb7a000e190c80625bc46b6a.zip
Version bump KDE SC 4.13.0
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0xF3CFD2BD
Diffstat (limited to 'kde-base/kdepim-common-libs/kdepim-common-libs-4.13.0.ebuild')
-rw-r--r--kde-base/kdepim-common-libs/kdepim-common-libs-4.13.0.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/kde-base/kdepim-common-libs/kdepim-common-libs-4.13.0.ebuild b/kde-base/kdepim-common-libs/kdepim-common-libs-4.13.0.ebuild
new file mode 100644
index 000000000000..2bc531a7a61f
--- /dev/null
+++ b/kde-base/kdepim-common-libs/kdepim-common-libs-4.13.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/kdepim-common-libs-4.13.0.ebuild,v 1.1 2014/04/16 18:26:26 johu Exp $
+
+EAPI=5
+
+KMNAME="kdepim"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Common libraries for KDE PIM apps"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ >=app-office/akonadi-server-1.12.1
+ dev-libs/grantlee
+ $(add_kdebase_dep baloo)
+ $(add_kdebase_dep kdepimlibs)
+"
+RDEPEND="${DEPEND}
+ !kde-base/akonadi:4
+ !kde-base/libkdepim:4
+ !kde-base/libkleo:4
+ !kde-base/libkpgp:4
+ !<kde-base/kaddressbook-4.11.50:4
+ !kde-base/kdepim-wizards:4
+ !<kde-base/kmail-4.4.80:4
+ !=kde-base/kmail-4.12.0
+ !=kde-base/kmail-4.12.1
+ !=kde-base/kmail-4.11*
+ !<kde-base/korganizer-4.5.67:4
+ app-crypt/gnupg
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+RESTRICT="test"
+# bug 393131
+
+KMEXTRA="
+ agents/followupreminderagent/
+ agents/sendlateragent/
+ akonadi_next/
+ calendarsupport/
+ calendarviews/
+ composereditor-ng/
+ grantleetheme/
+ kaddressbookgrantlee/
+ incidenceeditor-ng/
+ libkdepim/
+ libkdepimdbusinterfaces/
+ libkleo/
+ libkpgp/
+ kdgantt2/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ noteshared/
+ pimcommon/
+ templateparser/
+"
+KMEXTRACTONLY="
+ kleopatra/
+ kmail/
+ knode/org.kde.knode.xml
+ korgac/org.kde.korganizer.KOrgac.xml
+ korganizer/org.kde.korganizer.Korganizer.xml
+ mailcommon/
+"
+KMSAVELIBS="true"
+
+PATCHES=( "${FILESDIR}/install-composereditorng.patch" )
+
+src_prepare() {
+ kde4-meta_src_prepare
+ sed -e '/folderarchiveagent.desktop/d' \
+ -i agents/CMakeLists.txt || die
+}